Project

General

Profile

Bug #16124

URLs without explicit .html are not redirected anymore

Added by sajolida 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
11/13/2018
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

To reproduce:

This is a regression, probably coming from self-hosting our website, and it's affecting the donation campaign (and probably other things), so marking as "High".

funky-download.png View (166 KB) sajolida, 11/13/2018 08:21 PM


Related issues

Related to Tails - Feature #14588: Self-host our website Resolved 10/03/2018
Related to Tails - Bug #16220: Website's "add trailing slash" trick is partly broken Resolved 12/11/2018
Duplicated by Tails - Bug #16127: Website install/ broken Duplicate 11/14/2018
Blocks Tails - Feature #13284: Core work: Sysadmin (Adapt our infrastructure) Confirmed 06/30/2017

History

#1 Updated by sajolida 6 months ago

I spotted this while release Tails Verification 1.2. It give a funky look to https://tails.boum.org/install/download. See attachment :)

#2 Updated by u 6 months ago

  • Related to Bug #16127: Website install/ broken added

#3 Updated by u 6 months ago

  • Related to deleted (Bug #16127: Website install/ broken)

#4 Updated by u 6 months ago

  • Duplicated by Bug #16127: Website install/ broken added

#5 Updated by u 6 months ago

Also see #16127: /install has the same issue.

But there are also other problems, like some CSS files are not found (assistant.css results in a 404). That's why the page looks funky.

#6 Updated by u 6 months ago

I've sent a mail to sysadmins this morning already, and now told them about this bug, so that they can find more info about the issue. I think intrigeri is not available today btw.

#7 Updated by groente 6 months ago

i'm seeing gateway timeouts on the ping command:

- [14/Nov/2018:18:52:06 +0000] "GET /ikiwiki.cgi?do=ping HTTP/1.1" 504 183 "-" "curl/7.52.1"

that's likely to be related

#8 Updated by intrigeri 6 months ago

  • Priority changed from High to Urgent
  • Target version set to Tails_3.11

#9 Updated by groente 6 months ago

set the timeout higher, and indeed the ping command was taking longer than the old limit, but manages to finish now.

#10 Updated by groente 6 months ago

https://tails.boum.org/install/download/ renders fine, whereas https://tails.boum.org/install/download does not, something about the trailing slash is a bit fucky..

#11 Updated by groente 6 months ago

  • Assignee changed from intrigeri to sajolida
  • QA Check set to Ready for QA

added a rewrite to force trailing slashes in the nginx config, i believe the problem is now fixed, can you confirm?

#12 Updated by intrigeri 6 months ago

sajolida wrote:

because they point 1 parent level too high (eg. https://tails.boum.org/donate.js instead of https://tails.boum.org/donate/donate.js).

Given:

$ ls wiki/src/donate*.js   
wiki/src/donate-banner.js  wiki/src/donate.js

I don't understand why you would expect links to point to https://tails.boum.org/donate/donate.js and still work, but whatever, I trust y'all there's a bug and I'm on it: will check if groente's fix is OK.

#13 Updated by intrigeri 6 months ago

  • Assignee changed from sajolida to intrigeri

#14 Updated by intrigeri 6 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to groente
  • % Done changed from 0 to 50

Cleaned up the regexp as discussed over XMPP, the fix still seems to work. Please review :)

#15 Updated by intrigeri 6 months ago

#16 Updated by intrigeri 6 months ago

  • Blocks Feature #13284: Core work: Sysadmin (Adapt our infrastructure) added

#17 Updated by groente 6 months ago

  • Assignee changed from groente to intrigeri
  • QA Check changed from Ready for QA to Pass

yep, that should do the trick aswell!

#18 Updated by intrigeri 6 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100

#19 Updated by intrigeri 6 months ago

  • Related to Bug #16220: Website's "add trailing slash" trick is partly broken added

Also available in: Atom PDF