Project

General

Profile

Bug #16123

Test suite broken on Jenkins since we self-host our website

Added by intrigeri 8 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
11/13/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

I suspect chutney on isotesters cannot connect to www.lizard, or similar.


Related issues

Related to Tails - Feature #14588: Self-host our website Resolved 10/03/2018

History

#1 Updated by intrigeri 8 months ago

#2 Updated by intrigeri 8 months ago

I came back online briefly from my week-"end" to take a look in the hope I could find a quick fix.

First, the timing is unfortunate: the DNS switch for #14588 happened very close to the Stretch 9.6 point release, which makes this problem a bit harder to diagnose.

I've verified that an isotester can successfully curl https://tails.boum.org/ so I don't think lizard's DNS/network/firewall changes I made for #14588 are the explanation. And Tails 3.10.1 running in a VM on my system successfully checks for upgrades so it's not a web server misconfiguration (or configuration mismatch with Tails::Download::HTTPS, which I initially suspected — #11815). So I'm starting to suspect a regression brought by the Stretch point release, e.g. via the tor 0.2.9.15-1 → 0.2.9.16-1 upgrade; but the Chutney nodes' logs look fine.

No quick fix from me today then. I'll deal with this first thing when I'm back from my week-"end" on Wed or Thu.

#3 Updated by intrigeri 7 months ago

Seems to be fixed, go figure: https://jenkins.tails.boum.org/view/RM/job/test_Tails_ISO_stable/1536/. I'll check how the other jobs fare.

#4 Updated by intrigeri 7 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100

Given the timing, I suspect the QEMU update (and the corresponding restart of libvirtd + shorewall) fixed that. But I'm afraid I don't understand what broke things and now that it's repaired, I cannot investigate anymore.

Also available in: Atom PDF