Project

General

Profile

Bug #16119

Drop jQuery in Tails verification extension

Added by Anonymous over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
11/11/2018
Due date:
% Done:

0%

Feature Branch:
verification-extension:usbimage
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Verification Extension

Description

Everything that is done with jquery can be done in vanillaJS. I did not do that yet, but ideally, we'd do it at some point on some kind of budget line that we have outside of this grant. What


Related issues

Related to Tails - Bug #15995: Have Tails Verification handle IDFs with several Tails installation paths (ISO/IMG) Resolved 09/28/2018

History

#1 Updated by Anonymous over 1 year ago

  • Related to Bug #15995: Have Tails Verification handle IDFs with several Tails installation paths (ISO/IMG) added

#2 Updated by intrigeri over 1 year ago

Everything that is done with jquery can be done in vanillaJS.

May I ask what would be the benefit of doing this migration work? (JS newbie here :)

#3 Updated by Anonymous over 1 year ago

The benefit of this is to ship one less library.

i.e.:

- extension will be lighter (in bytes)
- extension will be faster: because this code does not need to be injected in the user's browser and we would rely on browser built-in JS
- we don't have to update the library in the extension regularly: less maintenance work for us

I think there is clearly a benefit and it would require ~1 hour of work to make that happen.

#4 Updated by intrigeri over 1 year ago

The benefit of this is to ship one less library. i.e.:

Thanks for educating me! I'm convinced :)

#5 Updated by Anonymous about 1 year ago

  • Status changed from Confirmed to 11
  • Feature Branch set to verification-extension:usbimage

I've done this in #15995.

#6 Updated by Anonymous about 1 year ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF