Project

General

Profile

Bug #16110

Feature #14568: Additional Software Packages

Button to remove package in ASP GUI has a wrong label

Added by bertagaz 11 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Accessibility
Target version:
Start date:
11/08/2018
Due date:
% Done:

100%

Feature Branch:
bugfix/16110-asp-remove-button-label
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

While finishing the test suite for ASP, we noticed in #14596#note-54 that for screen readers and accessibility technologies, the "x" button in ASP GUI to remove a package from the list is labeled "close", which does not fit with the design.


Related issues

Related to Tails - Bug #15838: Fix non-blocking issues identified during ASP code review Resolved 09/26/2018
Blocked by Tails - Bug #16226: Most branches FTBFS on Jenkins since the 3.11 release Resolved 12/15/2018

Associated revisions

Revision ec888112 (diff)
Added by alant 10 months ago

ASP configutation: set accessible name of remove button

Will-fix: #16110

Revision 3f1f1b0e (diff)
Added by intrigeri 7 months ago

Test suite: update button label to match fixed implementation (refs: #14596, #16110)

Revision 4ecaedba
Added by intrigeri 7 months ago

Merge remote-tracking branch 'origin/bugfix/16110-asp-remove-button-label' into stable (Fix-committed: #16110)

History

#1 Updated by bertagaz 11 months ago

  • Related to Bug #15838: Fix non-blocking issues identified during ASP code review added

#2 Updated by alant 10 months ago

  • Category set to Accessibility
  • Status changed from Confirmed to In Progress
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/16110-asp-remove-button-label

#3 Updated by intrigeri 10 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

Too late for 3.11.

#4 Updated by alant 10 months ago

  • Blocked by Bug #16226: Most branches FTBFS on Jenkins since the 3.11 release added

#5 Updated by alant 9 months ago

  • Assignee changed from alant to segfault

Feel free to assign to someone else to review if you can't.

#6 Updated by segfault 9 months ago

  • Assignee changed from segfault to alant
  • QA Check changed from Ready for QA to Pass

Code review passes. I don't think it's worth the time to test this again if you already tested it.

#7 Updated by anonym 9 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#8 Updated by alant 7 months ago

  • Assignee changed from alant to anonym

#9 Updated by intrigeri 7 months ago

  • Assignee changed from anonym to intrigeri

I guess this will require updating the test suite accordingly. Given I'll work on this part of the test suite soon, I can as well take this one.

#10 Updated by intrigeri 7 months ago

  • Assignee changed from intrigeri to anonym

#11 Updated by anonym 7 months ago

  • Assignee changed from anonym to intrigeri

#12 Updated by intrigeri 7 months ago

  • Subject changed from Improve ASP code: button to remove package in ASP GUI has a wrong label to Button to remove package in ASP GUI has a wrong label

#13 Updated by intrigeri 7 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 0 to 100

#14 Updated by intrigeri 7 months ago

  • Status changed from Fix committed to In Progress

#15 Updated by intrigeri 7 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)

Merged and updated the test suite on the #14596 branch.

#16 Updated by CyrilBrulebois 7 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF