Project

General

Profile

Bug #16101

Bug #16336: Check which packages we still need to patch on Buster

Build our custom Thunderbird package for Buster

Added by CyrilBrulebois 11 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/05/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

With our ongoing upstreaming efforts, it is possible that we might not need to build/ship/maintain a custom Thunderbird in the future.

To get the feature/buster ball rolling, we're switching to the thunderbird package from sid temporarily; until we figure out what to do on the long run.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

History

#1 Updated by mercedes508 11 months ago

  • Status changed from New to Confirmed

#2 Updated by CyrilBrulebois 11 months ago

There seems to be some concurrency here, with hefee and I working on feature/buster and making a note about our switch back to sid's thunderbird; while anonym had already filed https://labs.riseup.net/code/issues/15788 (that I failed to spot before filing this bug report, my bad).

See latest development → https://labs.riseup.net/code/issues/15788#note-9

TL;DR: We'll need a custom TB anyway: patches are needed; and even upstreamed, they would need to be published in some ESR release anyway.

#3 Updated by intrigeri 9 months ago

  • Subject changed from Check whether a custom Thunderbird is needed for Buster to Build our custom Thunderbird package for Buster

Let's do this once we're closer to releasing 4.0~beta1, but not too close to that: we'll want our test suite to exercise the right package and spot any regression soon enough :)

#4 Updated by anonym 6 months ago

  • Parent task set to #16336

#5 Updated by anonym 6 months ago

  • Status changed from Confirmed to In Progress
  • Assignee set to anonym
  • % Done changed from 0 to 40
  • Affected tool set to Email Client

I am currently slowly uploading patched packages (60.6.1-1.0tails1). I thought this would completely fix Thunderbird on buster so we could get some test suite results, but we are affected by #16573 so account config is completely broken.

#6 Updated by intrigeri 6 months ago

#7 Updated by anonym 5 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (anonym)
  • % Done changed from 40 to 100

The upload was finished during the sprint. And buster will only be affected by #16573 until devel is merged into it.

Also available in: Atom PDF