Project

General

Profile

Feature #16094

Have simplified and traditional Chinese in the list of languages in Tails Greeter

Added by sajolida about 1 year ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Internationalization
Target version:
-
Start date:
11/04/2018
Due date:
% Done:

100%

Feature Branch:
https://salsa.debian.org/tails-team/tails/merge_requests/39/commits
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:
Greeter

Description

Right now we have instead:

  • Chinese, Singapore (language name untranslated)
  • Chinese, China
  • Chinese, Taiwan
  • Chinese, Hong Kong

Which correspond to spoken local dialects but lack information about the writing script, either simplified or traditional.

Simplified Chinese was invented in mainland China and consist in a simplification of the writing of traditional Chinese (independently from how it is spoken).

  • People with basic literacy in mainland China are not able to read the more complex traditional Chinese characters.
  • People in Taiwan are not taught simplified Chinese in school and are not using it in their daily life on the island.

Someone from Taiwan told me that, instead of the 4 options that we currently have, we should instead have 2:

  • 1 for simplified Chinese
  • 1 for traditional Chinese

Which are different scripts for the same Chinese (Mandarin) language.

They should be written under the category "中文" (we currently have a different name for our Chinese category).

Update: here's the design intrigeri and sajolida agreed on:

  • Chinese (simplified)
    • Chinese (simplified, China)
    • Chinese (simplified, Singapore)
  • Chinese (traditional)
    • Chinese (traditional, Hong Kong)
    • Chinese (traditional, Taiwan)

windows-10-download.png View (34.1 KB) sajolida, 03/21/2019 03:39 PM


Related issues

Related to Tails - Feature #14544: Spend software developer time on smallish UX improvements In Progress 08/31/2018
Related to Tails - Bug #16093: Remove untranslated Chinese languages from Tails Greeter Resolved 11/04/2018
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed
Blocked by Tails - Feature #16095: Curate the list of languages in Tails Greeter Resolved 11/04/2018

Associated revisions

Revision f7b6c690 (diff)
Added by segfault about 2 months ago

Separate Chinese into simplified and traditional Chinese (refs: #16094)

Revision 53c6c19a
Added by intrigeri about 2 months ago

Merge branch 'feature/17098-refactor-greeter' into devel (Closes: #17098, #17089, #16806, #13447, #17087, #17058, #17101, #6525, #16095, #16094, #16093)

History

#1 Updated by sajolida about 1 year ago

  • Related to Feature #14544: Spend software developer time on smallish UX improvements added

#2 Updated by sajolida about 1 year ago

  • Related to Bug #16093: Remove untranslated Chinese languages from Tails Greeter added

#3 Updated by intrigeri 8 months ago

One question, first, that might help assessing the priority of this ticket: isn't the name of these languages, in the Greeter, displayed using the preferred script for the corresponding locale? It seems to me that "Chinese - China" is displayed as "汉语" (which is simplified Chinese for "the Chinese language"). And I see that "Chinese - Taiwan" is displayed differently, presumably in traditional Chinese. I would hope this helps users pick simplified vs. traditional, even if we don't spell out "this is simplified Chinese" vs. "this is traditional Chinese": the mere fact the language name is written in a given script suggests which script will be used to display the desktop if one selects that language, no?

Someone from Taiwan told me that, instead of the 4 options that we currently have, we should instead have 2:

  • 1 for simplified Chinese
  • 1 for traditional Chinese

The problem with this proposal is that our "language" option maps to a locale = a language and a territory. So what locale would each of this option map to? I'm concerned that any choice we make — e.g. we could map simplified Chinese to zh_CN and traditional Chinese to zh_TW — has the potential to make a subset of the affected users unhappy. Not providing options for Hong Kong and Singapore is perhaps sensitive. Now, even if they used the same script, I don't know how much of a noticeable difference it makes to run the Desktop in, say, zh_HK compared to zh_CN. If it's not noticeable, I guess most users won't care. If it's noticeable, we might open a deep can of worms. Maybe I'm overly scared.

They should be written under the category "中文" (we currently have a different name for our Chinese category).

The two options are like this:

I can think of good arguments in favour of either of those and I have no strong preference.

Be it wrt. the language (= language + territory) or the category title, given the sensitive political context, acting based upon the suggestion of one single individual, who's from one of the parties in conflict, feels a bit tricky. So I suggest we do the same as more popular IT systems, e.g. Android or Windows.

#4 Updated by sajolida 8 months ago

Isn't the name of these languages, in the Greeter, displayed using the preferred script for the corresponding locale?

That's my understanding as well.

Note that both scripts (eg. China and Taiwan) are under the same
foldable section (Chinese) which is displayed in simplified Chinese.

If someone can only read traditional Chinese, they might not find Taiwan
in the Chinese submenu.

Also note that my Taiwanese user was coming back from trying "Chinese,
mandarin" (without any Chinese script, #16093) way up the language list,
so maybe his reaction was influenced by this first bad experience :)

So I suggest we do the same as more popular IT systems, e.g. Android or Windows.

Here is what Windows does:

  • When configuring the language of Windows 7, you get more options for
    the territories (eg. Français (Suisse)) and the Chinese options are the
    following (in the language of your Windows session):
    • Chinois (simplifié, République populaire de Chine)
    • Chinois (simplifié, Singapour)
    • Chinois (traditionnel, Hong Kong R.A.S.)
    • Chinois (traditionnel, Macao R.A.S.)
    • Chinois (traditionnel, Taiwan)

I think we should do something similar: at least have simplified and
traditional Chinese in 2 different submenus and maybe remove all
submenus, if we can, after #16095.

#5 Updated by sajolida 8 months ago

Right now we have 3 Chinese locales in our PO files:

  • zh_CN: 97% translated, that would be "Chinese (China)" in simplified script
  • zh_HK: 39% translated, that would be "Chinese (Hong-Kong)" in traditional script
  • zh_TW: 39% translated, that would be "Chinese (Taiwan)" in traditional script

#6 Updated by intrigeri 8 months ago

Note that both scripts (eg. China and Taiwan) are under the same foldable section (Chinese) which is displayed in simplified Chinese.
If someone can only read traditional Chinese, they might not find Taiwan in the Chinese submenu.

Good point. I hadn't noticed that because I never scroll through this looong list: I always type the first few letters of the language I'm looking for, and search results appear unfolded.

Also note that my Taiwanese user was coming back from trying "Chinese, mandarin" (without any Chinese script, #16093) way up the language list, so maybe his reaction was influenced by this first bad experience :)

Right. If we at least removed these buggy ones for the (top of the) list, perhaps your tester would have not found it so quickly, and resorted to search, which expands the foldable section.

So I suggest we do the same as more popular IT systems, e.g. Android or Windows.

Here is what Windows does:

OK, so I assume that either they ask for the territory later on, or they detect it via GeoIP, both of which have low risk of causing political trouble.

I think we should do something similar: at least have simplified and traditional Chinese in 2 different submenus

What do you mean with "in 2 different submenus"? Two top-level list entries, just like Uzbek? Or two entries inside a foldable section? (and then how would that foldable section be called?) Or something else?

At this point, my proposal would be to do:

  • Chinese (simplified)
    • Chinese (simplified, China)
    • Chinese (simplified, Singapore)
  • Chinese (traditional)
    • Chinese (traditional, Hong Kong)
    • Chinese (traditional, Taiwan)

This avoids all the politically sensitive problems I was talking about earlier, just like Windows 7 does, and presumably like Windows 10 does (in a different way that we can't copy).

#7 Updated by sajolida 8 months ago

OK, so I assume that either they ask for the territory later on, or they detect it via GeoIP, both of which have low risk of causing political trouble.

Yes, my guess is that from the French download for example, you can then change your territory when installing.

Today I had an installed Windows 10 at hand. You can also go into the language settings and add a new language. Then the list displayed all languages and territories for which you can download a "language pack". The list is flat, with no submenus, like I described in Windows 7.

At this point, my proposal would be to do:

  • Chinese (simplified)
    • Chinese (simplified, China)
    • Chinese (simplified, Singapore)
  • Chinese (traditional)
    • Chinese (traditional, Hong Kong)
    • Chinese (traditional, Taiwan)

Yes, like this!

After #16095 we might realize that the list is small enough to be displayed without submenus, like Windows 10 does. But we're not there yet and we should do your proposal.

#8 Updated by intrigeri 6 months ago

  • Description updated (diff)

#9 Updated by intrigeri 6 months ago

Yes, like this!

Updated the ticket description accordingly, then!

#10 Updated by sajolida 3 months ago

Applying my proposal from #16095#note-16 would be consistent with the proposal that we agreed upon here as we currently have in tails.git:po/:

zh_TW 100.0%
zh_CN 100.0%
zh_HK  37.1%
zh      0.0%
  • I expect translators for each territory to use the common script from this territory.
  • Compared to the proposal from #16094#note-9 we miss Chinese (simplified, Singapore). It would be added automatically once people start translating for it, cf. #16095#note-16.
  • We should remove zh which hasn't be used by translators, probably because it was unclear regarding the territory (and thus the script).

#11 Updated by intrigeri 3 months ago

  • Blocks Bug #16239: <pre><code> inside tip containers overflows added

#12 Updated by intrigeri 3 months ago

#13 Updated by intrigeri 3 months ago

  • Blocks deleted (Bug #16239: <pre><code> inside tip containers overflows)

#14 Updated by intrigeri 2 months ago

  • Blocked by Feature #16095: Curate the list of languages in Tails Greeter added

#15 Updated by segfault about 2 months ago

This seems to contradict the decision we made on #16095: zh-TW is neither in the list of tier-1 languages, nor in tails.git/po. So should we still add it or not? And what about zh-SG and zh-HK?

#16 Updated by sajolida about 2 months ago

I based my reasoning on the content of master, which still has:

  • zh_CN.po
  • zh_HK.po
  • zh_TW.po

These were removed from devel in 1aeddb857e, maybe due to the unfinished work in #16774.

I'll let @intrigeri confirm this.

#17 Updated by intrigeri about 2 months ago

  • Assignee set to sajolida
  • Type of work changed from Code to User interface design

(Folks who like diving into historical background may find the data points I provided in #16095#note-24 and #16774#note-14 interesting.)

These were removed from devel in 1aeddb857e, maybe due to the unfinished work in #16774.

These two languages currently have no reviewed translated string. If this does not change, even once the work on #16774 is completed, the corresponding PO files will not be in tails.git. Same for Singapore.

So, should be unconditionally list these 4 countries in the Greeter, as if they were tier-1 languages, even at times when they don't match the criteria defined in #16095 + #16774?

Or should we do anything else?

#18 Updated by sajolida about 2 months ago

  • Assignee deleted (sajolida)

Note that when defining our tier-1 languages we added "Chinese" without specifying whether it was simplified or traditional Chinese. Fixed now in 9784963a15.

I was tempted to add at least 1 locale that uses traditional Chinese (Hong Kong or Taiwan) but it would be an unjustified twist of our policy regarding tier-1 languages (for example, neither Hong Kong nor Taiwan are high in the list of Tor users).

They will appear again in Tails Greeter as soon as people start translating them again. I'm not so worried about that seeing the big Free Software community in Taiwan :)

So I'm fine with only having Simplified Chinese appear in Tails Greeter for now.

Still, how the language is listed should be improved, according to the feedback I received in Taiwan. See comments above.

Right now it's listed as:

汉语 (Chinese)

And it should be listed as:

中文 (Chinese, simplified)

With maybe some additional Chinese characters to qualify it as "simplified".

@u could probably help us on that.

Like we have:

ελληνικά (Greek, modern (1453-))

#19 Updated by u about 2 months ago

sajolida wrote:

Note that when defining our tier-1 languages we added "Chinese" without specifying whether it was simplified or traditional Chinese. Fixed now in 9784963a15.

I was tempted to add at least 1 locale that uses traditional Chinese (Hong Kong or Taiwan) but it would be an unjustified twist of our policy regarding tier-1 languages (for example, neither Hong Kong nor Taiwan are high in the list of Tor users).

They will appear again in Tails Greeter as soon as people start translating them again. I'm not so worried about that seeing the big Free Software community in Taiwan :)

So I'm fine with only having Simplified Chinese appear in Tails Greeter for now.

Still, how the language is listed should be improved, according to the feedback I received in Taiwan. See comments above.

Right now it's listed as:

汉语 (Chinese)

And it should be listed as:

中文 (Chinese, simplified)

With maybe some additional Chinese characters to qualify it as "simplified".

@u could probably help us on that.

This is hard! There is writing and language.

I would assume that the translations that are made are made into one of the standard chinese languages, called 普通话 Pǔtōnghuà in China and 国语 (traditional: 國語) Guóyǔ in Taiwan.

Now to writing.

To my knowledge 汉语 (Chinese) means "hànyǔ", chinese language, which is often used synonymously with the word "Chinese", while in reality it denotes a Han Chinese dialect that not all Chinese speak. So indeed, it would be wrong to use this translation for "Chinese".

中文 ("zhōngwén") language/writing of the land of the middle, is more generic for Chinese. The simplified characters are called 简化字 (jiǎnhuà zì).
So we could write

中文 (简化字, Chinese, simplified).

字 means character.

Traditional characters, written in traditional characters, reads 正體字 (zhèngtǐ zì), if needed later.

Wikipedia uses only 中文 - Chinese.

#20 Updated by segfault about 2 months ago

sajolida wrote:

Still, how the language is listed should be improved, according to the feedback I received in Taiwan. See comments above.

Right now it's listed as:

[...]

And it should be listed as:

[...]

That turns out to be hard to implement. A lot of code in the Greeter assumes that the locales are grouped by the language code (i.e. "zh"). I already spent 1,5 hours trying to hack something that separates Chinese into the two groups without breaking stuff, but I wasn't successful yet.

#21 Updated by segfault about 2 months ago

  • Status changed from Confirmed to In Progress

#22 Updated by segfault about 2 months ago

  • Status changed from In Progress to Needs Validation

#23 Updated by segfault about 2 months ago

  • Feature Branch set to https://salsa.debian.org/tails-team/tails/merge_requests/39/commits

#24 Updated by intrigeri about 2 months ago

  • Assignee set to intrigeri

#25 Updated by intrigeri about 2 months ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF