Project

General

Profile

Bug #16093

Remove untranslated Chinese languages from Tails Greeter

Added by sajolida about 1 year ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
-
Start date:
11/04/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Greeter

Description

See screenshot in attachment.

These are not languages that people use and even their name is not translated in Tails. They take up more space that groups of translated language names (who are collapsed under a single name, like "Español") and are confusing because they appear before the Chinese that works (and that has it's name translated) at the very bottom of the list.

chinese.png View (185 KB) sajolida, 11/04/2018 07:00 AM


Related issues

Related to Tails - Feature #14544: Spend software developer time on smallish UX improvements In Progress 08/31/2018
Related to Tails - Feature #16095: Curate the list of languages in Tails Greeter Resolved 11/04/2018
Related to Tails - Feature #16094: Have simplified and traditional Chinese in the list of languages in Tails Greeter Resolved 11/04/2018

Associated revisions

Revision 53c6c19a
Added by intrigeri about 1 month ago

Merge branch 'feature/17098-refactor-greeter' into devel (Closes: #17098, #17089, #16806, #13447, #17087, #17058, #17101, #6525, #16095, #16094, #16093)

History

#1 Updated by sajolida about 1 year ago

  • Affected tool set to Greeter

#2 Updated by sajolida about 1 year ago

  • Related to Feature #14544: Spend software developer time on smallish UX improvements added

#3 Updated by sajolida about 1 year ago

  • Related to Feature #16095: Curate the list of languages in Tails Greeter added

#4 Updated by sajolida about 1 year ago

  • Related to Feature #16094: Have simplified and traditional Chinese in the list of languages in Tails Greeter added

#5 Updated by intrigeri 8 months ago

These are not languages that people use and even their name is not translated in Tails. They take up more space that groups of translated language names (who are collapsed under a single name, like "Español") and are confusing because they appear before the Chinese that works (and that has it's name translated) at the very bottom of the list.

These untranslated languages are about locales like cmn_TW (Chinese, mandarin) and yue_HK (Chinese, yue). I guess they're not grouped with the other Chinese languages because that group is about zh_* locales.

FWIW, according to https://peterburk.github.io/i2018n/ there "is a different locale cmn_TW for Hanzi collation (sort order), and zh_TW, which are both Mandarin". While that might be in favour of exposing e.g. cmn_TW, it definitely should not be listed as "Chinese, mandarin". I've tested that locale and indeed, the GNOME desktop is not translated.

I think we should hide all such languages (Chinese whose name is not translated) that totally lack GNOME translations: if there's no translator interest whatsoever, it tends to confirm that "These are not languages that people use".

#6 Updated by intrigeri about 1 month ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF