Project

General

Profile

Bug #16087

The download extension doesn't work on Chrome > 69

Added by goupille over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
10/31/2018
Due date:
% Done:

0%

Feature Branch:
verification-extension.git:usbimage
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Verification Extension

Description

a user reported that with Ubuntu 18.10 and Chrome 70.0.3538.77, ahen trying to install the extension, it keeps returning to the installation page and the extension doesn't appear to be installed.


Related issues

Related to Tails - Bug #16098: Inline installation deprecated in Chrome 71 Resolved 11/05/2018
Related to Tails - Bug #15995: Have Tails Verification handle IDFs with several Tails installation paths (ISO/IMG) Resolved 09/28/2018
Duplicates Tails - Bug #16098: Inline installation deprecated in Chrome 71 Resolved 11/05/2018

Associated revisions

Revision fe2c7513
Added by intrigeri 5 months ago

Merge branch 'bugfix/16807-impossible-to-maximize-gimp' into devel (Closes: #16087)

History

#1 Updated by Anonymous over 1 year ago

  • Subject changed from the download extension doesn't work on the latest Chrome release to The download extension doesn't work on the latest Chrome release
  • Assignee changed from sajolida to goupille

I'm not aware of the extension working on Chrome. It should work in Firefox.

#2 Updated by Anonymous over 1 year ago

  • Assignee changed from goupille to sajolida

#3 Updated by Anonymous over 1 year ago

I confirm that the extension installs fine on Chromium 69.0.3497.92 running on Debian 9.5 (Stretch), but is greyed out and does not seem to work on the installation page.

#4 Updated by Anonymous over 1 year ago

  • Status changed from New to Confirmed

#5 Updated by Anonymous over 1 year ago

  • Related to Bug #16098: Inline installation deprecated in Chrome 71 added

#6 Updated by Anonymous over 1 year ago

  • Subject changed from The download extension doesn't work on the latest Chrome release to The download extension doesn't work on Chrome > 69

#7 Updated by Anonymous over 1 year ago

  • Related to Bug #15995: Have Tails Verification handle IDFs with several Tails installation paths (ISO/IMG) added

#8 Updated by Anonymous over 1 year ago

I guess I could look into it as part of my work on the USB image project. But for now I will leave this assigned to sajolida, just in case he knows what this could be about.

#9 Updated by Anonymous over 1 year ago

  • Assignee changed from sajolida to Anonymous

Ok, so it seems the work I (now I should say "we" because I have a rubber duck) are currently doing on #15995 ie. the USB image project will fix this problem :) So I'll take that ticket.

#10 Updated by Anonymous over 1 year ago

  • Target version set to Tails_3.11

#11 Updated by Anonymous over 1 year ago

  • Assignee changed from Anonymous to sajolida
  • QA Check set to Ready for QA
  • Feature Branch set to verification-extension.git:usbimage
  • Type of work changed from Research to Code

@sajolida: I have worked on the extension in #15995 and I tried it in Chrome: it seems to work.

I'm not sure it works without reloading the page, but I could implement this if needed: for Chrome only. In Firefox this does already work.

Would you like to test it? Please make sure to read the README file because I've dropped your patch-style approach for something nicer :)

I think it could actually be released as is.

I'm asking @intrigeri for a code review on #15995.

I did not yet augment the version numbers anywhere.

#12 Updated by Anonymous over 1 year ago

  • Assignee changed from sajolida to Anonymous
  • Target version deleted (Tails_3.11)
  • QA Check deleted (Ready for QA)
  • Type of work changed from Code to Research

It would be good to test in Chrome 70+ too: I did not do that as this is not part of the USB Image assignment. I tested in Chrome 69.

#13 Updated by Anonymous over 1 year ago

  • Target version set to Tails_3.11
  • QA Check set to Ready for QA

#14 Updated by sajolida over 1 year ago

  • Affected tool set to Verification Extension

#15 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to Duplicate
  • Assignee deleted (Anonymous)
  • QA Check deleted (Ready for QA)

I did some test today as part of releasing 1.2 to fix #16078.

The current website and extension work fine in Chromium 70: the extension gets installed, the page is refreshed, and the extension works.

But the installation of the extension in Chrome 71 is broken: clicking on the installation link doesn't do anything. I didn't look at the changelog of Chrome to understand this in depth but it seems like the deprecation of inline installation (#16098) and we have to use an explicit link anyway.

After 94249e3b71 (for #16098), the extension works fine: it gets installed and it works.

So I'm marking this ticket as a duplicate of #16098.

#16 Updated by sajolida over 1 year ago

  • Duplicates Bug #16098: Inline installation deprecated in Chrome 71 added

#17 Updated by Anonymous over 1 year ago

  • Status changed from Duplicate to Confirmed
  • Assignee set to Anonymous
  • QA Check set to Info Needed

I'm not sure this is the same error really: on Chrome 69 the extension did get installed fine but it is greyed out and does not function. I want to test with the one you uploaded but our website is currently broken. So I'm reopening this ticket.

#18 Updated by Anonymous over 1 year ago

I want to test thouroughly because 69 is the current Debian stable's Chromium version, so it might affect more people.

#19 Updated by Anonymous over 1 year ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (Anonymous)
  • QA Check deleted (Info Needed)

Ack: 1.2 also works in Chromium 69 (and the website is back)

Also available in: Atom PDF