Project

General

Profile

Bug #16078

Download page is not refreshed when verification extension is installed

Added by sajolida 12 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Installation
Target version:
Start date:
10/27/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:
Verification Extension

Description

See the end of the screencast in attachment (originally for #14922). The issue is still here after reverting #14922.

Elevated since it's a regression on the download procedure.

Also document to check that in the manual test suite, section "Tails Verification" since that was missed apparently...

NetworkError on download and no refresh after installing extension.webm (1.07 MB) sajolida, 10/27/2018 03:49 PM

page-reset-in-chrome.webm (645 KB) sajolida, 12/25/2018 07:21 PM


Related issues

Related to Tails - Bug #13450: Implement CSP HTTP header Rejected 07/10/2017
Related to Tails - Feature #15060: Apply a more restrictive CSP in Verification Extension Resolved 12/14/2017
Related to Tails - Bug #16009: Metrics for USB Image Resolved 09/28/2018

History

#1 Updated by sajolida 12 months ago

Reverting 6f94042 fixes the issue locally in Chromium but not in Firefox. I'll release a new version soon and it might fix things for Firefox in production as well. But I only have 1.5 hour in front of me now, so that wouldn't be safe.

Most likely, this has been broken since 1.0 and everybody who worked on these lines participated in creating the bug :(

#2 Updated by sajolida 11 months ago

I release 1.2 with a relaxed CSP. The problem is fixed in Chrome but not in Firefox...

My next step is to cherry-pick 104d7d8 & co in master and test them locally.

#3 Updated by u 11 months ago

  • Related to Bug #13450: Implement CSP HTTP header added

#4 Updated by u 11 months ago

  • Related to Feature #15060: Apply a more restrictive CSP in Verification Extension added

#5 Updated by u 11 months ago

@sajolida: I think that instead of cherry picking 104d7d8 we should just release the updates version of the extension from branch usbimage. One could for example diverge from the usbimage branch and delete the function that checks for the type of ISO/USB image. I would happily take care of this - respecting a deadline you can give.

I'm also not super convinced of relaxing the CSP as a long-term solution and would prefer if we could invest some time to fix this issue. I can ask Enrico to give advice. What do you think?

#6 Updated by u 11 months ago

Oh and note that 104d7d8 works in Chrome: but I need to do more work to make the extension reload itself correctly. So it might be a waste of time to cherry pick this right now.

#7 Updated by u 11 months ago

Oh and 104d7d8 does work in Firefox. (sorry for the multiple comments!)

#8 Updated by sajolida 10 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#9 Updated by u 10 months ago

This is fixed in version 2.0 of the verification extension, so you can probably close this ticket once it it released.

#10 Updated by sajolida 10 months ago

I confirm that this is fixed in Tor Browser in Tails with 2.0.

#11 Updated by sajolida 10 months ago

  • File page-reset-in-chrome.webm added
  • Assignee changed from sajolida to u
  • Priority changed from Elevated to Normal
  • QA Check set to Dev Needed

In Chrome the page is refreshed but also reseted, see screencast in attachment.

Do you see an easy fix for this?

Still, the situation improved a lot with 2.0. Congrats!

#12 Updated by u 10 months ago

sajolida wrote:

In Chrome the page is refreshed but also reseted, see screencast in attachment.

Correct.

Do you see an easy fix for this?

I actually do. Instead of just reloading the page, we can also toggle visibility of "step-verify-direct" in the download page. This code is a workaround anyway.

Let me know if you want me to implement this.

Still, the situation improved a lot with 2.0. Congrats!

Great.

#13 Updated by anonym 9 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#14 Updated by sajolida 8 months ago

  • Assignee changed from u to sajolida
  • Type of work changed from Code to Test

I'll test again what's up with that now that 3.12 has been released.

#15 Updated by sajolida 8 months ago

  • Status changed from Confirmed to In Progress
  • Target version changed from Tails_3.13 to Tails_3.14

It was quite an odyssey but I finally managed to fix that.

To summarize, we need to fully reload the page to be able to actually use the extension. But reloading the page prevent us from sending more JavaScript to it. So in the end I'm reloading the page on a custom HTML anchor. See tails.git:4bda4d93cf.

Just out of curiosity, I'll procrastinate to do some stats on the usage of the extension by Chrome users before and after this change (February 13). With my new script it should be fast :)

#16 Updated by sajolida 8 months ago

  • Related to Bug #16009: Metrics for USB Image added

#17 Updated by sajolida 8 months ago

Actually, I can use the data I already compute for #16009.

Here is the baseline from December 26 → January 22:

| Browser | Download | Successful | Failed | Total | Usage rate | Failure rate |
|---------+----------+------------+--------+-------+------------+--------------|
| Chrome  |    26715 |       3380 |    395 |  3775 |       14.1 |          1.5 |
| Firefox |    32009 |       7073 |   1475 |  8548 |       26.7 |          4.6 |
#+TBLFM: $5=vsum($3+$4)::$6=round(100*$5/$2,1)::$7=round(100*$4/$2,1)

#18 Updated by sajolida 5 months ago

  • Status changed from In Progress to Resolved
  • QA Check deleted (Dev Needed)

Since we release USB images the usage rate on Chrome raised by more than 1% but the usage rate which could be attributed to this UX improvement. But surprisingly, the usage rate on Firefox, with no UX change, dropped by less than 1%. Are the user segments that are downloading Tails more (eg. macOS) less prone to use the verification extension is general?

March

| Browser | Download | Successful | Failed | Total | Usage rate | Failure rate |
|---------+----------+------------+--------+-------+------------+--------------|
| Chrome  |    40576 |       5810 |    668 |  6478 |         16 |          1.6 |
| Firefox |    43429 |       9394 |   1942 | 11336 |       26.1 |          4.5 |
#+TBLFM: $5=vsum($3+$4)::$6=round(100*$5/$2,1)::$7=round(100*$4/$2,1)

April

| Browser | Download | Successful | Failed | Total | Usage rate | Failure rate |
|---------+----------+------------+--------+-------+------------+--------------|
| Chrome  |    38158 |       5231 |    605 |  5836 |       15.3 |          1.6 |
| Firefox |    39236 |       8338 |   1799 | 10137 |       25.8 |          4.6 |
#+TBLFM: $5=vsum($3+$4)::$6=round(100*$5/$2,1)::$7=round(100*$4/$2,1)

#19 Updated by intrigeri 5 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#20 Updated by anonym 5 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#21 Updated by intrigeri 5 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF