Project

General

Profile

Bug #16077

devel branch FTBFS because of newer torbirdy in stretch-backports

Added by CyrilBrulebois about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Build system
Target version:
Start date:
10/27/2018
Due date:
% Done:

100%

Feature Branch:
bugfix/devel-FTBFS-because-of-torbirdy
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

The devel branch built fine until 2018-10-25, but started FTBFSing on 2018-10-26, due to a failure to apply the torbirdy install.rdf patch:

P: Applying patch config/chroot_local-patches/torbirdy-60.2-compat.diff...
patching file usr/share/xul-ext/torbirdy/install.rdf
Reversed (or previously applied) patch detected!  Assume -R? [n] 
Apply anyway? [n] 
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file usr/share/xul-ext/torbirdy/install.rdf.rej

This is due to the upload of torbirdy 0.2.6-1~bpo9+1 to stretch-backports, replacing 0.2.5-1~bpo9+1.

Dropping the patch should be sufficient to get everything back in order.


Related issues

Blocks Tails - Feature #15506: Core work 2018Q4: Foundations Team Resolved 04/08/2018

Associated revisions

Revision 31f7adb4 (diff)
Added by segfault about 1 year ago

Drop obsolete Torbirdy patch (refs: #16077)

torbirdy 0.2.6-1~bpo9+1 in stretch-backports now already declares
Torbirdy as compatible with Thunderbird 60.*

Revision 98b90c75 (diff)
Added by segfault about 1 year ago

Update torbirdy patches for 0.2.6-1~bpo9+1 (refs: #16077)

Revision 79a45981
Added by intrigeri about 1 year ago

Merge remote-tracking branch 'origin/bugfix/devel-FTBFS-because-of-torbirdy' into devel (Fix-committed: #16077)

History

#1 Updated by intrigeri about 1 year ago

#2 Updated by intrigeri about 1 year ago

  • Category set to Build system
  • Status changed from New to Confirmed
  • Assignee set to segfault
  • Priority changed from Normal to High
  • Target version set to Tails_3.11
  • Affected tool set to Email Client

segfault, do you want to take this one? I expect you'll be the first one affected when working on the USB image project.

#3 Updated by segfault about 1 year ago

intrigeri wrote:

segfault, do you want to take this one?

sure

#4 Updated by segfault about 1 year ago

  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/devel-FTBFS-because-of-torbirdy

Pushed a commit which removes the obsolete patch to the feature branch. Now waiting to see whether Jenkins can build the branch.

#5 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to 11
  • % Done changed from 10 to 100

#6 Updated by intrigeri about 1 year ago

  • Assignee deleted (segfault)
  • Target version changed from Tails_3.11 to Tails_3.12

Thanks!

#7 Updated by anonym 12 months ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF