Project

General

Profile

Feature #16065

Feature #10034: Translation web platform

Feature #11759: Install & configure a fresh weblate on the VM

Grant hefee ability to disable puppet

Added by groente about 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/18/2018
Due date:
% Done:

90%

Feature Branch:
feature/16065-sudo-puppet-for-weblate-admins
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Translate is currently administered as a production server, but from an application admin point of view is still under development and requires testing on the machine itself. It would therefore be useful to grant weblate admins the ability to temporarily disable puppet to run tests without puppet overwriting their changes.

Note that this requires a strict policy from the weblate admins to both:

- notify when they disable puppet (also because we can then acknowledge the monitor alerts that will pop up)

- enable puppet again once they are done with their experiments (and again, notify )

History

#1 Updated by groente about 1 year ago

  • Assignee set to u
  • QA Check set to Info Needed
  • Feature Branch set to feature/16065-sudo-puppet-for-weblate-admins

Hey u, do you think this policy is acceptable/workable?

#2 Updated by emmapeel about 1 year ago

I would love to have that possibility on the translate server!

It is very annoying to have to have scripts while true overwriting the settings file when testing different options

#3 Updated by u about 1 year ago

  • Subject changed from Grant weblate admins ability to disable puppet to Grant hefee ability to disable puppet
  • Assignee changed from u to groente
  • Parent task set to #10034
  • QA Check deleted (Info Needed)

Please see email I will send later today about the future work on the platform, and grant access to hefee.

I think it's useful to grant this access only to him for now, in order to not interfere with his work.
If anybody needs to test something on their side, please talk to hefee about it. Thanks for your understanding.

In any case, this measure should remain temporary until we consider the translation platform to be "production" which we currently do not.

#4 Updated by groente about 1 year ago

  • Assignee changed from groente to bertagaz
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

Hey bertagaz,

Can you check if everything is okay with these sudo rights? Thank you!

#5 Updated by bertagaz about 1 year ago

  • Assignee changed from bertagaz to groente

groente wrote:

Hey bertagaz,

Can you check if everything is okay with these sudo rights? Thank you!

Yes, looks good! Beware though your banch seems to be based on the #16064 one and contains its patches, and I've not reviewed it yet. But feel free to merge and deploy this ticket's branch without #16064 changes. When hefee will confirm it works, all will be ready for this ticket to be closed.

#6 Updated by groente about 1 year ago

  • Assignee changed from groente to hefee
  • % Done changed from 50 to 90

Hey hefee, you should now be able to run

/usr/bin/puppet agent --disable
/usr/bin/puppet agent --enable

Can you verify and close the ticket if it works?

#7 Updated by hefee about 1 year ago

  • Status changed from Confirmed to Resolved

groente wrote:

Hey hefee, you should now be able to run

/usr/bin/puppet agent --disable
/usr/bin/puppet agent --enable

Can you verify and close the ticket if it works?

that works.

#8 Updated by intrigeri 12 months ago

  • QA Check deleted (Ready for QA)

#9 Updated by u 10 months ago

  • Parent task changed from #10034 to #11759

#10 Updated by intrigeri 5 months ago

  • Assignee deleted (hefee)

Also available in: Atom PDF