Project

General

Profile

Feature #16063

Support restarting tests in CI without rebuilding

Added by segfault 11 months ago. Updated 6 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Continuous Integration
Target version:
-
Start date:
10/17/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Related to Tails - Bug #16959: Gather usability data about our current CI In Progress

Associated revisions

Revision 300369ce (diff)
Added by intrigeri 6 days ago

Document how (and why) one can trigger a test suite run without rebuilding images (refs: #16063)

Revision 39f45019 (diff)
Added by intrigeri 6 days ago

Clarify what images are tested (refs: #16063)

History

#1 Updated by intrigeri 19 days ago

  • Related to Bug #16959: Gather usability data about our current CI added

#2 Updated by intrigeri 6 days ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri

It looks like I have something that works on my local Jenkins ⇒ applied the same changes to our shared Jenkins. Will now test and if that works, document & announce it.

#3 Updated by intrigeri 6 days ago

  • Status changed from In Progress to Resolved

It works. Documented and announced to the relevant folks.

The corresponding Jenkins job change is: https://git.tails.boum.org/jenkins-jobs/commit/?id=59929903bf1295ea6b0623146f54377c06d824a6

Also available in: Atom PDF