Project

General

Profile

Bug #16017

Upgrade Tor Browser to 8.0.2

Added by intrigeri over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
10/01/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Associated revisions

Revision f5f99ca9 (diff)
Added by anonym over 1 year ago

Upgrade Tor Browser to 8.0.2-build1.

Fix-committed: #16017

Revision 333e74ae (diff)
Added by anonym over 1 year ago

getTorBrowserUserAgent: simplify.

Let's just duplicate the Tor Browser user-agent string, which hasn't
changed for years (and likely won't for a loooooong time). Generating
it from Tor Browser 8.0.2+ is much more complicated since it has been
split up in several different prefs.

Refs: #16017

History

#1 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to anonym

The user agent spoofing changes might require adjustments on our side.

#2 Updated by intrigeri over 1 year ago

Just in case you missed it (since I had claimed I would let you know more directly), see tails-rm@ for the last updates on the upstream browser builds.

#3 Updated by anonym over 1 year ago

  • Status changed from Confirmed to 11
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100
  • QA Check set to Pass

Automated tests look good: https://jenkins.tails.boum.org/job/build_Tails_ISO_stable/2334/ + I ran complementary tests locally with success.

#4 Updated by anonym over 1 year ago

  • Status changed from 11 to In Progress

#5 Updated by anonym over 1 year ago

  • Status changed from In Progress to 11

#6 Updated by anonym over 1 year ago

  • Target version changed from Tails_3.9.1 to Tails_3.10.1

#7 Updated by CyrilBrulebois over 1 year ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF