Project

General

Profile

Bug #16012

Feature #15292: Distribute a USB image

Ensure Tails installer is removed from Debian & Ubuntu by the end of 2019

Added by u about 1 year ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
09/28/2018
Due date:
% Done:

0%

Feature Branch:
master
Type of work:
Debian
Blueprint:
Starter:
Affected tool:

Description

  • upload the changes from #16011 to sid, stretch-backports and Ubuntu PPA; see the plan on #16011#note-6 for detailed timing info

Then:

  • late February: get Tails Installer removed from testing via a RC bug that'll trigger the auto-removal process at some point during the Buster freeze; don't do that earlier because we might need to get some follow-up fixes into stretch-backports if we messed it up, and we can't do that anymore once the package is removed from testing
  • at the end of 2019:
    • drop from Debian sid → submitted removal request to ftpmasters for unstable, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=942790
    • (ignore stretch-backports) → I did not request removal from stretch-bpo.
    • drop from Ubuntu PPA → done on Oct 21st 2019
      write email to help desk in case users complain
    • adjust our release process / packaging doc → done in feature/16012-remove-tails-installer → merged to master so that nobody tries to commit to salsa, as the repo is now read-only.
    • adjust Vcs-control fields → done in tails-installer.git: 9122a5408f4804a61ef0966ba63bd8b97713cbad
    • archive the repository on salsa.d.o → no commits are possible anymore.
    • keep old branches for reference in the packaging repo → if the upstream developers want to change this, they can do that and refer to the archived version on https://salsa.debian.org/pkg-privacy-team/tails-installer
      (this is part of core work in Debian)

Related issues

Blocked by Tails - Bug #16011: Get ready for removing tails-installer from Debian Resolved 09/28/2018

Associated revisions

Revision 08442296 (diff)
Added by u about 2 months ago

Delete Debian & Ubuntu parts of release doc

refs: #16012

Revision b40de22d (diff)
Added by u about 2 months ago

Restore a part of the documentation that is still relevant for upstream. Refs: #16012

History

#1 Updated by u about 1 year ago

  • Blocked by Bug #16011: Get ready for removing tails-installer from Debian added

#2 Updated by u about 1 year ago

Milestone 5

#3 Updated by u about 1 year ago

  • Target version changed from Tails_3.11 to Tails_3.12

#4 Updated by u about 1 year ago

  • Priority changed from Normal to Elevated

I'm bumping priority so i don't miss this ticket in my view.

#5 Updated by intrigeri 12 months ago

  • Description updated (diff)

(Fixed markup.)

#6 Updated by intrigeri 12 months ago

  • Description updated (diff)

#7 Updated by u 11 months ago

  • Subject changed from Ensure Tails installer is removed from Debian to Ensure Tails installer is removed from Debian late February/end of yea 2019

#8 Updated by u 11 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#9 Updated by intrigeri 10 months ago

  • Subject changed from Ensure Tails installer is removed from Debian late February/end of yea 2019 to Ensure Tails installer is removed from Debian late February/end of 2019

#10 Updated by u 10 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#11 Updated by u 9 months ago

#12 Updated by u 9 months ago

  • Subject changed from Ensure Tails installer is removed from Debian late February/end of 2019 to Ensure Tails installer is removed from Debian & Ubuntu by the end of 2019

#13 Updated by u 9 months ago

  • Target version changed from Tails_3.14 to Tails_3.17

#14 Updated by u 9 months ago

  • Priority changed from Elevated to Normal

#15 Updated by intrigeri 3 months ago

  • Target version changed from Tails_3.17 to Tails_4.0

#16 Updated by intrigeri about 2 months ago

  • Target version changed from Tails_4.0 to Tails_4.1

#17 Updated by u about 2 months ago

  • Description updated (diff)

#18 Updated by u about 2 months ago

  • Feature Branch set to feature/16012-remove-tails-installer

#19 Updated by u about 2 months ago

  • Status changed from Confirmed to In Progress

#20 Updated by u about 2 months ago

  • Description updated (diff)

#21 Updated by u about 2 months ago

  • Description updated (diff)

#22 Updated by u about 2 months ago

  • Description updated (diff)

#23 Updated by u about 2 months ago

  • Description updated (diff)

#24 Updated by u about 2 months ago

  • Description updated (diff)

#25 Updated by u about 2 months ago

  • Description updated (diff)

#26 Updated by u about 2 months ago

  • Description updated (diff)

#27 Updated by u about 2 months ago

  • Description updated (diff)

#28 Updated by u about 2 months ago

  • Description updated (diff)

#29 Updated by u about 2 months ago

  • Description updated (diff)

#30 Updated by u about 2 months ago

  • Description updated (diff)

#31 Updated by u about 2 months ago

  • Description updated (diff)

#32 Updated by u about 2 months ago

  • Feature Branch changed from feature/16012-remove-tails-installer to master

@intrigeri If you like to review my changes, feel free to do so.

I'm leaving the ticket assigned to me until I have confirmation of the removal in Debian.

#33 Updated by u about 2 months ago

  • Description updated (diff)

#34 Updated by intrigeri about 2 months ago

If you like to review my changes, feel free to do so.

Looks good to me.

FTR, mostly for the sake of whoever will wonder some day why this info was deleted: the part that you deleted in the "Upstream" section has info that is still relevant upstream, and not specific to having the package in Debian: every second year, this codebase must support 2 Debian releases concurrently, because we're porting Tails to the next version of Debian; so for example, it may be that it 6-12 months, we need a feature/bullseye branch from which we build 6.x releases. But once #7036 is done, this info won't be useful anymore, so IMO it's not worth the effort to salvage it now.

#35 Updated by u about 2 months ago

intrigeri wrote:

If you like to review my changes, feel free to do so.

Looks good to me.

FTR, mostly for the sake of whoever will wonder some day why this info was deleted: the part that you deleted in the "Upstream" section has info that is still relevant upstream, and not specific to having the package in Debian: every second year, this codebase must support 2 Debian releases concurrently, because we're porting Tails to the next version of Debian; so for example, it may be that it 6-12 months, we need a feature/bullseye branch from which we build 6.x releases. But once #7036 is done, this info won't be useful anymore, so IMO it's not worth the effort to salvage it now.

Ah I see! Thanks for clarifying this. I salvaged it anyway.

#36 Updated by u about 2 months ago

  • Status changed from In Progress to Resolved

The last part of this ticket has now been accomplished: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=942790

Also available in: Atom PDF