Project

General

Profile

Bug #16009

Metrics for USB Image

Added by u 8 months ago. Updated 18 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/28/2018
Due date:
% Done:

0%

Estimated time:
3.00 h
Spent time:
QA Check:
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Compute metrics on the downloads of the DVD and USB images
- assuming the infra to gather the raw data is done as part of sajolida's UX core work in advance (#14922)
- deliverable: nicely formatted data we can report to the sponsor, once before we ship a USB image, once a few months later

I.1 Number of downloaded images and fraction of USB images

In this task, we will compute the number of images downloaded from our
website at the beginning and at the end of this project. At the end of
the project, we will also compute the number of downloads of the new USB
images.

I.2 Conversion rate of Windows and macOS users

As part of our installation instructions, people are instructed to open
the instructions on another device (for example a smartphone) so they
can continue reading them while restarting their computer on Tails for
the first time. Doing web analytics on the reopening of our installation
instructions can be used as a metric of successful installations by
first-time users.

In this task, we will compute the conversion rate of people following
our installation instructions for Windows and macOS, both before and
after the release of USB images to our users (Milestone #3).

Related issues

Related to Tails - Bug #16078: Download page is not refreshed when verification extension is installed Resolved 10/27/2018
Related to Tails - Bug #15312: "Tor check" button is badly aligned and looks buggy In Progress 02/15/2018
Blocked by Tails - Feature #14922: Integrate download metrics in the new download page Resolved 11/04/2017

History

#1 Updated by sajolida 6 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#2 Updated by intrigeri 4 months ago

  • Blocked by Feature #14922: Integrate download metrics in the new download page added

#3 Updated by intrigeri 4 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#4 Updated by sajolida 3 months ago

  • Description updated (diff)

#5 Updated by sajolida 3 months ago

  • Related to Bug #16078: Download page is not refreshed when verification extension is installed added

#6 Updated by sajolida 3 months ago

  • Assignee changed from sajolida to groente
  • Target version changed from Tails_3.13 to Tails_3.14
  • Type of work changed from Research to Sysadmin

Here is the baseline before we released USB images. I used stats from Dec 26 to Jan 22 (28 days and log files starting on a Tuesday).

This period was 2 weeks after a release. So I'll compare them with Apr 3 to Apr 30 which is 28 days starting on a Tuesday and 2 weeks after 3.13.

The next is for our dear sysadmins to send me these logs during the 3.14 release cycle.

*** I.1 Download

| Scenario      | Count direct | Count torrent | Total |   % |
|---------------+--------------+---------------+-------+-----|
| win           |        23818 |          5841 | 29659 |  38 |
| mac           |         1206 |           246 |  1452 |   2 |
| debian        |         7173 |          1324 |  8497 |  11 |
| linux         |         1526 |           272 |  1798 |   2 |
|---------------+--------------+---------------+-------+-----|
| download only |        22294 |          4775 | 27069 |  35 |
| dvd           |         2510 |           453 |  2963 |   4 |
| vm            |         4428 |           861 |  5289 |   7 |
| upgrade       |          912 |           103 |  1015 |   1 |
|---------------+--------------+---------------+-------+-----|
| Total         |        63867 |         13875 | 77742 | 100 |
#+TBLFM: @>$2=vsum(@<<..@>>)::@>$3=vsum(@<<..@>>)::@>$4=vsum(@<<..@>>)::$4=$2+$3::$5=round(100*$4/@10$4)

*** I.2 Back

| Scenario | Count |   % |
|----------+-------+-----|
| win      |  3801 |  77 |
| debian   |   605 |  12 |
| mac      |   258 |   5 |
| linux    |   155 |   3 |
| expert   |    98 |   2 |
|----------+-------+-----|
| Total    |  4917 | 100 |
#+TBLFM: @>$2=vsum(@<<..@>>)::$3=round(100*$2/@7$2)

#7 Updated by intrigeri 3 months ago

The next is for our dear sysadmins to send me these logs during the 3.14 release cycle.

Do you mean the 3.14 dev cycle (i.e. between the 3.13 and 3.14 releases) or the 3.14 release life (i.e. between the 3.14 and 3.15 releases)?

#8 Updated by sajolida 3 months ago

Oops, yeah: dev cycle :)

#9 Updated by groente 3 months ago

So this will be April 3rd - 30th (including all of the 30th).

#10 Updated by sajolida 3 months ago

  • Related to Bug #15312: "Tor check" button is badly aligned and looks buggy added

#14 Updated by sajolida about 2 months ago

  • Priority changed from Normal to Elevated

groente: I have bad news. I missed the fact that we updated the milestone with the funder half-way through and that the metrics are due on March 31 :(

Would you mind giving me access to 28 days of logs, with filenames from February 20 to March 19? Very sorry about that!!!

Ulrike: I totally missed that. We have 3 different versions of the milestone in fundraising.git and I looked at the 2 versions that are outdated :( I fixed that with 78c5681.

But I think we're still on time for March 31 as the scripts are already written. I asked groente for fresher logs.

Still, I'm afraid that the logs will give us worth data as less time has passed since the release. So I'll also compare with some older logs later on: from April 17 to May 14.

#15 Updated by u about 2 months ago

Ulrike: I totally missed that. We have 3 different versions of the milestone in fundraising.git and I looked at the 2 versions that are outdated :( I fixed that with 78c5681.

@sajolida: I should have modified all the files in fundraising.git accordingly and not bet on the fact that everybody will remember this file :(

But I think we're still on time for March 31 as the scripts are already written. I asked groente for fresher logs.

Yay! Thanks! I hope it works out :)

Still, I'm afraid that the logs will give us worth data as less time has passed since the release. So I'll also compare with some older logs later on: from April 17 to May 14.

You mean worse data I suspect. Yes, let's see…

#16 Updated by groente about 2 months ago

  • Assignee changed from groente to sajolida

sajolida wrote:

groente: I have bad news. I missed the fact that we updated the milestone with the funder half-way through and that the metrics are due on March 31 :(

Would you mind giving me access to 28 days of logs, with filenames from February 20 to March 19? Very sorry about that!!!

I've put a file logs.tar in your homedir on misc that should contain all the data you need.

#17 Updated by sajolida about 2 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)

I sent a mail right now on tails-project@ and a copy to tails-ux@.

#18 Updated by sajolida about 2 months ago

  • Status changed from Resolved to In Progress
  • Assignee set to groente

Actually, I'm reopening because I still want to see data from April to see the evolution with a bit more time.

That is: April 3rd - 30th (including all of the 30th).

#19 Updated by u about 2 months ago

  • Parent task deleted (#15292)

unparenting

#20 Updated by u about 2 months ago

thank you both @sajolida and @groente !

#21 Updated by groente 23 days ago

  • Assignee changed from groente to sajolida
  • Priority changed from Elevated to Normal

hey sajolida,

the new batch of logs is now in your homedir on misc under the name freshlogs.tar
please remove these files once you're done with them. thank you!

#22 Updated by sajolida 23 days ago

You're so sweet! I meant to remind you today but I already had your message in my inbox when I woke up :)))

#23 Updated by sajolida 23 days ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

Sent the update to tails-project@. 1 more month, didn't make a big difference.

#24 Updated by intrigeri 19 days ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#25 Updated by anonym 18 days ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#26 Updated by intrigeri 18 days ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF