Project

General

Profile

Bug #16008

Feature #15292: Distribute a USB image

Adjust check-mirrors for USB image

Added by u 12 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
09/28/2018
Due date:
% Done:

50%

Estimated time:
5.00 h
Feature Branch:
feature/16008-usb-image-mandatory
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

worker: intrigeri
reviewer: sajolida

  • Adjust check-mirrors
  • Review, rubber-duck and ensure it keeps working on our infra

History

#1 Updated by u 12 months ago

  • Target version set to Tails_3.11

Milestone 5

#2 Updated by intrigeri 10 months ago

  • Category set to Infrastructure
  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to sajolida
  • % Done changed from 0 to 30
  • QA Check set to Ready for QA
  • Feature Branch set to feature/16008-usb-image

Please review and if happy, merge into master and reassign to me. Then I'll create another branch that drops the --img option and makes USB image checking mandatory (on par with ISO image checking); once you've reviewed that second branch, we shall merge it only after we've released a USB image (i.e. after 3.12 is out if everything goes according to the plan).

#3 Updated by sajolida 10 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Ready for QA to Dev Needed

Excellent! I merged your branch into master. I wish I would remember all these nice tricks I see in your code :)

I also updated the cron job that I run on another server.

#4 Updated by intrigeri 10 months ago

Excellent! I merged your branch into master. I wish I would remember all these nice tricks I see in your code :)

/me blushes (Ruby is not exactly my native programming language)

I also updated the cron job that I run on another server.

I assume you mean you updated the checkout of the check-mirror code used there: I did this work, on purpose, in a way that should not require updating the cronjobs themselves.

#5 Updated by intrigeri 10 months ago

  • Assignee changed from intrigeri to sajolida
  • % Done changed from 30 to 50
  • QA Check changed from Dev Needed to Ready for QA
  • Feature Branch changed from feature/16008-usb-image to feature/16008-usb-image-mandatory

Then I'll create another branch that drops the --img option and makes USB image checking mandatory (on par with ISO image checking);

Done!

once you've reviewed that second branch, we shall merge it only after we've released a USB image (i.e. after 3.12 is out if everything goes according to the plan).

⇒ If happy, set target version to 3.13 and reassign to me so I handle the (timely) merge when it's time.

#6 Updated by u 10 months ago

This morning check-mirrors reported errors (see tails-mirror list). I wonder if this is due to your merge?

#7 Updated by intrigeri 10 months ago

Please review commit c10e19d8a20619219a7a19a7e1f96bce2c657e76, which I pushed straight to master in order to fix the regression reported by u.

#8 Updated by sajolida 9 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

All good and no errors [misc]!

#9 Updated by intrigeri 9 months ago

  • Status changed from Resolved to In Progress
  • Assignee set to sajolida
  • Target version changed from Tails_3.11 to Tails_3.12
  • QA Check set to Ready for QA

I understand that you've validated my follow-up fix on the original branch that was merged already. Thanks! For the next step, see #16008#note-5 (which also documents what you should do after reviewing).

#10 Updated by sajolida 9 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

I'll review and merge feature/16008-usb-image-mandatory after we've releases USB images for 3.12.

#12 Updated by sajolida 8 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Ready for QA to Info Needed

I merged feature/16008-usb-image-mandatory and pushed.

intrigeri: Do you have to do anything to update the Git repo used by the cronjob on lizard?

#13 Updated by intrigeri 8 months ago

  • Assignee changed from intrigeri to sajolida

intrigeri: Do you have to do anything to update the Git repo used by the cronjob on lizard?

No, Puppet updates twice an hour the working copy used by the cronjob.

#14 Updated by sajolida 8 months ago

So I remember right, then. I added a note about this to
mirrors.git:24d2ab3 so I hopefully don't have to ask you again next time.

#15 Updated by sajolida 8 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Info Needed)

#16 Updated by u 7 months ago

  • Description updated (diff)

Also available in: Atom PDF