Project

General

Profile

Feature #15968

Feature #14877: Donation campaign 2018

Prepare donation banner

Added by sajolida over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Fundraising
Target version:
Start date:
09/22/2018
Due date:
% Done:

0%

Feature Branch:
web/15968-donation-banner
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Related issues

Blocks Tails - Feature #15970: Translate the donation banner Resolved 09/22/2018

History

#1 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to web/15968-donation-banner

I rescued the code from last year, cleaned it, and removed the theming.

Now we can discuss the content and theme for this year.

It should also be easier to reuse next year.

#2 Updated by sajolida over 1 year ago

#3 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to moire

I rescued the message we had on /home in 2016 with 26828f29f1.

moire: Tomorrow we'll discuss the banner and message for this year. Please have a look at what's currently on web/15968-donation-banner. For example, you can do:

git diff origin/master...origin/web/15968-donation-banner

For reference, the banners from previous years:

I'll want to discuss:

  • Changes in the text of the banner.
  • What visual we want for the banner this year.
  • Changes in the text of the message.
  • Changes in the graphic design of the message.

#4 Updated by sajolida over 1 year ago

  • Priority changed from Normal to Elevated

#5 Updated by sajolida over 1 year ago

  • Assignee changed from moire to sajolida

#6 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to moire
  • QA Check set to Ready for QA

I'm done, see web/15968-donation-banner.

Since our meeting today I sneaked in a couple of improvements to /donate. Please have a look at the Git history for comments.

I'll monitor tails-l10n@ to integrate translations as they arrive.

#7 Updated by sajolida over 1 year ago

I also:

  • Integrated the French translation.
  • Changed the color scheme of /donate to be green and have more contrast.

Please review all that before our meeting tomorrow if you can!

#8 Updated by moire over 1 year ago

  • Assignee changed from moire to sajolida
  • QA Check changed from Ready for QA to Dev Needed

Pulled, switched to web/15968-donation-banner, built the website and browsed locally english and french versions.

image: pass, great!
english: pass, both the banner and the new version of /donate
french: no translation

#9 Updated by sajolida over 1 year ago

  • Status changed from In Progress to 11
  • QA Check deleted (Dev Needed)

The banners are ready!

#10 Updated by sajolida over 1 year ago

  • QA Check set to Pass

#11 Updated by sajolida over 1 year ago

  • Status changed from 11 to Resolved
  • Assignee deleted (sajolida)

Done!

Also available in: Atom PDF