Project

General

Profile

Feature #15963

Feature #14877: Donation campaign 2018

Analyze the conversion rate of PayPal donations from /home

Added by sajolida 11 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Fundraising
Target version:
Start date:
09/19/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

History

#1 Updated by sajolida 11 months ago

  • Subject changed from Analyze conversion rate for people using Tor Browser to Analyze conversion rate of PayPal donations for people using Tor Browser

#2 Updated by sajolida 11 months ago

  • Parent task set to #14877

#3 Updated by sajolida 11 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Ready for QA

During the summit, you formulated the assumption that people are not donating through PayPal from Tails.

To check it I compared the conversion rate from /donate to /donate/thanks across different user-agents.

According to my results, people who are running Tor Browser only donate 50% less through PayPal than people who are not running Tor Browser.

See donors.git:eb76ed2, donors.git:analysis/2017/Donation campaign 2017.ods cells Stats:C99 and Stats:C100.

Does it make sense?

#4 Updated by intrigeri 11 months ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Info Needed

According to my results, people who are running Tor Browser only donate 50% less through PayPal than people who are not running Tor Browser.
Does it make sense?

Since Tor Browser exposes the same user agent as Firefox on Windows, to me your data instead allows to conclude that "people who are running Firefox on Windows or Tor Browser only donate 50% less through PayPal than people who are not running other web browsers", and we have no way to tell how many of those who did donate were using Tor Browser. Right?

#5 Updated by sajolida 11 months ago

  • Target version deleted (Tails_3.10.1)
  • QA Check changed from Info Needed to Dev Needed

Indeed, my analysis is bogus. As I saw tons of other user-agent from Windows I thought that the Tor Browser agent would be quite unique. But quickly checking the logs of other websites, this user agent is indeed used by a majority of non-Tor users.

I still find it important to check this assumption you made at the summit because it might greatly influence how we design the incentives to donate (and without data we might debate endlessly or make wrong decisions), but hopefully we should be able to do this once we have #14877, so I'll keep this ticket open for analysis of the upcoming campaign.

#6 Updated by intrigeri 11 months ago

I still find it important to check this assumption you made at the summit because it might greatly influence how we design the incentives to donate (and without data we might debate endlessly or make wrong decisions),

Agreed. Note that the data we already have tells us that "people who are running Firefox on Windows or Tor Browser donate 50% less through PayPal than everyone else". These 50% less must come from somewhere so either users of Firefox on Windows donate less, or people donate less using Tor Browser, or both. Of course we have no way to tell but I find it hard to believe that "Firefox on Windows" is the determining factor. Anyway, let's wait until we have actual data :)

but hopefully we should be able to do this once we have #14877, so I'll keep this ticket open for analysis of the upcoming campaign.

I think you meant something else than #14877 here. To get the data we need, I believe we'll need something that analyzes traffic on our website with access to both the User-Agent string and the IP, so that it can sort Tor connections out from non-Tor connections.

#7 Updated by sajolida 11 months ago

I think you meant something else than #14877 here.

Oops, I meant #15964: It will give us a count and a conversion rate on
?r=home, the banner on /home being somehow the root of the controversy here.

To get the data we need, I believe we'll need something that analyzes traffic on our website with access to both the User-Agent string and the IP, so that it can sort Tor connections out from non-Tor connections.

Right, that would be the best and also take into account donations from
elsewhere than /home.

#8 Updated by intrigeri 11 months ago

Oops, I meant #15964: It will give us a count and a conversion rate on ?r=home, the banner on /home being somehow the root of the controversy here.

Right, excellent! I forgot about it.

To get the data we need, I believe we'll need something that analyzes traffic on our website with access to both the User-Agent string and the IP, so that it can sort Tor connections out from non-Tor connections.

Right, that would be the best and also take into account donations from elsewhere than /home.

… but ?r=home will be good enough :)

#9 Updated by sajolida 10 months ago

  • Target version set to Tails_3.12

#10 Updated by sajolida 8 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#11 Updated by sajolida 5 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#12 Updated by sajolida 5 months ago

  • Subject changed from Analyze conversion rate of PayPal donations for people using Tor Browser to Analyze the conversion rate of PayPal donations from /home

#13 Updated by sajolida 4 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Dev Needed)

It's actually slightly higher than average. So yes, people donate from inside Tails, even with PayPal.

#14 Updated by intrigeri 4 months ago

It's actually slightly higher than average. So yes, people donate from inside Tails, even with PayPal.

Wow, I'm impressed and happy we have actual data that proves my intuition was totally wrong!! :)

Now, whether these Tails users understand the trade-off they're making or not, is another question…

#15 Updated by intrigeri 4 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#16 Updated by anonym 4 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#17 Updated by intrigeri 4 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF