Project

General

Profile

Bug #15958

devel branch FTBFS since torbrowser-launcher 0.2.9-5 is in sid

Added by intrigeri 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
09/18/2018
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
torbrowser-launcher:bugfix/15958-torbrowser-launcher-0.2.9-5, bugfix/15958-torbrowser-launcher-0.2.9-5+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Related issues

Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018

Associated revisions

Revision 2e777e42 (diff)
Added by intrigeri 8 months ago

Tor Browser AppArmor profile patch: update to apply cleanly on top of torbrowser-launcher 0.2.9-5 (refs: #15958).

And in passing: deduplicate custom stuff in favour of what I've upstreamed
and remove obsolete bits about the plugin-container executable.

Revision a2bbaa1f
Added by intrigeri 8 months ago

Merge branch 'bugfix/15958-torbrowser-launcher-0.2.9-5+force-all-tests' into devel (Fix-committed: #15958)

History

#1 Updated by intrigeri 8 months ago

#2 Updated by intrigeri 8 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to torbrowser-launcher:bugfix/15958-torbrowser-launcher-0.2.9-5, bugfix/15958-torbrowser-launcher-0.2.9-5+force-all-tests

#3 Updated by intrigeri 8 months ago

  • Assignee changed from intrigeri to segfault
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

Only unrelated failures during a full test suite run.

#4 Updated by segfault 8 months ago

  • Assignee changed from segfault to intrigeri
  • QA Check changed from Ready for QA to Pass

LGTM, but I wonder why the branch is based on devel. I expected it to be based on stable, because its a bug fix.

#5 Updated by intrigeri 8 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100

segfault wrote:

LGTM,

Thank you. Merged!

but I wonder why the branch is based on devel. I expected it to be based on stable, because its a bug fix.

The bug only applies to devel: stable has frozen APT repos that do not include this torbrowser-launcher upgrade :)

#6 Updated by segfault 8 months ago

intrigeri wrote:

The bug only applies to devel: stable has frozen APT repos that do not include this torbrowser-launcher upgrade :)

Oh, right facepalm

#7 Updated by intrigeri 8 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.9.1

#8 Updated by anonym 8 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF