Project

General

Profile

Feature #15927

Feature #14468: Add VeraCrypt support to Tails

Document that VeraCrypt PIM will only be supported in Tails 4.0

Added by segfault about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/09/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

Users complain that the PIM is not supported in 3.9. We know that the PIM is only supported if cryptsetup 2.0 is installed, which will be the case in Tails 4.0. I suggest we add a note about this to the known issues of 3.9.

History

#1 Updated by intrigeri about 1 year ago

  • Assignee set to sajolida
  • Target version set to Tails_3.10.1
  • Parent task set to #14468
  • Type of work changed from Website to End-user documentation

#2 Updated by intrigeri about 1 year ago

  • Assignee changed from sajolida to segfault
  • QA Check set to Info Needed

Note that https://tails.boum.org/doc/encryption_and_privacy/veracrypt/ documents this limitation already. Good enough?

By the way, why do we expose the PIM option to users if we don't support it? It feels a bit unpolished and as you said, it confuses users. How hard would it be to hide the corresponding widgets?

#3 Updated by segfault about 1 year ago

  • Assignee changed from segfault to sajolida
  • QA Check deleted (Info Needed)

intrigeri wrote:

Note that https://tails.boum.org/doc/encryption_and_privacy/veracrypt/ documents this limitation already. Good enough?

My suggestion was to add it to the known issues of 3.9, so that testers would stop reporting it. But I didn't get that many reports about it and none since a few days, so maybe it's not that important.

By the way, why do we expose the PIM option to users if we don't support it? It feels a bit unpolished and as you said, it confuses users. How hard would it be to hide the corresponding widgets?

I know it's ugly, but it's pretty hard to fix.

To hide the PIM option in Disks, I think we would have to add a property or method to the udisks D-Bus bus, which tells Disks whether it supports the PIM or not.

Hiding the PIM option in GNOME Shell is even harder, because the Shell doesn't talk to udisks directly. We think we would have to patch at least GVfs and probably also GTK and GLib.

#4 Updated by segfault about 1 year ago

Hiding the PIM option in GNOME Shell

I mean adjusting the note about the PIM in GNOME Shell

#5 Updated by intrigeri about 1 year ago

  • Assignee changed from sajolida to segfault
  • QA Check set to Info Needed

By the way, why do we expose the PIM option to users if we don't support it? It feels a bit unpolished and as you said, it confuses users. How hard would it be to hide the corresponding widgets?

I know it's ugly, but it's pretty hard to fix.

To hide the PIM option in Disks, I think we would have to add a property or method to the udisks D-Bus bus, which tells Disks whether it supports the PIM or not.

Hiding the PIM option in GNOME Shell is even harder, because the Shell doesn't talk to udisks directly. We think we would have to patch at least GVfs and probably also GTK and GLib.

Thank you for the quick turnaround :) But — sorry I was unclear! — actually I meant unconditionally hiding these widgets in our Stretch backports of the relevant packages, not cleverly hiding them iff. PIM is not supported. Is that hard as well?

#6 Updated by segfault about 1 year ago

intrigeri wrote:

Thank you for the quick turnaround :) But — sorry I was unclear! — actually I meant unconditionally hiding these widgets in our Stretch backports of the relevant packages, not cleverly hiding them iff. PIM is not supported. Is that hard as well?

No, that's not hard. I can do that for 3.10.

#7 Updated by sajolida about 1 year ago

I did that in doc/15927-pim-in-known-issues.

Note that it was already mentioned in /doc/encryption_and_privacy/veracrypt.

#8 Updated by segfault 11 months ago

  • Assignee changed from segfault to sajolida

segfault wrote:

intrigeri wrote:

Thank you for the quick turnaround :) But — sorry I was unclear! — actually I meant unconditionally hiding these widgets in our Stretch backports of the relevant packages, not cleverly hiding them iff. PIM is not supported. Is that hard as well?

No, that's not hard. I can do that for 3.10.

I created #16031 to track this.

I did that in doc/15927-pim-in-known-issues.

What's the status of this? I see that it wasn't merged yet. Are you waiting for a review?

#9 Updated by intrigeri 11 months ago

I did that in doc/15927-pim-in-known-issues.

What's the status of this? I see that it wasn't merged yet. Are you waiting for a review?

I suspect the doc may be phrased differently depending on whether we display a non-working PIM option (as in 3.9.1) or we don't display it at all (#16031). So that's why I (and maybe sajolida too) were waiting for your input/code before moving forward on the doc side.

#10 Updated by sajolida 11 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Info Needed)

My branch doc/15927-pim-in-known-issues was copying the note that we already have in the VeraCrypt documentation to the known issues for 3.9. Now that 3.9.1, I think it doesn't make much sense to add it there. So let's close this ticket.

#11 Updated by intrigeri 11 months ago

I've thus deleted the doc/15927-pim-in-known-issues branch so Jenkins stops wasting time on it :)

Also available in: Atom PDF