Project

General

Profile

Bug #15914

Update (or remove) some manual Thunderbird tests

Added by intrigeri 11 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
09/05/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:
Email Client

Description

We have a manual test that relies on having access to a non-anonymizing SMTP relay, i.e. a SMTP relay that writes the IP address of the client it is relaying email for in the Received header: check that Thunderbird really torifies SMTP connections, by looking at the Received header → that's not necessary anymore since the corresponding automated tests have the check_tor_leaks tag so a proxy + firewall bypass would be noticed.

And we also check that the EHLO/HELO SMTP message is not leaking anything at the application level, that currently relies on using a SMTP relay that either supports non-TLS connections (emma peel tells me she could not find one) or that supports StartTLS. emma peel suggested we drop the first option that's impractical and I agree… unless there are common .onion SMTP services without TLS (Riseup?).

The manual test suite is: https://tails.boum.org/contribute/release_process/test/

The branch should be based on master so we can merge it without waiting for a specific release.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

Associated revisions

Revision b9e9667b (diff)
Added by intrigeri 4 months ago

Remove manual Thunderbird test that's been automated (refs: #15914)

The corresponding automated tests have the check_tor_leaks tag so a proxy
and firewall bypass would be noticed.

Revision 2e14a7d9 (diff)
Added by intrigeri 4 months ago

Drop impractical option in Thunderbird manual test suite (refs: #15914)

It's pretty hard to find SMTP relays that support delivery over cleartext SMTP
these days (thankfully). Let's focus on the most realistic option.

History

#1 Updated by intrigeri 11 months ago

#2 Updated by intrigeri 11 months ago

  • Description updated (diff)

#3 Updated by intrigeri 11 months ago

  • Assignee changed from intrigeri to segfault

Do you want this one?

#4 Updated by segfault 9 months ago

  • Assignee changed from segfault to intrigeri
  • QA Check set to Info Needed

Do you want this one?

This doesn't have to be finished for 3.10, right? In that case, I would take it, but work on it post-3.10.

#5 Updated by intrigeri 9 months ago

  • Assignee changed from intrigeri to segfault
  • Target version changed from Tails_3.10.1 to Tails_3.12
  • QA Check changed from Info Needed to Dev Needed

This doesn't have to be finished for 3.10, right? In that case, I would take it, but work on it post-3.10.

Yes, this can wait a bit (I'll handle the issue with the current manual test suite during the 3.10 and 3.11 release, somehow) ⇒ please work on this once your VeraCrypt and USB image work is done :) Thanks!

#6 Updated by segfault 8 months ago

  • Target version changed from Tails_3.12 to Tails_3.11

#7 Updated by CyrilBrulebois 7 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#8 Updated by intrigeri 7 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#9 Updated by segfault 4 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#10 Updated by intrigeri 4 months ago

#11 Updated by intrigeri 4 months ago

#12 Updated by intrigeri 4 months ago

  • Status changed from Confirmed to In Progress

#13 Updated by intrigeri 4 months ago

  • QA Check changed from Dev Needed to Ready for QA

It was cheaper for me to do it than to bother doing useless manual tests during the 3.13.1 release process ⇒ pushed two commits to master (see "Associated revisions" above). Please review :)

#14 Updated by segfault 4 months ago

  • Assignee changed from segfault to intrigeri
  • QA Check changed from Ready for QA to Info Needed

Regarding b9e9667bb2e5ce97c9be0d253978d00500eb8766:
In the commit message you say that the test has been automated, but I can't find an automated test that checks a Received header. Could you point me to that?

#15 Updated by intrigeri 4 months ago

  • Assignee changed from intrigeri to segfault
  • QA Check changed from Info Needed to Ready for QA

Regarding b9e9667bb2e5ce97c9be0d253978d00500eb8766: In the commit message you say that the test has been automated, but I can't find an automated test that checks a Received header. Could you point me to that?

@segfault, we have no tests that specifically about the Received header, but that's not really the point here: in our manual test suite, we were using that header only as a way to try & detect a potential firewall+proxy bypass (recorded by the outgoing SMTP server) when sending email. Given our test suite exercises sending email in a test that has the check_tor_leaks tag, if we introduced such a regression, we would detect such a bypass directly via the test suite, instead of indirectly via the Received header.

#16 Updated by segfault 4 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (segfault)
  • QA Check deleted (Ready for QA)

@segfault, we have no tests that specifically about the Received header, but that's not really the point here: in our manual test suite, we were using that header only as a way to try & detect a potential firewall+proxy bypass (recorded by the outgoing SMTP server) when sending email. Given our test suite exercises sending email in a test that has the check_tor_leaks tag, if we introduced such a regression, we would detect such a bypass directly via the test suite, instead of indirectly via the Received header.

I see. Review passes, setting status to resolved because it's already merged in master.

#17 Updated by intrigeri 2 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#18 Updated by anonym 2 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#19 Updated by intrigeri 2 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF