Project

General

Profile

Bug #15911

Feature #14568: Additional Software Packages

Leftover config/chroot_local-includes/usr/share/polkit-1/actions/org.boum.tails.additional-software.policy in Git

Added by intrigeri 12 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/04/2018
Due date:
% Done:

100%

Feature Branch:
bugfix/15911-leftover-asp-policy
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

6818d283b8193b6ca6931f375bc34e5373984734 on the bugfix/14598-asp-review-bugs branch adds config/chroot_local-includes/usr/share/polkit-1/actions/org.boum.tails.additional-software.policy.in but ./config/chroot_local-includes/usr/share/polkit-1/actions/org.boum.tails.additional-software.policy is still tracked in Git. I guess that's an oversight since that file will be auto-generated at build time, no?

Associated revisions

Revision 4a606d84 (diff)
Added by CyrilBrulebois 10 months ago

Remove leftover file (refs: #15911).

This file was made translatable in this commit (through a .in file added
alongside, and its addition to po/POTFILES.in): | commit 6818d283b8193b6ca6931f375bc34e5373984734 | Author: Alan <> | Date: Sun Aug 26 12:59:10 2018 +0000 | | ASP: make policykit action translatable | | Will-fix: #14598

but the target script wasn't removed from git accordingly. Let's fix this.

Revision 9d852d94 (diff)
Added by alant 10 months ago

ASP: ignore policy file managed by intltool

Will-fix: #15911

Revision 73af7766
Added by intrigeri 10 months ago

Merge remote-tracking branch 'origin/bugfix/15911-leftover-asp-policy' into stable (Fix-committed: #15911)

History

#1 Updated by u 10 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#2 Updated by CyrilBrulebois 10 months ago

The leftover file appeared as modified by the po refresh process, on my way to release 3.10; currently considering removing this file before the 3.10 release.

#3 Updated by segfault 10 months ago

IMO the fix is to 1. remove the file, and 2. add the path to .gitignore, in the # Files managed by intltool section, so that it is ignored if it's created by refresh-translations.

#4 Updated by CyrilBrulebois 10 months ago

  • Status changed from Confirmed to In Progress

#5 Updated by alant 10 months ago

  • Assignee changed from alant to CyrilBrulebois
  • % Done changed from 0 to 30
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/15911-leftover-asp-policy

The file is recreated by update-translations so I added it to .gitignore.

#6 Updated by intrigeri 10 months ago

  • Assignee changed from CyrilBrulebois to intrigeri

#7 Updated by intrigeri 10 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 30 to 100
  • QA Check changed from Ready for QA to Pass

#8 Updated by u 10 months ago

  • Parent task changed from #15567 to #14568

Thanks! I am unparenting this because it makes my life easier :)

#9 Updated by CyrilBrulebois 8 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF