Project

General

Profile

Bug #15905

JavaScript disabled by default on recent builds from testing

Added by intrigeri about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
09/02/2018
Due date:
% Done:

10%

Feature Branch:
feature/15907-tor-browser-8.0+force-all-tests
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Browser

Description

As per #15803#note-17.


Related issues

Related to Tails - Bug #17007: JavaScript sometimes blocked on Tor Browser first start ⇒ "Watching a WebM video over HTTPS" and "Playing an Ogg audio track" scenarios are fragile: blocked by NoScript click-to-play Confirmed
Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018
Blocked by Tails - Bug #15907: Upgrade Tor Browser to 8.0 final Resolved 09/03/2018

History

#1 Updated by intrigeri about 1 year ago

#2 Updated by intrigeri about 1 year ago

sajolida: tl;dr I'll need you to test an ISO tomorrow (Monday) — most likely I won't be able to reproduce the bug myself so I won't be able to validate the fix either :/

Note to myself: a few days ago I could not reproduce this but the problem seems to be a race condition so there's a chance that the problem shows up for sajolida and not for me. Since then lots of changes in this very area were made in Tor Browser (https://trac.torproject.org/projects/tor/ticket/26520 and the follow-up https://trac.torproject.org/projects/tor/ticket/27401 fix) so I'm hopeful. I'll test the latest Tor Browser tomorrow but even if I cannot reproduce, that won't mean much, so I'll need other people to test as well.

#3 Updated by intrigeri about 1 year ago

  • Blocked by Bug #15907: Upgrade Tor Browser to 8.0 final added

#4 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

As expected I can't reproduce this with my tails-amd64-testing-3.9-20180902T2051Z-0db0bd1299.iso build so I won't be able to confirm myself that the fixes work.

#5 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to sajolida
  • QA Check set to Info Needed
  • Feature Branch set to feature/15907-tor-browser-8.0+force-all-tests

Can you please test an ISO from https://nightly.tails.boum.org/build_Tails_ISO_feature-15907-tor-browser-8.0-force-all-tests/lastSuccessful/archive/build-artifacts/ and see if that fixes the problem for you?

I can't reproduce the bug there but again, I could not reproduce it before either :/

#6 Updated by intrigeri about 1 year ago

  • Assignee changed from sajolida to intrigeri

#7 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to sajolida

intrigeri wrote:

Can you please test an ISO from https://nightly.tails.boum.org/build_Tails_ISO_feature-15907-tor-browser-8.0-force-all-tests/lastSuccessful/archive/build-artifacts/ and see if that fixes the problem for you?

There you go, ready for testing! :)

#8 Updated by intrigeri about 1 year ago

  • QA Check changed from Info Needed to Ready for QA

atomike and muri both tried a recent build from testing and another one from this branch, and could not reproduce the bug in any of these tests. So far you're the only one who can tell me whether this branch improves things for you.

#9 Updated by sajolida about 1 year ago

  • Status changed from In Progress to Fix committed
  • QA Check deleted (Ready for QA)

That's solved for me in 3.9 (the tentative ISO)!

#10 Updated by intrigeri about 1 year ago

That's solved for me in 3.9 (the tentative ISO)!

Amazing, thanks!

#11 Updated by intrigeri about 1 year ago

  • Status changed from Fix committed to Resolved

#12 Updated by intrigeri about 1 month ago

  • Related to Bug #17007: JavaScript sometimes blocked on Tor Browser first start ⇒ "Watching a WebM video over HTTPS" and "Playing an Ogg audio track" scenarios are fragile: blocked by NoScript click-to-play added

Also available in: Atom PDF