Project

General

Profile

Feature #15898

Update website with new roadmap

Added by Anonymous over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/02/2018
Due date:
% Done:

100%

Feature Branch:
web/15898-update-roadmap
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:

Related issues

Blocked by Tails - Feature #15920: Lead our roadmapping process to completion Resolved 09/06/2018
Blocks Tails - Feature #15931: Write blog posts about achievement Resolved 09/10/2018

Associated revisions

Revision 01134c8c
Added by intrigeri over 1 year ago

Merge remote-tracking branch 'origin/web/15898-update-roadmap' (Closes: #15898)

History

#1 Updated by sajolida over 1 year ago

  • Target version changed from 2018 to Tails_3.10.1

Indeed! Thanks for reminding me :)

#2 Updated by intrigeri over 1 year ago

  • Blocked by Feature #15920: Lead our roadmapping process to completion added

#3 Updated by intrigeri over 1 year ago

I need to do #15920 first. FYI I'll try to start it tomorrow and to complete it within a month so we can have an updated roadmap live in October.

#4 Updated by sajolida over 1 year ago

#5 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Ready for QA
  • Feature Branch set to web/15898-update-roadmap

I started preparing something even though the process of #15920 is not 100% done. I bet it'll be quite fast to update to the latest changes.

As usual, I felt a tension between being exhaustive on /contribute/roadmap and not having too much noise by including too much small, invisible, or internal stuff. So I've left some items in a comment for now.

For example, I wonder if all the fundraising items that we have are worth being put on /contribute/roadmap. Maybe I would keep all this internal.

What do you think?

#6 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Dev Needed

I started preparing something even though the process of #15920 is not 100% done. I bet it'll be quite fast to update to the latest changes.

Good idea (especially I had claimed I would finalize #15920 2 days ago and I've been late; now it's done :)

As usual, I felt a tension between being exhaustive on /contribute/roadmap and not having too much noise by including too much small, invisible, or internal stuff. So I've left some items in a comment for now.

For example, I wonder if all the fundraising items that we have are worth being put on /contribute/roadmap. Maybe I would keep all this internal.

I agree all the fundraising bits you've put in a comment at the bottom should not be listed here. But I see value in keeping "Funding from private partners": sometimes we need to prove to potential sponsors that we are seriously working on diversifying our sources of income.

What do you think?

Great! A few minor comments:

  • #15875 will be done "if it's cheap to implement" so I'm not sure we should list it here.
  • wrt. #16035 the explanation is incorrect and the correct one is probably too technical for this document
  • "**Upgrade our automated test suite** to Java 9" feels misleading (most likely, the work needs to be done in Debian and not in our test suite). What about "**Upgrade dependencies of our automated test suite** so they work with Java 9"?

Apart of that, next step is to update the list wrt. what just got dropped from our roadmap due to incomplete teams and then I bet we can merge this after one last round of review :)

#7 Updated by sajolida over 1 year ago

I agree all the fundraising bits you've put in a comment at the bottom should not be listed here. But I see value in keeping "Funding from private partners": sometimes we need to prove to potential sponsors that we are seriously working on diversifying our sources of income.

I rephrase this section accordingly in ef1cd4a2d3.

  • #15875 will be done "if it's cheap to implement" so I'm not sure we should list it here.

I added an if in 65b7f548bc. Note that many other items in the document
comes with an "if" as well, like all the ones for the bigger grant.

  • wrt. #16035 the explanation is incorrect and the correct one is probably too technical for this document

I removed this line with 6e670f87ed.

  • "**Upgrade our automated test suite** to Java 9" feels misleading (most likely, the work needs to be done in Debian and not in our test suite). What about "**Upgrade dependencies of our automated test suite** so they work with Java 9"?

I fixed this with 8b2dcf3cfd.

Apart of that, next step is to update the list wrt. what just got dropped from our roadmap due to incomplete teams and then I bet we can merge this after one last round of review :)

Done in 73db0b904a.

#8 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

#9 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

Great, merged!

Also available in: Atom PDF