Project

General

Profile

Bug #15895

Remove our predefined bookmarks

Added by sajolida about 1 year ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
09/02/2018
Due date:
% Done:

100%

Feature Branch:
feature/15895-remove-custom-bookmarks+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

I see in Tails 3.9 the following bookmarks embedded in Tails:

Now that we have good support for bookmarks in Persistence, I think we should review this list.

  • I don't think it should be a place to link the email providers our team historically liked the most.
  • I don't think that the Tor stack exchange is an official support channel anymore.

We'd be left with:

Going a bit futher:

  • Searching for "Tails" or "Tor Project" in the URL bar points you to https://tails.boum.org/ and https://www.torproject.org/. I think that's what the majority of our users will do instead of looking for it in the bookmark menu.
  • Our documentation is already linked from the desktop and the Applications menu.

So if we want, I don't think we would miss much by getting rid of this file completely. It's a SQL dump that seems painful to maintain, so that might be a good move.


Related issues

Related to Tails - Feature #5870: Better support of non-commercial ISPs Rejected

Associated revisions

Revision 803c40ec (diff)
Added by intrigeri 3 months ago

Ship default upstream Tor Browser bookmarks instead of an empty set (refs: #15895).

Revision 23863ff2
Added by intrigeri 3 months ago

Merge remote-tracking branch 'origin/feature/15895-remove-custom-bookmarks+force-all-tests' into stable

Fix-committed: #15895

Revision 5120693b (diff)
Added by intrigeri 3 months ago

Ship default upstream Tor Browser bookmarks instead of an empty set (refs: #15895).

History

#1 Updated by intrigeri about 1 year ago

  • Assignee set to sajolida

I doubt someone else than you will lead this discussion within the time constraints (target version) you've set.

#2 Updated by letthemeatpie about 1 year ago

"I don't think it should be a place to link the email providers our team historically liked the most." (sorry, tried the Quote button, it gave me an error)

Agreed.

#3 Updated by letthemeatpie about 1 year ago

OTOH, this would be another great place to link about/for donations! _

#4 Updated by sajolida about 1 year ago

OTOH, this would be another great place to link about/for donations! _

+1, if we keep the custom bookmarks we could add one to our donation page.

On the other hand, we're providing people using Tails other much better
pointers to our donation page (eg. /home) so I don't think it will make
a significant difference. So I would definitely not keep this
customization just for that :)

#5 Updated by sajolida 12 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

I won't be able to discuss this before the December meeting.

#6 Updated by sajolida 10 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#7 Updated by sajolida 9 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#8 Updated by sajolida 7 months ago

  • Subject changed from Remove some of our predefined bookmarks to Remove our predefined bookmarks

#9 Updated by sajolida 7 months ago

With the deprecation of monthly meetings, we're left with mailing lists for such discussions. I raised the point on tails-dev.

#10 Updated by intrigeri 7 months ago

+1

#11 Updated by sajolida 7 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#12 Updated by intrigeri 7 months ago

#13 Updated by intrigeri 7 months ago

  • Related to Feature #5870: Better support of non-commercial ISPs added

#14 Updated by intrigeri 7 months ago

  • Related to deleted (Feature #5810: Fix files' associations)

#15 Updated by sajolida 6 months ago

Nobody followed up on my question to tails-dev:

http://lists.autistici.org/message/20190308.075800.b7154a0e.en.html

So I'll submit a branch at some point.

#16 Updated by sajolida 5 months ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to feature/15895-remove-custom-bookmarks

#17 Updated by CyrilBrulebois 5 months ago

  • Target version changed from Tails_3.14 to Tails_3.15

#18 Updated by intrigeri 5 months ago

sajolida wrote:

You mean typing one of these strings, then Enter, to search it with DuckDuckGo, right? If you instead mean that you see this completion happen without pressing Enter: that's precisely because we have bookmarks for these websites and I doubt it would work if/once we drop them.

#19 Updated by sajolida 5 months ago

You mean typing one of these strings, then Enter, to search it with DuckDuckGo, right?

Yes.

#20 Updated by sajolida 4 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (sajolida)
  • Type of work changed from Discuss to Code

Builds and tested :)

#21 Updated by intrigeri 4 months ago

@anonym, @segfault: any taker? If this feels too risky/invasive for a bugfix release, feel free to merge into feature/buster instead of stable.

#22 Updated by intrigeri 3 months ago

  • Assignee set to intrigeri

#23 Updated by intrigeri 3 months ago

  • Feature Branch changed from feature/15895-remove-custom-bookmarks to feature/15895-remove-custom-bookmarks+force-all-tests

I have cherry-picked the relevant commit in a new branch because:

  • The original branch was forked off devel. If we merge into devel we won't release this before our next major release, on Oct 22. I guess that was not sajolida's intent.
  • This affects Tor Browser and most automated tests about the browser are tagged fragile, so they don't run on Jenkins unless we're on a branch with the +force-all-tests suffix. I'd like to see automated test results before we merge this.

Will now code review and if that passes, I'll build & test manually a little bit.

#24 Updated by intrigeri 3 months ago

IMO, ideally while doing this we would ship Tor Browser's default bookmarks instead of an empty set of bookmarks. It would simplify our codebase a little (no need to maintain this sqlite dump anymore) and would reduce our delta with upstream, which in general is nice for users who use Tor Browser both in Tails and outside of Tails. @sajolida, do you agree?

I've implemented it on the branch and we'll see what Jenkins thinks.

#25 Updated by intrigeri 3 months ago

  • Status changed from Needs Validation to In Progress

#26 Updated by intrigeri 3 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to sajolida

The bookmarks-related tests pass on Jenkins so either sajolida agrees with my reasoning above (and then I'll request a review from FT for my additional commits) or he does not (and then I'll merge sajolida's work as-is).

#27 Updated by segfault 3 months ago

Code review passes

#28 Updated by sajolida 3 months ago

  • Target version changed from Tails_3.15 to Tails_3.16

#29 Updated by sajolida 3 months ago

IMO, ideally while doing this we would ship Tor Browser's default bookmarks instead of an empty set of bookmarks. It would simplify our codebase a little (no need to maintain this sqlite dump anymore) and would reduce our delta with upstream, which in general is nice for users who use Tor Browser both in Tails and outside of Tails. @sajolida, do you agree?

Oh no! I'm feeling bad about having you do some more work on this branch
that is super low prio and which I started just for fun.

I agree with your approach and shipping the default bookmarks in Tor
which also simplies our codebase (one of my initial goals).

#30 Updated by sajolida 3 months ago

  • Assignee changed from sajolida to intrigeri

Now you still have to merge, right?

#31 Updated by intrigeri 3 months ago

Now you still have to merge, right?

Yes, someone should merge into stable→devel once the release process for 3.15 is over.

#32 Updated by intrigeri 3 months ago

Oh no! I'm feeling bad about having you do some more work on this branch that is super low prio and which I started just for fun.

OK, next time I'll only review and will let you complete the work you started (or decide it's not worth the effort).

I agree with your approach and shipping the default bookmarks in Tor which also simplies our codebase (one of my initial goals).

:)

#33 Updated by intrigeri 3 months ago

  • Status changed from Needs Validation to Fix committed
  • % Done changed from 0 to 100

#34 Updated by intrigeri 3 months ago

  • Status changed from Fix committed to In Progress

#35 Updated by intrigeri 2 months ago

  • Status changed from In Progress to Fix committed

#36 Updated by CyrilBrulebois about 1 month ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF