Project

General

Profile

Bug #15834

3.9rc1: gvfs-bin (and presumably other) dependency tangles

Added by blue9 9 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/23/2018
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Apologies if this has been reported elsewhere or if it belongs here. Most of that thread is beyond my ken...

The gvfs-bin package has a strict dependency on gvfs-common=1.30.4-1. While most packages that depend on gvfs-bin seem to be flexible, and are happy to work with gvfs-bin=1.30.4-1.0tails5, they still error on installation through apt. I assume this is due to the above mentioned strict dependency, but I could be wrong.

To reproduce: sudo apt install gedit-latex-plugin

(This issue also blocks the installation of the atom text editor, either through sudo dpkg -i or through apt after adding a package repository that contains the atom package.)

Workaround:

  • sudo apt install gvfs-bin=1.30-4.1.0tails5
  • Click Install Every Time to add `gvfs-bin to .../live-additional-software.conf. (This prevents ASP hooks from asking whether or not to persist gvfs-bin when subsequently starting Tails with persistence enabled.)
  • Manually add gvfs-bin=1.30.4-1.0tails5 to .../live-additional-software.conf. (This reinstalls the Tails-maintained package when starting Tails with persistence enabled. For the two packages I tested, this works fine.)

Related issues

Blocked by Tails - Bug #15837: APT is not configured to install packages from our repo Resolved 08/24/2018
Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018

Associated revisions

Revision f3912498
Added by intrigeri 8 months ago

Merge branch 'bugfix/15837-fix-apt-preferences+force-all-tests' into stable (Fix-committed: #15837, #15834)

History

#1 Updated by intrigeri 9 months ago

  • Status changed from New to Confirmed
  • Assignee set to segfault
  • Target version set to Tails_3.9

Hey segfault, this seems to be a regression unexpectedly caused by shipping custom packages for VeraCrypt support. Can you please look into it?

#2 Updated by segfault 9 months ago

  • Blocked by Bug #15837: APT is not configured to install packages from our repo added

#3 Updated by segfault 9 months ago

This seems to be caused by #15837

#4 Updated by segfault 9 months ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

#5 Updated by segfault 9 months ago

FTR: This is not a regression in 3.9, and the root cause is not our custom VeraCrypt packages

#6 Updated by intrigeri 8 months ago

#7 Updated by intrigeri 8 months ago

  • Subject changed from 3.9rc1: gvfs-bin (and presumbly other) dependency tangles to 3.9rc1: gvfs-bin (and presumably other) dependency tangles
  • Status changed from Confirmed to Fix committed
  • Assignee deleted (segfault)
  • % Done changed from 0 to 100
  • QA Check set to Pass

Fixed via #15837 :)

#8 Updated by intrigeri 8 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.9.1

#9 Updated by anonym 8 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF