Project

General

Profile

Bug #15833

Regression in 3.9~rc1 on some NVIDIA Pascal graphics cards

Added by intrigeri 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Hardware support
Target version:
Start date:
08/22/2018
Due date:
% Done:

100%

Feature Branch:
bugfix/15833-revert-to-stretch-nouveau-driver
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

This is being discussed on tails-testers@ (Subject: Nvidia Pascal no longer loads gdm) + I've received some more data privately (Subject: Clean Tails 3.8 Nvidia Pascal dump.


Related issues

Related to Tails - Bug #14910: NVIDIA Pascal series graphic card: slow graphics operations Resolved 10/31/2017
Related to Tails - Bug #15116: X.Org does not start with some NVidia Maxwell and Pascal graphic cards Confirmed 12/27/2017
Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018

Associated revisions

Revision 56046f50 (diff)
Added by intrigeri 11 months ago

Revert to Stretch's X.Org nouveau video driver (refs: #15833)

It seems that the regression brought by the upgraded one
is worse than the improvements reported after my call for testing.

Revision a1a3fb52
Added by intrigeri 11 months ago

Merge branch 'bugfix/15833-revert-to-stretch-nouveau-driver' into testing-integration+force-all-tests (Fix-committed: #15833)

History

#1 Updated by intrigeri 11 months ago

#2 Updated by intrigeri 11 months ago

  • Description updated (diff)

#3 Updated by intrigeri 11 months ago

  • Description updated (diff)

#4 Updated by intrigeri 11 months ago

GTX 1070 ti aka. 07:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP104 [10de:1b82] (rev a1) aka. NV134:

  • in 3.8, "ran stable, if poorly", using the modesetting X.Org driver in Tails 3.8 because Unknown chipset: NV134 and [drm] Failed to open DRM device for pci:0000:07:00.0: -13
  • in 3.9~rc1, various issues that the OP is debugging and sending me info about

#5 Updated by intrigeri 11 months ago

  • Related to Bug #14910: NVIDIA Pascal series graphic card: slow graphics operations added

#6 Updated by intrigeri 11 months ago

  • Related to Bug #15116: X.Org does not start with some NVidia Maxwell and Pascal graphic cards added

#7 Updated by intrigeri 11 months ago

The call for testing for the nouveau upgrade showed only 1 significant improvement that was improved performance on GTX 1080.

But now we see a severe regression with GTX 1070 ti: GDM won't load unless one pass:

  • either modeset=0, which makes X.Org fall back to the fbdev driver
  • or live-config.xorg-driver=modesetting

The latter is probably better.

#8 Updated by intrigeri 11 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/15833-revert-to-stretch-nouveau-driver

#9 Updated by intrigeri 11 months ago

  • Assignee changed from intrigeri to segfault
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

According to Soul Null's report on the topic branch on GTX 1070 ti:

  • If we "downgrade" the nouveau driver to the version from Stretch that was shipped in Tails 3.8, we're back to square one i.e. Tails boots fine, uses the modesetting driver, and #14910 is back.
  • Even with the newest version of everything involved (Arch Linux), there are lots of stability issues on GTX 1070 Ti and GTX 710 when using the nouveau driver, which suggests that the ecosystem is not ready to support this hardware properly.

According to #15116#note-42 (the single substantial improvement reported about the nouveau driver upgrade) and #14910#note-16, on 3.9~rc1 and GTX 1080, performance is better but there are still a number of bugs.

Improving performance on one graphics card model is not worth breaking X.Org startup so let's revert to the nouveau driver from Stretch. Once this is merged we should reopen #14910.

#10 Updated by intrigeri 11 months ago

  • Type of work changed from Research to Code

#11 Updated by segfault 11 months ago

Code review passes, will test this later today

#12 Updated by intrigeri 11 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#13 Updated by segfault 11 months ago

  • Assignee changed from segfault to intrigeri
  • QA Check changed from Ready for QA to Pass

Works on my hardware

#14 Updated by intrigeri 11 months ago

  • Assignee deleted (intrigeri)

Thx!

#15 Updated by intrigeri 11 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF