Project

General

Profile

Bug #15822

Feature #14568: Additional Software Packages

Bug #15567: Fix bugs and UX issues in the Additional Software beta

Install notification of Additional Software is not handling target release

Added by sajolida 9 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/20/2018
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/14598-asp-review-bugs
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

In my live-additional-software.conf I have ikiwiki/sid.

The target version (sid) is passed correctly to apt install and ikiwiki from sid is being installed.

But I also get a notification asking me whether I want to install it every time. See screenshot in attachment.

So it seems to me that the APT hook of Additional Software doesn't handle well target releases.

In the logs I have:

Aug 20 07:54:18 amnesia tails-additiona[4882]: [INFO] New packages manually installed: {'ikiwiki'}
  • It should at least respect target releases when entered manually in live-additional-software.conf. It doesn't make sense to have two different versions of the same package installed. So, in my case for example, the APT hook should detect that I already have ikiwiki in my live-additional-software.conf though it's called ikiwiki/sid.
  • Ideally, it should process ikiwiki/sid as being manually installed and not only ikiwiki so it can add the target version to live-additional-software.conf.

ikiwiki.png View (13.8 KB) sajolida, 08/20/2018 08:09 AM


Related issues

Related to Tails - Bug #16298: Additional Software is not saving target release Confirmed 01/05/2019

Associated revisions

Revision 63397628 (diff)
Added by alant 9 months ago

ASP: fix package details filtering

Will-fix: #15822

Revision 80e7496f (diff)
Added by alant 9 months ago

ASP: also gracefully remove ASP with target version

Will-fix: #15822

Revision a25c5aac (diff)
Added by alant 9 months ago

ASP: import fixed tailslib

This should fix the build of the last fix for #15822.

Will-fix #15822.

Revision 268e3f78 (diff)
Added by alant 9 months ago

ASP: restore filtering of ASP after APT

Use a set instead of map object to restore intended behaviour of filter and
intersection.

Will-fix: #15822

Revision 33e3d67a
Added by intrigeri 9 months ago

Merge remote-tracking branch 'origin/bugfix/14598-asp-review-bugs' into testing-integration (Fix-committed: #15822, #15879)

History

#1 Updated by intrigeri 9 months ago

  • It should at least respect target releases when entered manually in live-additional-software.conf. It doesn't make sense to have two different versions of the same package installed. So, in my case for example, the APT hook should detect that I already have ikiwiki in my live-additional-software.conf though it's called ikiwiki/sid.

Agreed. While we're at it, let's support other common syntax:

  • PACKAGE=VERSION
  • PACKAGE:ARCHITECTURE

Essentially we need to extract the leading substring (on each line) that matches the regexp that APT package names must satisfy. I hope there's code in a utility/library to do that already, or at least the exact requirements are well defined somewhere. I can help find that spec if needed.

#2 Updated by mercedes508 9 months ago

  • Status changed from New to Confirmed

#3 Updated by alant 9 months ago

Should that be fixed in time for 3.9? I'd prefer not to as it was not in the spec of the feature IMHO.

#4 Updated by intrigeri 9 months ago

Should that be fixed in time for 3.9?

With my RM hat on: yes, I'd like this regression to be fixed in time for the release. Now, arguably it'll affect very few people so maybe it's not a blocker.

With my other hats on, FWIW: issues like that, when deemed non-blockers for the release, tend to never be fixed; I'm not sure why but that's how things happen.

I'd prefer not to as it was not in the spec of the feature IMHO.

I hope we don't need to explicitly write "this feature must not introduce regressions" every time we specify a new feature :)

#5 Updated by alant 9 months ago

  • Assignee changed from alant to intrigeri
  • QA Check set to Info Needed

I'd prefer not to as it was not in the spec of the feature IMHO.

I hope we don't need to explicitly write "this feature must not introduce regressions" every time we specify a new feature :)

I pushed a commit that will fix the regression without actually supporting complex usecases in the GUI: the GUI code will filter /distribution, :arch and =version after reading config file. The install code still reads it unfiltered.

I can help find that spec if needed.

I would appreciate.

#6 Updated by alant 9 months ago

  • Status changed from Confirmed to In Progress

#7 Updated by intrigeri 9 months ago

  • Assignee changed from intrigeri to alant
  • Target version set to Tails_3.9
  • QA Check deleted (Info Needed)

alant wrote:

I can help find that spec if needed.

I would appreciate.

https://www.debian.org/doc/debian-policy/ch-controlfields.html#version

#8 Updated by alant 9 months ago

  • % Done changed from 0 to 30
  • Feature Branch set to bugfix/14598-asp-review-bugs

#9 Updated by alant 9 months ago

  • QA Check set to Ready for QA

#11 Updated by alant 9 months ago

  • Assignee changed from alant to segfault
  • % Done changed from 30 to 70

#12 Updated by segfault 9 months ago

  • Assignee changed from segfault to intrigeri
  • QA Check changed from Ready for QA to Pass

alant wrote:

I pushed a commit that will fix the regression without actually supporting complex usecases in the GUI: the GUI code will filter /distribution, :arch and =version after reading config file. The install code still reads it unfiltered.

Seems reasonable to me. I reviewed this and it looks good to me.

#13 Updated by intrigeri 9 months ago

  • % Done changed from 70 to 100

Merged locally, filed #15911.

#14 Updated by intrigeri 9 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)

#15 Updated by intrigeri 9 months ago

  • Status changed from Fix committed to Resolved

#16 Updated by sajolida 5 months ago

  • Subject changed from APT hook of Additional Software is not handling target release to Install notification of Additional Software is not handling target release

#17 Updated by sajolida 5 months ago

  • Related to Bug #16298: Additional Software is not saving target release added

Also available in: Atom PDF