Project

General

Profile

Bug #15821

Video playback broken on some Intel graphics cards (regression in 3.9~rc1)

Added by mercedes508 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Hardware support
Target version:
Start date:
08/20/2018
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/15821-totem-broken-with-new-graphics-stack
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Hey, received a bug report sent from 3.8 saying that Intel Corporation HD Graphics 530 doesn't work with 3.9~rc1. SO this looks like a regression.
But the report was sent without email, so can't get in touch withe reporter...


Related issues

Related to Tails - Bug #12334: Gnome freeze with Intel Skylake GPU Rejected 03/13/2017
Related to Tails - Bug #11060: problem with Intel HD Graphics 520 Rejected 02/05/2016
Duplicated by Tails - Bug #15842: Totem doesn't play video Duplicate 08/25/2018
Blocks Tails - Bug #15841: "Totem could not display the help contents" Resolved 08/25/2018

Associated revisions

Revision d20fbcc2 (diff)
Added by intrigeri 3 months ago

Totem AppArmor profile: inline backported mesa and dri-enumerate abstractions, to fix Totem on Intel graphics cards with recent Mesa and libdrm (refs: #15821)

Revision 70f0f0bb
Added by intrigeri 2 months ago

Merge branch 'bugfix/15821-totem-broken-with-new-graphics-stack' into testing-integration+force-all-tests (Fix-committed: #15821)

History

#1 Updated by intrigeri 3 months ago

  • Assignee changed from intrigeri to mercedes508
  • QA Check set to Info Needed

Thanks for this ticket.

doesn't work with 3.9~rc1

Is this really all the info you've received? :/

So this looks like a regression.

Just to be clear: did the bug reporter suggest this or are you guessing?

#2 Updated by mercedes508 3 months ago

  • Assignee changed from mercedes508 to intrigeri

intrigeri wrote:

Thanks for this ticket.

doesn't work with 3.9~rc1

Is this really all the info you've received? :/

The user sent a WhisperBack report logs included.

So this looks like a regression.

Just to be clear: did the bug reporter suggest this or are you guessing?

The bug report was sent using Tails 3.8 and it says precisely "Playing Video not compatible with
Intel Corps HD Graphics Card 530 (in Lenovo Thinkpad T460p)"

#3 Updated by intrigeri 3 months ago

  • Assignee changed from intrigeri to mercedes508

The user sent a WhisperBack report logs included.

OK, then please give me the exact graphics card identifier that's in the lspci section: this is what we now ask users to send us, because that's what the FT need to work on this kind of stuff, so please get used to forwarding this info (granted, all this is relatively new :)

The bug report was sent using Tails 3.8 and it says precisely "Playing Video not compatible with
Intel Corps HD Graphics Card 530 (in Lenovo Thinkpad T460p)"

Thanks! That's a less dire problem than Tails not working at all. I'll update the ticket metadata accordingly.

#4 Updated by intrigeri 3 months ago

  • Subject changed from 3.9~rc1 regression concerning Intel GPU support to Video playback broken on Intel Corporation HD Graphics 530 (regression in 3.9~rc1)
  • Assignee changed from mercedes508 to intrigeri

#5 Updated by intrigeri 3 months ago

  • Assignee changed from intrigeri to mercedes508

#6 Updated by mercedes508 3 months ago

  • Assignee changed from mercedes508 to intrigeri

OK, then please give me the exact graphics card identifier that's in the lspci section:

Intel Corporation HD Graphics 530 [8086:191b] (rev 06)

#7 Updated by intrigeri 3 months ago

Intel Corporation HD Graphics 530 [8086:191b] (rev 06)

Thanks!

(In passing, when you provide the requested info, please remove the "Info Needed" annotation :)

#8 Updated by intrigeri 3 months ago

  • QA Check deleted (Info Needed)

#9 Updated by intrigeri 3 months ago

I'll test on a couple laptops with Intel graphics to see if this is more widespread.

#10 Updated by intrigeri 3 months ago

  • Related to Bug #12334: Gnome freeze with Intel Skylake GPU added

#11 Updated by intrigeri 3 months ago

  • Related to Bug #11060: problem with Intel HD Graphics 520 added

#12 Updated by intrigeri 3 months ago

  • Priority changed from Normal to Elevated

https://mailman.boum.org/pipermail/tails-testers/2018-August/001105.html reports broken video playback with:

  • 00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
  • 00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)

#13 Updated by segfault 3 months ago

  • Duplicated by Bug #15842: Totem doesn't play video added

#14 Updated by intrigeri 3 months ago

This seems to be an AppArmor issue: the updated libdrm (or friends) wants access to /sys/devices/pci0000:00/0000:00:02.0/vendor. I'm pretty sure we've fixed this upstream and in sid already. I'll look into backporting the fix and will ask the bug reporters to test a nightly build.

Also, I see a denied file_mmap operation on /home/amnesia/#151720 then a fall back to /tmp/#65807 which is denied as well. Not sure these ones are regressions.

#15 Updated by intrigeri 3 months ago

  • Subject changed from Video playback broken on Intel Corporation HD Graphics 530 (regression in 3.9~rc1) to Video playback broken on some Intel graphics cards (regression in 3.9~rc1)

#16 Updated by intrigeri 3 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/15821-totem-broken-with-new-graphics-stack
  • Type of work changed from Research to Code

#17 Updated by intrigeri 3 months ago

  • Assignee changed from intrigeri to segfault
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#18 Updated by intrigeri 3 months ago

  • Blocks Bug #15841: "Totem could not display the help contents" added

#19 Updated by segfault 2 months ago

LGTM. Will test later today.

#20 Updated by segfault 2 months ago

  • Assignee changed from segfault to intrigeri
  • QA Check changed from Ready for QA to Pass

Works on my hardware (but I also didn't have any problems before)

#21 Updated by intrigeri 2 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100

#22 Updated by intrigeri 2 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF