Project

General

Profile

Bug #15820

Ublock Log window is empty, need right-click to display logs

Added by mercedes508 11 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
08/20/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Browser

Description

In Tails 3.9~rc1, when opening UBlock log window, another window pops up but completely empty, which is a regression from Tails 3.8/


Related issues

Related to Tails - Bug #16206: Consider dropping CSS hack for uBlock Origin sidebar Resolved 12/08/2018

History

#1 Updated by intrigeri 11 months ago

I suspect that's because of the hacks I had to do so that the uBlock Origin sidebar does not open every time one starts the browser: e945d0c9dd331bf63edc576ace154df4aaff19a1. I'll take a look! But TBH I don't think it's very important and won't block 3.9 on this.

#2 Updated by intrigeri 11 months ago

  • Subject changed from Ublock Log window is empty to Ublock Log window is empty, need right-click to display logs
  • Assignee changed from intrigeri to mercedes508
  • Type of work changed from Code to Test

Reproduced, even without our CSS hacks.

Interestingly, right-clicking somewhere inside this big empty window fixes it. Next step: try to reproduce in a clean Firefox 60 ESR profile on Debian with webext-ublock-origin 1.16.14+dfsg-1 installed; if this can be reproduced there, report the bug against uBlock Origin in the Debian BTS or upstream; otherwise, try to reproduce in a pristine Tor Browser 8.0a10 outside of Tails. No big emergency IMO, feel free to postpone to 3.10 if you want.

Alternatively, or additionally, I could look into hiding the "Open the logger" button so at least we don't promise anything that won't work. Do you think it's worth it? I doubt it.

#3 Updated by mercedes508 11 months ago

Interestingly, right-clicking somewhere inside this big empty window fixes it. Next step: try to reproduce in a clean Firefox 60 ESR profile on Debian with webext-ublock-origin 1.16.14+dfsg-1 installed; if this can be reproduced there, report the bug against uBlock Origin in the Debian BTS or upstream; otherwise, try to reproduce in a pristine Tor Browser 8.0a10 outside of Tails. No big emergency IMO, feel free to postpone to 3.10 if you want.

There's the same bug (with same workaround) using FF60 and ublock as described on Debian Buster. After a quick look this doesn't seem already reported, I will in the coming days.

Alternatively, or additionally, I could look into hiding the "Open the logger" button so at least we don't promise anything that won't work. Do you think it's worth it? I doubt it.

I don't think it's worth it.

#4 Updated by mercedes508 11 months ago

  • Assignee changed from mercedes508 to intrigeri

Filled https://bugs.debian.org/906911 on Debian BTS.

#5 Updated by intrigeri 11 months ago

There's the same bug (with same workaround) using FF60 and ublock as described on Debian Buster. After a quick look this doesn't seem already reported, I will in the coming days.

Excellent, thanks :)

Alternatively, or additionally, I could look into hiding the "Open the logger" button so at least we don't promise anything that won't work. Do you think it's worth it? I doubt it.

I don't think it's worth it.

OK.

#6 Updated by intrigeri 11 months ago

  • Assignee changed from intrigeri to mercedes508
  • Type of work changed from Test to Communicate

The next step is yours and AFAICT there's nothing else to do so reassigning.

#7 Updated by intrigeri 11 months ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

#8 Updated by intrigeri 9 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#9 Updated by CyrilBrulebois 7 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#10 Updated by mercedes508 7 months ago

  • Assignee deleted (mercedes508)
  • Type of work changed from Communicate to Wait

According to Debian, it's fixed in ublock-origin 1.17.0+dfsg-3 which is currently available for Sid.

#11 Updated by intrigeri 7 months ago

  • Status changed from Confirmed to Fix committed
  • % Done changed from 0 to 100
  • Type of work changed from Wait to Communicate

… which we install on the devel branch already.

#12 Updated by anonym 6 months ago

  • Status changed from Fix committed to Resolved

#13 Updated by mercedes508 6 months ago

  • Status changed from Resolved to Confirmed
  • Assignee set to anonym
  • Target version changed from Tails_3.12 to Tails_3.13

Hey,

just tried with Tails 3.12 and it's still there apparently...

#14 Updated by mercedes508 6 months ago

  • % Done changed from 100 to 0
  • Type of work changed from Communicate to Research

#15 Updated by intrigeri 5 months ago

#16 Updated by intrigeri 5 months ago

  • Assignee deleted (anonym)

#17 Updated by intrigeri 5 months ago

#18 Updated by intrigeri 5 months ago

  • Target version deleted (Tails_3.13)

#19 Updated by intrigeri 5 months ago

  • Related to Bug #16206: Consider dropping CSS hack for uBlock Origin sidebar added

#20 Updated by intrigeri 5 months ago

Next steps: test on current devel and if that's not enough to fix the bug, test with our CSS hacks removed (#16206, can probably be done without building an image: edit userChrome.css in the browser profile and remove everything after "Hide the uBlock sidebar").

#21 Updated by intrigeri 2 months ago

  • Assignee set to intrigeri
  • Target version set to Tails_3.14

#16206 probably fixed that.

#22 Updated by intrigeri 2 months ago

  • Status changed from Confirmed to Resolved
  • Target version changed from Tails_3.14 to Tails_3.13.2

I can't reproduce this on 3.13.2 :)

Also available in: Atom PDF