Project

General

Profile

Feature #15807

Define & apply clear criteria for including dictionaries, fonts and language packs

Added by intrigeri over 1 year ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
Start date:
08/18/2018
Due date:
% Done:

100%

Feature Branch:
feature/15807-trimmed-and-consistent-l10n-support+force-all-tests, greeter:feature/9956-noto
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Historically we included dictionaries (hunspell-*), fonts and LibreOffice language packs (libreoffice-l10n-*) for each language that was on the short list in the old Greeter we used to ship during the Tails 2.x era. We have no such list anymore. I don't remember where this short list came from anyway, most likely the reasons behind it don't matter so much anymore. Additionally we install all Thunderbird language packs.

Due to how our Tor Browser localization script is implemented, while working on #15023 I've added dictionaries for the new locales supported by Tor Browser (da, he, ko, nl, pl, sv); but I did not install LibreOffice language packs nor fonts for those. And now Tor Browser 8.0a10 supports 5 new locales (ca, ga-IE, id, is, nb-NO), most of which have hunspell dictionaries in Debian. I was going to automatically add them to our list of packages, then wondered what I should do, and decided to not install these dictionaries: it's easier to decide to add them later than to decide to remove them later.

So, I'd like us to answer these questions:

  1. what's the criteria for adding new spellchecker dictionaries in Tails?
  2. what's the criteria for adding new LibreOffice or Thunderbird language packs in Tails? Note that they're necessary to have a translated UI.
  3. what's the criteria for adding new fonts in Tails? Note: fonts are necessary to display our GNOME desktop correctly; some font families (Noto, Roboto) have very broad coverage and could be a reasonable fallback (#9956).
  4. Once we have such criteria, shall we apply them to the languages we already ship support files for? FTR the current list, wrt. dictionaries and LibreOffice l10n packs, is: ar, da, de, en_US, es, fa, fr, he, it, ko, nl, pl, pt-br, ru, sv, vi, zh-CN. Add to this all available Thunderbird language packs. I did not look at the list of scripts supported by the fonts we ship. I suspect these two lists are not fully consistent.

Criteria we might want to use:

  • Is our website translated (or in good way to be) in this language? Rationale: consistency; if it looks like a language is well supported by looking at our website, then perhaps it should be well supported when starting Tails.
  • Number of native speakers worldwide
  • Number of Tor users (yeah, that's per-country, not per-language, but perhaps that's good enough)
  • Size of the support files
  • Impact of the missing support files (e.g. unusable desktop or LibreOffice vs. not the nicest looking fonts ever)

I think this is related to ASP and #15543: once it's easy enough to add the necessary packages to one's Tails, perhaps we can raise the bar for inclusion by default. Ideally we could hint the user towards installing the needed packages depending on the locale they chose but let's please avoid designing an over-engineered solution that will be added to our roadmap and then postponed year after year.


Related issues

Related to Tails - Feature #9021: Consider including more dictionaries Rejected 03/06/2015
Related to Tails - Bug #13473: Missing common proprietary Arabic fonts make some PDF documents unreadable Rejected 07/16/2017
Related to Tails - Feature #15543: Give a list of examples of nice software to install each time Confirmed 04/17/2018
Related to Tails - Bug #15305: Add Libreoffice in Catalan Resolved 02/11/2018
Related to Tails - Feature #15291: Remove less popular packages that users could install themselves Resolved 04/17/2018
Related to Tails - Feature #5962: Set default dictionary according to locale in the browser Rejected
Related to Tails - Feature #16337: Upgrade to Tor Browser 8.5 Resolved 03/15/2019
Related to Tails - Feature #16095: Curate the list of languages in Tails Greeter Resolved 11/04/2018
Related to Tails - Bug #16571: Tor Browser does not list spell checker dictionaries installed via APT In Progress 03/18/2019
Related to Tails - Bug #16611: Propose users to add relevant internationalization Debian packages Confirmed
Related to Tails - Feature #15764: Improve right to left support in Thunderbird Confirmed 08/04/2018
Related to Tails - Feature #16399: Write release notes for 3.14 Resolved 01/29/2019
Related to Tails - Bug #16648: Update list of l10n packages for tier-1 supported languages Confirmed
Duplicated by Tails - Feature #9956: Consider replacing the additional fonts we ship with Noto Duplicate 08/09/2015
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision f5391c2b (diff)
Added by intrigeri 9 months ago

Install l10n support packages for all tier-1 supported languages, and only those (refs: #15807)

I'm using the list of tier-1 supported languages proposed on #15807#note-22:

- Arabic - AR
- German - DE
- English - EN
- Spanish - ES
- Farsi - FA
- French - FR
- Italian - IT
- Portuguese - PT-BR
- Russian - RU
- Turkish - TR
- Simplified Chinese - zh-CN

… and applying to Thunderbird, LibreOffice, and spellchecker dictionaries.

Exceptions:

- I'm keeping hunspell-vi because we've been installing it so far, Vietnamese
is one of our strong candidates, and even if one installs it manually, it's
not available in Tor Browser (refs: #16571)
- There's no Farsi l10n package for Thunderbird (thunderbird-l10n-fa).

Revision e015382a (diff)
Added by intrigeri 9 months ago

Don't fail the build if Tor Browser supports new locales that we don't ship a spellchecking dictionary for (refs: #15807)

We're not trying to ship spellcheckers for every language Tor Browser
ships a language pack for: we only include spellchecking dictionaries
for tier-1 supported languages. So let's drop the need to maintain
$NO_SPELLCHECKER_LOCALES and the code that would encourage developers
to install new spellchecking dictionaries.

Revision eb554a6a (diff)
Added by intrigeri 9 months ago

Install l10n support packages for all tier-1 supported languages, and only those, take 2 (refs: #15807)

As per #15807#note-26, I'm adding Hindi and Indonesian wherever possible,
and removing Vietnamese.

Revision 179b3335 (diff)
Added by intrigeri 9 months ago

Document Tier-1 languages and localization support (refs: #15807).

Revision 422ae8c0 (diff)
Added by intrigeri 8 months ago

Replace obsolete APT overlay with feature-15807-trimmed-and-consistent-l10n-support (refs: #15807).

Revision caf1b7ba (diff)
Added by intrigeri 8 months ago

Replace obsolete APT overlay with feature-15807-trimmed-and-consistent-l10n-support-force-all-tests (refs: #15807).

Revision 03703837 (diff)
Added by intrigeri 8 months ago

Install hunspell-tr from sid (refs: #15807)

Thanks segfault for spotting the fact I had forgotten this one!

Revision 6ad1d590
Added by segfault 8 months ago

Merge branch 'feature/15807-trimmed-and-consistent-l10n-support+force-all-tests' into stable (Fix-committed: #15807)

History

#1 Updated by intrigeri over 1 year ago

  • Related to Feature #9956: Consider replacing the additional fonts we ship with Noto added

#2 Updated by intrigeri over 1 year ago

  • Related to Feature #9021: Consider including more dictionaries added

#3 Updated by intrigeri over 1 year ago

  • Related to Bug #13473: Missing common proprietary Arabic fonts make some PDF documents unreadable added

#4 Updated by intrigeri over 1 year ago

  • Related to Feature #15543: Give a list of examples of nice software to install each time added

#5 Updated by intrigeri over 1 year ago

  • Related to Bug #15305: Add Libreoffice in Catalan added

#6 Updated by intrigeri over 1 year ago

Meta: if including the fonts in this discussion makes it much more complicated (e.g. because we need more info on #9956), I'd rather discuss the 2 other items now than postpone the entire discussion.

#7 Updated by intrigeri over 1 year ago

  • Related to Feature #15291: Remove less popular packages that users could install themselves added

#8 Updated by u over 1 year ago

  • Related to Feature #15023: Upgrade to Tor Browser based on Firefox ESR60 added

#9 Updated by u over 1 year ago

  • Related to deleted (Feature #15023: Upgrade to Tor Browser based on Firefox ESR60)

#10 Updated by u over 1 year ago

  • Related to Feature #5962: Set default dictionary according to locale in the browser added

#11 Updated by intrigeri over 1 year ago

  • Description updated (diff)

#12 Updated by sajolida over 1 year ago

I think we should agree on a list of languages to support well and adds whatever makes sense for these.

Then, don't include anything for the other languages but:

  • Document better how to add more packages for these languages (Additional Software).
  • Design something to educate people when they are starting Tails in a language that's not in the first list. Maybe a notification pointing to the doc could be good enough as a start.

For example, Tor has this as their list of tier-1 languages:

  • English - EN
  • Farsi - FA
  • Spanish - ES
  • Russian - RU
  • Simplified Chinese - zh-CN
  • Portuguese - PT-BR
  • French - FR
  • German - DE
  • Korean - KO
  • Turkish - TR
  • Italian - IT
  • Arabic - AR

In our case, I think that any language activated on our website should have good support in Tails:

  • English - EN
  • Farsi - FA
  • Spanish - ES
  • Portuguese - PT-BR
  • French - FR
  • German - DE
  • Italian - IT

Then the difference with the Tor list is:

  • Russian - RU
  • Simplified Chinese - zh-CN
  • Korean - KO
  • Turkish - TR
  • Arabic - AR

Russian, Chinese, and Arabic seem obvious to me (like their are UN official languages for a reason).

Korean and Turkish are more debatable and we could probably find other language from heavily censored or respressed countries. Looking at metrics.torproject.org:

Other candidates could be (in this order):

Then only Turkish. Korean wouldn't even be on the list.

#13 Updated by intrigeri over 1 year ago

For example, Tor has this as their list of tier-1 languages:

Where does this come from?

If that's the list of localized Tor Browser tarballs, FYI they plan to add more and more incrementally as translations are completed, so that's not really tier-1, it's more "every language whose translation is good enough" AFAIK.

In our case, I think that any language activated on our website should have good support in Tails:

Agreed.

Russian, Chinese, and Arabic seem obvious to me (like their are UN official languages for a reason).

Agreed.

#14 Updated by intrigeri about 1 year ago

sajolida wrote:

Then the difference with the Tor list is:

  • Russian - RU
  • Simplified Chinese - zh-CN
  • Korean - KO
  • Turkish - TR
  • Arabic - AR

Add to this list da, he, nl, pl and sv, for which we ship l10n at least some packages for.

#15 Updated by intrigeri 9 months ago

  • Assignee changed from intrigeri to sajolida
  • QA Check set to Info Needed

intrigeri wrote:

For example, Tor has this as their list of tier-1 languages:

Where does this come from?

If that's the list of localized Tor Browser tarballs, FYI they plan to add more and more incrementally as translations are completed, so that's not really tier-1, it's more "every language whose translation is good enough" AFAIK.

@sajolida, ping about this question?

(Working on #16452 and the problem that made me file this ticket initially pops up again: I see that Tor Browser 8.5 will add Czech, Greek, and Hungarian. anonym was probably not aware of this discussion so his branch installs new dictionaries for these 3 languages. I'm going to revert this change until we have reached a conclusion here.)

#16 Updated by intrigeri 9 months ago

#17 Updated by sajolida 9 months ago

  • Related to Feature #16095: Curate the list of languages in Tails Greeter added

#18 Updated by sajolida 9 months ago

Where does this come from?

Sorry. This list of 1-tier languages comes from:

https://storm.torproject.org/shared/o7Rh2S9bsMNN7Eh7C9cKaqxR371pR1AmpRxbu--nC34

Linked from:

https://trac.torproject.org/projects/tor/ticket/21222

Since then they launched their support portal with a different set of
languages, probably the ones for which they have translations.

So I think that this list has to be taken as a political statement
(based on data from +2 years ago) of what they consider their most
important languages, and reality can differ.

If that's the list of localized Tor Browser tarballs, FYI they plan to add more and more incrementally as translations are completed, so that's not really tier-1, it's more "every language whose translation is good enough" AFAIK.

@sajolida, ping about this question?

Their "Tier 1" list is a different but shorter list of which languages
their consider the most important.

I'm also linking this ticket with #16095: it wouldn't make much sense to
include dictionaries, fonts and language packs for languages that are
not otherwise translated enough to be on the Greeter, though maybe
that's only going to be an hypothetical situation.

#19 Updated by sajolida 9 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from sajolida to intrigeri

Regarding your original questions:

what's the criteria for adding new spellchecker dictionaries in Tails?

My understanding is that different spell checkers are added differently. For example, I have hunspell-ca in my Additional Software: it used by Thunderbird but not in Tor Browser.

So regarding dictionaries, we could have a smaller list if they can be installed using Additional Software.

Would you mind educating me on which dictionaries are available in Tor Browser and where our hunspell are useful and where not?

If users can install additional dictionaries persistently in Tor Browser as well, then we might limit the list that we include by default to our own list of tier-1 languages.

what's the criteria for adding new LibreOffice or Thunderbird language packs in Tails? Note that they're necessary to have a translated UI.

  • LibreOffice language packs are libreoffice-l10n-$lang packages so I would say that they are good candidates for Additional Software apart for our tier-1 languages.
  • I can see only one package for Thunderbird: thunderbird-l10n-all. Would we be able to add only some languages to Thunderbird and not others?

what's the criteria for adding new fonts in Tails? Note: fonts are necessary to display our GNOME desktop correctly; some font families (Noto, Roboto) have very broad coverage and could be a reasonable fallback (#9956).

If the font is needed to open GNOME in one of the curated languages from the Greeter, then I'd say we should include it.

To summarize:

  • Like Tor did, we could decide on a list of tier-1 languages that would be the most important languages for us in terms of impact. We would support these languages as good as possible in Tails (and could put more effort in having them on the website as well for example).
  • We could have a bigger list of tier-2 languages that would be listed in Greeter and for which our custom software and Debian/GNOME is reasonably well translated. We would ensure that people can add better support for these languages using Additional Software.

#20 Updated by sajolida 9 months ago

And:

  • If Additional Software is not enough to add better support for tier-2 languages in some cases, then we should dig a bit deeper on how to provide Persistence for such cases (eg. maybe for spellcheckers in Tor Browser) or maybe add them by default in Tails.
  • We shouldn't spend time or MB in Tails for other languages.

#21 Updated by intrigeri 9 months ago

  • Related to Bug #16571: Tor Browser does not list spell checker dictionaries installed via APT added

#22 Updated by intrigeri 9 months ago

  • Assignee changed from intrigeri to sajolida

Thanks a lot for these thoughtful answers!

what's the criteria for adding new spellchecker dictionaries in Tails?

My understanding is that different spell checkers are added differently. For example, I have hunspell-ca in my Additional Software: it used by Thunderbird but not in Tor Browser.

That's a bug ⇒ filed #16571.

(Note that what's the default language for spellchecking is another matter: #5962.)

Would you mind educating me on which dictionaries are available in Tor Browser and where our hunspell are useful and where not?

At first glance (right click in a text area, enable spellchecking, then right click again and select language), it seems that all the hunspell-* packages we install by default are available in Tor Browser. For the current list: git grep -E '^hunspell' wiki/src/torrents/files/*.packages.

If users can install additional dictionaries persistently in Tor Browser as well, then we might limit the list that we include by default to our own list of tier-1 languages.
  • LibreOffice language packs are libreoffice-l10n-$lang packages so I would say that they are good candidates for Additional Software apart for our tier-1 languages.

Thanks and agreed. Will do so once we have a list of tier-1 languages (see below).

  • I can see only one package for Thunderbird: thunderbird-l10n-all.

This package is a metapackage depending on all available localization of Thunderbird.
For the up-to-date list of the 56 Thunderbird localization packages we currently install, run: git grep -E '^thunderbird-l10n-' wiki/src/torrents/files/*.packages.

Would we be able to add only some languages to Thunderbird and not others?

Yes: we could very well install a subset of these 56 packages and drop thunderbird-l10n-all.

  • Like Tor did, we could decide on a list of tier-1 languages that would be the most important languages for us in terms of impact. We would support these languages as good as possible in Tails (and could put more effort in having them on the website as well for example).

Building on the research you did above, taking languages activated on our website + a subset of the Tor list (Russian, simplified Chinese, Arabic and Turkish; not Korean) I propose to start with this list:

  • Arabic - AR
  • German - DE
  • English - EN
  • Spanish - ES
  • Farsi - FA
  • French - FR
  • Italian - IT
  • Portuguese - PT-BR
  • Russian - RU
  • Turkish - TR
  • Simplified Chinese - zh-CN

And I'm totally fine with considering the other candidates you've identified, be it now or later, as you prefer, as long as it doesn't increase too much how long we need to make some decision here :)

  • We could have a bigger list of tier-2 languages that would be listed in Greeter and for which our custom software and Debian/GNOME is reasonably well translated. We would ensure that people can add better support for these languages using Additional Software.
  • If Additional Software is not enough to add better support for tier-2 languages in some cases, then we should dig a bit deeper on how to provide Persistence for such cases (eg. maybe for spellcheckers in Tor Browser) or maybe add them by default in Tails.

AFAIK Additional Software is good enough for everything but:

  • spellchecking in Tor Browser (due to #16571 that you've reported here) ⇒ I say let's put #16571 on the FT's plate but don't block on it here, i.e. we can remove spellchecking dictionaries for non-tier-1 languages; based on the above proposed list, this means we could remove spellchecking dictionaries for Danish, Greek, Korean, Dutch, Polish, Swedish and Vietnamese; but I'm fine with keeping Vietnamese since it's on your list of candidates for tier-1.
  • Tor Browser language packs, since they are not in Debian ⇒ I propose we keep shipping all the Tor Browser language packs for now; and we have done #16095, it won't make sense anymore to ship language packs that can't possibly be used (because they're not listed in the Greeter); added to the description of that ticket.
  • We shouldn't spend time or MB in Tails for other languages.

ACK.

I'll prepare a branch that removes all l10n support, except Tor Browser language packs, except for the list of tier-1 languages proposed above. I hope the resulting data (e.g. resulting IMG size, UX to install the l10n support back via Additional Software) will inform our decision here.

#23 Updated by intrigeri 9 months ago

  • Feature Branch set to feature/15807-trimmed-and-consistent-l10n-support

#24 Updated by intrigeri 9 months ago

I'll prepare a branch that removes all l10n support, except Tor Browser language packs, except for the list of tier-1 languages proposed above. I hope the resulting data (e.g. resulting IMG size, UX to install the l10n support back via Additional Software) will inform our decision here.

Regarding size: this saves 31M on the ISO size (1177 → 1146). Given most of the saved space comes from the removal of dozens of Thunderbird l10n packages, and we update Thunderbird in basically every release, this should also make the automatic updates smaller. Tweaking a bit the list of tier-1 languages should not impact these results much.

Regarding UX, the tl;dr is: to install l10n support packages, for best results one needs to know how to write the name of the desired language in English. It's not a new problem for the vast majority of languages wrt. spellchecker & LibreOffice. But with my branch the problem extends to a few more languages (no big deal) and to Thunderbird (perhaps more serious).

Debian package descriptions are translatable (stats), but we don't tell APT to download the l10n data for the language one selects in the Greeter, and even if we did the results are not great:

  • For example, if I login in Dutch, and I search for "nederlands" in Synaptic, there's no single result… while searching for "dutch" yields a slightly overwhelming list of 63 packages, including those I've removed in f5391c2bba439fb0e083c5eceff818e376965028. I've tried enabling the download of translations (Acquire::Languages { "nl"; "en"; };) but Synaptic yields only one result (GIMP doc in Dutch) when I search for "nederlands". Same in GNOME Software (that doesn't even find anything for "dutch", probably because it's about apps only, not about the sort of things I'm looking for). I guess that's because Dutch is very little translated there (most Dutch people I've met speak English so well, why bother, I guess). But given most languages have a rather low amount of translations there, this probably reflects the most common case.
  • I've retried the same in Danish, because it's pretty well translated according to https://ddtp2.debian.net/. I can find results for "danks" in Synaptic (204 packages), including those I've removed in f5391c2bba439fb0e083c5eceff818e376965028. Again, GNOME Software finds nothing.

So I'm not convinced it's worth bothering and tweaking the APT config according to the chosen locale: for the vast majority of languages, it won't help at all, so in any case we'll need to somehow teach user to search for their preferred language name in English.

#25 Updated by intrigeri 9 months ago

  • Target version set to Tails_3.14
  • % Done changed from 0 to 10
  • QA Check changed from Info Needed to Ready for QA

#26 Updated by sajolida 9 months ago

That's a bug ⇒ filed #16571.

Thanks! Sometimes I don't dare declaring things as bugs :)

At first glance (right click in a text area, enable spellchecking, then right click again and select language), it seems that all the hunspell-* packages we install by default are available in Tor Browser. For the current list: git grep -E '^hunspell' wiki/src/torrents/files/*.packages.

After seeing #16571 I understand better :)

This package is a metapackage depending on all available localization of Thunderbird.

Got it!

  • Like Tor did, we could decide on a list of tier-1 languages that would be the most important languages for us in terms of impact. We would support these languages as good as possible in Tails (and could put more effort in having them on the website as well for example).

Building on the research you did above, taking languages activated on our website + a subset of the Tor list (Russian, simplified Chinese, Arabic and Turkish; not Korean) I propose to start with this list:

  • Arabic - AR
  • German - DE
  • English - EN
  • Spanish - ES
  • Farsi - FA
  • French - FR
  • Italian - IT
  • Portuguese - PT-BR
  • Russian - RU
  • Turkish - TR
  • Simplified Chinese - zh-CN

And I'm totally fine with considering the other candidates you've identified, be it now or later, as you prefer, as long as it doesn't increase too much how long we need to make some decision here :)

Ok, so here is a proposal. Our list of tier-1 languages should include:

The resulting list is consistent with your proposal but adds 2:

  • Indonesian, 4th country for directly connecting users!
  • Hindi, India is 5th country for bridge users, 57% of the population
    speaks Hindi.

I'm fine with keeping Vietnamese since it's on your list of candidates for tier-1.

I'm not sure anymore why I put Vietnamese on the list :)

  • Tor Browser language packs, since they are not in Debian ⇒ I propose we keep shipping all the Tor Browser language packs for now; and we have done #16095, it won't make sense anymore to ship language packs that can't possibly be used (because they're not listed in the Greeter); added to the description of that ticket.

Ok.

#27 Updated by sajolida 9 months ago

Regarding size: this saves 31M on the ISO size (1177 → 1146).

Not bad!!!

So I'm not convinced it's worth bothering and tweaking the APT config according to the chosen locale: for the vast majority of languages, it won't help at all, so in any case we'll need to somehow teach user to search for their preferred language name in English.

Right.

A nice solution would be to propose people to add the relevant Debian
packages to their Additional Software based on the language of their
session :)

#28 Updated by intrigeri 9 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Ready for QA to Dev Needed

#29 Updated by intrigeri 9 months ago

Ok, so here is a proposal. Our list of tier-1 languages should include:

The resulting list is consistent with your proposal but adds 2:

  • Indonesian, 4th country for directly connecting users!
  • Hindi, India is 5th country for bridge users, 57% of the population
    speaks Hindi.

Fine, implemented locally.

@sajolida, I was going to add this info to our design doc, but perhaps you had something else in mind?

#30 Updated by intrigeri 9 months ago

A nice solution would be to propose people to add the relevant Debian packages to their Additional Software based on the language of their session :)

Sure. Of course, the main blocker is: maintaining these list of packages. And a slightly less obvious one is: how to avoid nagging users who replied "no", every time they start Tails? (IIRC we already have a years-old ticket about this second problem.) I don't think we should block on that here and I'll assume you agree :)

#31 Updated by intrigeri 9 months ago

  • Related to Feature #9956: Consider replacing the additional fonts we ship with Noto added

#32 Updated by intrigeri 9 months ago

  • Related to deleted (Feature #9956: Consider replacing the additional fonts we ship with Noto)

#33 Updated by intrigeri 9 months ago

  • Related to deleted (Feature #9956: Consider replacing the additional fonts we ship with Noto)

#34 Updated by intrigeri 9 months ago

  • Blocked by Feature #9956: Consider replacing the additional fonts we ship with Noto added

#35 Updated by intrigeri 9 months ago

  • Feature Branch changed from feature/15807-trimmed-and-consistent-l10n-support to feature/15807-trimmed-and-consistent-l10n-support, greeter:feature/9956-noto

#36 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #9956: Consider replacing the additional fonts we ship with Noto)

#37 Updated by intrigeri 9 months ago

  • Duplicated by Feature #9956: Consider replacing the additional fonts we ship with Noto added

#38 Updated by intrigeri 9 months ago

  • Subject changed from Have clear criteria for including dictionaries, fonts and language packs to Define & apply clear criteria for including dictionaries, fonts and language packs
  • Type of work changed from Discuss to Code

#39 Updated by intrigeri 9 months ago

intrigeri wrote:

sajolida, I was going to add this info to our design doc

Done on the topic branch.

#40 Updated by intrigeri 9 months ago

  • % Done changed from 10 to 30
  • QA Check changed from Dev Needed to Ready for QA

The resulting ISO, that combines this with #9956, is 1146M large (-23M compared to 3.13.1). Not bad considering this was not the primary goal here: for now I care more about stopping the inflation that lead me to file this ticket, than about shrinking the ISO.

Given this branch also has the switch to Noto fonts for non-Latin languages (#9956), I've sent a call for testing. I'm not super hopeful given my last calls for testing got very little feedback, if any, so I did my homework and tested, side by side, this ISO vs. 3.13.1 in various languages:

  • Arabic, Farsi, Russian: no difference to my unskilled eye (possibly the extra fonts we used to ship were not used in the GNOME interface so Noto is not used either)
  • Hindi, Japanese, simplified Chinese: sharper, brighter font hinting is still present but makes the characters less fuzzy

I'll wait a week or two for feedback and if it's positive (or if there's none) I'll submit this branch for QA.

#41 Updated by sajolida 9 months ago

@sajolida, I was going to add this info to our design doc, but perhaps you had something else in mind?

I don't :) It would be great if you put it on our design doc.

#42 Updated by sajolida 9 months ago

  • Related to Bug #16611: Propose users to add relevant internationalization Debian packages added

#43 Updated by sajolida 9 months ago

Of course, the main blocker is: maintaining these list of packages. And a slightly less obvious one is: how to avoid nagging users who replied "no", every time they start Tails? (IIRC we already have a years-old ticket about this second problem.)

I created #16611 for that.

I don't think we should block on that here and I'll assume you agree :)

Of course :)

#44 Updated by intrigeri 8 months ago

  • Related to Feature #15764: Improve right to left support in Thunderbird added

#45 Updated by intrigeri 8 months ago

  • Feature Branch changed from feature/15807-trimmed-and-consistent-l10n-support, greeter:feature/9956-noto to feature/15807-trimmed-and-consistent-l10n-support+force-all-tests, greeter:feature/9956-noto

#46 Updated by intrigeri 8 months ago

#47 Updated by intrigeri 8 months ago

#48 Updated by intrigeri 8 months ago

  • Assignee changed from intrigeri to segfault
  • % Done changed from 30 to 50

@segfault, can you please review and merge these 2 branches?

I've run the full test suite locally; failures were:

  • Totem ǂ Watching a WebM video over HTTPS: fragile, rarely passes these days
  • Electrum Bitcoin client ǂ Using a persistent Electrum configuration: known issue
  • Additional software ǂ Recovering in offline mode after Additional Software previously failed to upgrade and then succeed to upgrade when online: passed on Jenkins

#49 Updated by segfault 8 months ago

@intrigeri: I reviewed the tails-greeter part. Should I release and build a new version?

#50 Updated by segfault 8 months ago

review of feature/15807-trimmed-and-consistent-l10n-support+force-all-tests:

Packages I miss in tails-common.list:

  • hunspell-tr (in buster and sid)

Packages I miss but also couldn't find in Debian:

  • spellchecking dictionary for zh-CN
  • thunderbird-l10n-{fa,hi}

Everything else looks good to me.

#51 Updated by segfault 8 months ago

  • Assignee changed from segfault to intrigeri
  • QA Check changed from Ready for QA to Dev Needed

#52 Updated by intrigeri 8 months ago

I reviewed the tails-greeter part. Should I release and build a new version?

I'm not sure it's worth the overhead. I'd say merge the topic branch into the greeter's master branch and then we'll bump the version number + release whenever we need it, and until then we ship 1.0.9+feature.9956.1.

#53 Updated by intrigeri 8 months ago

  • Related to Bug #16648: Update list of l10n packages for tier-1 supported languages added

#54 Updated by intrigeri 8 months ago

  • Assignee changed from intrigeri to segfault
  • QA Check changed from Dev Needed to Ready for QA

@segfault, thanks for the comprehensive review! I'm very glad you double-checked All The Things and did spot a mistake of mine :)))

Packages I miss in tails-common.list:

  • hunspell-tr (in buster and sid)

Good catch, thanks! Fixed.

I've then successfully built an image locally (after locally merging stable into the topic branch). I don't see how installing hunspell-tr can possibly invalidate earlier successful test suite results, so I'm sending this back to your review plate without waiting for the whole CI to run. If we do realize post-merge that this last minute change does break stuff, I'm totally prepared to fix it up in a hurry… or to see this change reverted :)

Packages I miss but also couldn't find in Debian:

Indeed. I've filed #16648 to ensure we take another look at it at some point.

#55 Updated by segfault 8 months ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

#56 Updated by segfault 8 months ago

  • Assignee deleted (segfault)
  • QA Check changed from Ready for QA to Pass

#57 Updated by intrigeri 7 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#58 Updated by anonym 7 months ago

  • Status changed from 11 to Resolved

#59 Updated by anonym 7 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#60 Updated by intrigeri 7 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF