Project

General

Profile

Bug #15805

Update doc for Tor Browser 8

Added by intrigeri about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
-
Target version:
Start date:
08/18/2018
Due date:
% Done:

0%

Feature Branch:
doc/15805-tor-browser-8
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Browser

Description

While Tails 3.9~rc1 already displays a big part of these changes, 8.0a10 changes things again so I recommend you use ISO images that have #15803 (once it's ready for QA or merged) to work on this.


Related issues

Blocks Tails - Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing Resolved 03/14/2018
Blocked by Tails - Feature #15803: Upgrade Tor Browser to 8.0a10 Resolved 08/18/2018

History

#1 Updated by intrigeri about 1 year ago

  • Blocks Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing added

#2 Updated by intrigeri about 1 year ago

#3 Updated by intrigeri about 1 year ago

The two Tor Browser know issues documented on https://tails.boum.org/news/test_3.9-rc1/ are fixed on the topic branch for #15803.

#4 Updated by intrigeri about 1 year ago

Also, the circuit view has moved to the URL bar (click the "(i)" icon or the TLS padlock) and it also offers "New Circuit for this Site", which is probably nicer to use (and to document!) than the hamburger menu.

#5 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to cbrownstein
  • Feature Branch set to doc/15805-tor-browser-8

Here is a branch. Ideally this should be reviewed and merged in time for 3.9 (Sep 4) but it's also fine to merge it shortly after the release.

#6 Updated by cbrownstein about 1 year ago

  • Assignee changed from cbrownstein to sajolida
  • QA Check set to Ready for QA

I've made a bunch of improvements to the page, unrelated to your changes. Your changes look fine.

https://0xacab.org/cbrownstein/tails/commits/doc/15805-tor-browser-8

Tor Browser is a web browser based on Mozilla Firefox. It is configured to protect your anonymity. Given the popularity of Firefox, you might have used it before. Its user interface is like any other modern web browser.

I'm having difficulty understanding that paragraph. Is it saying that given the popularity of Firefox, you might have tried Tor Browser before? Or is it saying that you might have used Firefox before?

#7 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to cbrownstein

Thanks for the quick review!

All your changes are very good!

Still, as explained in the message of commit 8982e3159a, in order to limit the number of translations that will get fuzzy, I limited myself to modifying strings that have already been changed by the adjustment to Tor Browser 8.

Your changes go way beyond that and will break more translations and each translation team will have to fix them manually. In general, I prefer avoiding that even though that sometimes imply leaving unpolished strings inherited from older versions.

But since you made all these nice changes already, I merged them :)

And of course, there's a balance to find between breaking all translations every time we edit a file and sticking to bad phrasing forever, so it's not black or white.

Regarding the first paragraph, these sentences are very old and I refrained from touching them until now for the same reason. But since you're saying that they are hard to understand, I stripped down stuff from this paragraph with d0e3c43ebc.

I'm merge this in time for 3.9 but I'm reassign this ticket to you to make sure that you read this comment (and checked d0e3c43ebc).

#8 Updated by sajolida about 1 year ago

  • Status changed from Confirmed to Fix committed

#9 Updated by cbrownstein about 1 year ago

  • Assignee changed from cbrownstein to sajolida
  • QA Check changed from Ready for QA to Pass

Perfect!

#10 Updated by intrigeri about 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF