Project

General

Profile

Bug #15791

Update test suite for Thunderbird 60

Added by intrigeri 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Test suite
Target version:
Start date:
08/15/2018
Due date:
% Done:

100%

Feature Branch:
kibi:bugfix/15791-update-test-suite-for-thunderbird-60
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

We've made good progress but there's still work left.


Related issues

Related to Tails - Feature #15091: Upgrade to Thunderbird 60 Resolved 05/09/2018
Blocks Tails - Feature #13241: Core work: Test suite maintenance Rejected 06/29/2017

Associated revisions

Revision b05edb90
Added by intrigeri 10 months ago

Merge branch 'kibi/bugfix/15791-update-test-suite-for-thunderbird-60' into testing (Fix-committed: #15791).

History

#1 Updated by intrigeri 10 months ago

#2 Updated by intrigeri 10 months ago

  • Parent task deleted (#15091)

#3 Updated by intrigeri 10 months ago

#4 Updated by CyrilBrulebois 10 months ago

  • Assignee changed from CyrilBrulebois to intrigeri
  • QA Check set to Ready for QA
  • Feature Branch changed from feature/15091-thunderbird-60 to kibi:bugfix/15791-update-test-suite-for-thunderbird-60

Here are the results with my bugfix/15791-update-test-suite-for-thunderbird-60 branch for a features/thunderbird.feature run:

5 scenarios (5 passed)
42 steps (42 passed)
7m32.128s

Next on my list are upstream bug reports to be filed:
  • file a bug report about this empty/unnamed frame… maybe its presence is accidental; but for sure having a name wouldn't hurt;
  • file a bug report about the nameless internal frame for the mail body;
  • file a bug report for “ - Mozilla Thunderbird” vs. “ - Thunderbird” as suffix in window titles. They might want to be consistent.

(I won't be clocking time spent filing those bug reports. They are nice to have on the long term but they're not critical.)

#5 Updated by intrigeri 10 months ago

  • Assignee changed from intrigeri to CyrilBrulebois
  • QA Check changed from Ready for QA to Dev Needed

Excellent work, congrats! I'm truly amazed by how fast you've learnt this stuff.

I have only one (maybe small) problem with c17a17bdf4862d9ea7bf53f21c0e437f3e47371e: on slower systems, Sikuli can win the race against Thunderbird and type "a" before the "Tools" menu has open. So I think we need to either insert something between pressing "alt-t" and "a". I'll spell out all the options I can think of, as a way to share knowledge and help you get up-to-speed on our test suite :)

  • either a call to screen.wait → picture that shows the menu has open: cheap and if properly trimmed, I think the picture won't have to be updated except when font rendering changes
  • or a call to sleep(1): very cheap, a bit ugly, but probably the most reliable option and zero maintenance cost
  • or some Dogtail magic to detect whether the menu is open (but then we can as well use Dogtail to click the "Add-ons" menu item, which I guess you would have done if it was easy): probably too expensive

I'm not ashamed to suggest you go for the 2nd (sleep) option, with a comment explaining why it's needed and good enough. What do you think? Any more clever idea?

Meanwhile I'll trigger test suite runs on your branch merged.

#6 Updated by CyrilBrulebois 10 months ago

intrigeri wrote:

Excellent work, congrats! I'm truly amazed by how fast you've learnt this stuff.

Surely because of my excellent teacher.

I have only one (maybe small) problem with c17a17bdf4862d9ea7bf53f21c0e437f3e47371e: on slower systems, Sikuli can win the race against Thunderbird and type "a" before the "Tools" menu has open. So I think we need to either insert something between pressing "alt-t" and "a". I'll spell out all the options I can think of, as a way to share knowledge and help you get up-to-speed on our test suite :)

  • either a call to screen.wait → picture that shows the menu has open: cheap and if properly trimmed, I think the picture won't have to be updated except when font rendering changes
  • or a call to sleep(1): very cheap, a bit ugly, but probably the most reliable option and zero maintenance cost
  • or some Dogtail magic to detect whether the menu is open (but then we can as well use Dogtail to click the "Add-ons" menu item, which I guess you would have done if it was easy): probably too expensive

I'm not ashamed to suggest you go for the 2nd (sleep) option, with a comment explaining why it's needed and good enough. What do you think? Any more clever idea?

To be honest, the sleep() solution jumped to my mind when reading the first part of your message, before even seeing the options you were proposing. The slight issue with a 1-second delay is that I couldn't immediately check it was taken into account because VNC viewing doesn't allow for high precision. I've confirmed it through a local patch bumping the delay to 100 seconds though.

You'll find an updated branch with an extra commit on my repository.

By the way, I've just noticed that this branch doesn't have any refs: in any commits. Should I amend them to mention this bug report?

#7 Updated by CyrilBrulebois 10 months ago

  • Assignee changed from CyrilBrulebois to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

#8 Updated by intrigeri 10 months ago

You'll find an updated branch with an extra commit on my repository.

Thanks!

By the way, I've just noticed that this branch doesn't have any refs: in any commits. Should I amend them to mention this bug report?

No, don't bother.

#9 Updated by intrigeri 10 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 60

Code review passes, now testing.

#10 Updated by intrigeri 10 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 60 to 100
  • QA Check changed from Ready for QA to Pass

Merged!

#11 Updated by intrigeri 10 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF