Project

General

Profile

Bug #15781

Feature #14568: Additional Software Packages

New ASP code disables pre-existing live-additional-software.conf after upgrade

Added by intrigeri 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Persistence
Target version:
Start date:
08/10/2018
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/15781-asp-cofiguration-file-migration
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

I've tried upgrading a USB stick that already had a persistent volume, using an ISO built from from the topic branch. When rebooting after the upgrade:

  1. my old (empty) live-additional-software.conf was disabled, because it has was created on Tails 3.8 with 600 permissions;
  2. a new live-additional-software.conf file is created, also with 600 permissions, so the ASP config GUI won't start and I believe that file will itself be disabled on next boot.

The only way to recover from this situation is to manually chmod 644 the file (as root, on the command line).

We can't merge a branch aimed at improving ASP if it fully breaks the feature for everyone who already had a persistent volume (regardless of whether they were using ASP or not), hence the High priority.

I believe 636fde21d3920c15b977dfed68dcf76c1bcb1d85 is the culprit. It's kinda funny to disable a file with perms 600, stating that it "has unsafe access rights", because we now expect — and need — more relaxed permissions :)

I recommend the following:

  • if the file has permissions 644 and the expected ownership and ACLs, fine, leave it alone
  • else, if the file has permissions 600 and the expected ownership and ACLs, then make it 644
  • else, disable the file

Associated revisions

Revision f7c31127 (diff)
Added by alant 9 months ago

ASP: fix access right of old configuration file

Will-fix: #15781

Revision 1ac10aa5 (diff)
Added by alant 9 months ago

ASP: fix syntax of f7c3112

Will-fix: #15781

History

#1 Updated by alant 9 months ago

  • Status changed from Confirmed to In Progress

#2 Updated by alant 9 months ago

  • % Done changed from 0 to 30
  • QA Check set to Ready for QA

#3 Updated by alant 9 months ago

  • Assignee changed from alant to segfault
  • % Done changed from 30 to 80
  • Feature Branch changed from feature/14594-asp-gui to bugfix/15781-asp-cofiguration-file-migration

I pushed a fix and tested it in a build. I did push it to the feature/14594-asp-gui for that which was stupid, sorry. It's two more commits to review.

#4 Updated by alant 9 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (segfault)
  • % Done changed from 80 to 100
  • QA Check changed from Ready for QA to Pass

I just saw you already reviewed this. Sorry for the noise

#5 Updated by segfault 9 months ago

Yes, I reviewed f7c31127c5b039f03414fae1c63c4be21b6cc3e4 and 1ac10aa5cbe9486d8f59bdae72f2661d2ad52231 as part of #14598.

#6 Updated by intrigeri 9 months ago

I pushed a fix and tested it in a build. I did push it to the feature/14594-asp-gui for that which was stupid, sorry.

IMO that was the right thing to do: we can't merge feature/14594-asp-gui without this fix anyway so implementing it on a different branch just adds overhead.

Also available in: Atom PDF