Project

General

Profile

Bug #15776

Bug #11082: Replace Liferea

Remove Liferea

Added by intrigeri 10 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/09/2018
Due date:
% Done:

100%

Feature Branch:
feature/11082-deprecate-liferea
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Feed Reader

Description

3.9 will have the deprecation wrapper + updated doc that recommends Thunderbird instead of Liferea. Then as per #11082#note-17 we shall remove Liferea in 3.10 or 3.11.


Related issues

Related to Tails - Bug #9429: Liferea internal browser's Javascript should be disabled by default Rejected 05/19/2015
Blocked by Tails - Feature #15745: Update doc wrt. Liferea → Thunderbird as the default feed reader Resolved 07/22/2018
Blocked by Tails - Bug #15775: Adjust persistence setup to Thunderbird being recommended for feeds Resolved 08/08/2018
Blocks Tails - Feature #15507: Core work 2019Q1: Foundations Team Resolved 04/08/2018
Blocked by Tails - Bug #16134: devel branch FTBFS since torbrowser-launcher 0.3.1-2 was uploaded to sid Resolved 11/17/2018
Blocks Tails - Bug #11051: Audit applications using WebKit ports in Tails Resolved 01/06/2019

Associated revisions

Revision fd8aaefa (diff)
Added by intrigeri 7 months ago

Remove Liferea (refs: #11082, #15776)

History

#1 Updated by intrigeri 10 months ago

  • Blocked by Feature #15745: Update doc wrt. Liferea → Thunderbird as the default feed reader added

#2 Updated by intrigeri 10 months ago

  • Blocked by Bug #15775: Adjust persistence setup to Thunderbird being recommended for feeds added

#3 Updated by intrigeri 10 months ago

#4 Updated by intrigeri 10 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

Let's do this in a major release.

#5 Updated by u 10 months ago

  • Related to Bug #9429: Liferea internal browser's Javascript should be disabled by default added

#6 Updated by u 10 months ago

  • Related to Bug #11051: Audit applications using WebKit ports in Tails added

#7 Updated by intrigeri 10 months ago

#8 Updated by intrigeri 10 months ago

#9 Updated by intrigeri 7 months ago

  • Status changed from Confirmed to In Progress

#10 Updated by intrigeri 7 months ago

  • % Done changed from 0 to 10
  • Feature Branch set to feature/11082-deprecate-liferea

#11 Updated by intrigeri 7 months ago

  • Blocked by Bug #16134: devel branch FTBFS since torbrowser-launcher 0.3.1-2 was uploaded to sid added

#12 Updated by intrigeri 7 months ago

  • Assignee changed from intrigeri to segfault
  • QA Check set to Ready for QA

#13 Updated by intrigeri 7 months ago

  • Related to deleted (Bug #11051: Audit applications using WebKit ports in Tails)

#14 Updated by intrigeri 7 months ago

  • Blocks Bug #11051: Audit applications using WebKit ports in Tails added

#15 Updated by intrigeri 7 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (segfault)
  • % Done changed from 10 to 100
  • QA Check changed from Ready for QA to Pass

segfault merged this with 0af6e1aeae39b2d0c9d905cbb7d55ab73c48961c (that referenced the wrong ticket, probably due to the naming of my branch).

#16 Updated by anonym 5 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF