Project

General

Profile

Bug #15774

Document workaround for soft lockup with Dell XPS 15 9560 and NVidia pascal

Added by goupille over 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
08/08/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

A user reported being showed a "soft lockup - CPU#X stuck for 22s" at boot with a Dell XPS 15 9560, with a core i7-7700 dual GPU (Intel HD Graphics 630 and NVIDIA GeForce GTX 1050).

just using the nouveau.modeset=0 parameter didn't solve the issue, however, the following parameters did :

acpi_osi=linux acpi_backlight=vendor nouveau.modeset=0

there is an extended thread about this laptop's linux support here :
https://bbs.archlinux.org/viewtopic.php?id=223056

note that another user with an Asus ux550 (same chipset, proc and GPUs) saw the same issue, unfortunately, even if tails can boot with them, the boot parameters break the screen backlight.


Related issues

Blocks Tails - Feature #15507: Core work 2019Q1: Foundations Team Resolved 04/08/2018

Associated revisions

Revision 01b39233 (diff)
Added by intrigeri 11 months ago

Document workaround for Dell XPS 15 9560 (Closes: #15774).

History

#1 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to goupille
  • QA Check set to Info Needed

A user reported being showed a "soft lockup - CPU#X stuck for 22s" at boot

… and then what happens?

#2 Updated by goupille over 1 year ago

  • Assignee changed from goupille to intrigeri

intrigeri wrote:

A user reported being showed a "soft lockup - CPU#X stuck for 22s" at boot

… and then what happens?

the computer get stuck on that error (I don't know if it is frozen).

#3 Updated by goupille over 1 year ago

goupille wrote:

note that another user with an Asus ux550 (same chipset, proc and GPUs) saw the same issue, unfortunately, even if tails can boot with them, the boot parameters break the screen backlight.

for this particular computer, according to the user, the following parameters fix the issue without messing with the backlight :

acpi_osi=! acpi_osi="Windows 2009" nouveau.modeset=0

#4 Updated by goupille over 1 year ago

goupille wrote:

note that another user with an Asus ux550 (same chipset, proc and GPUs)

sorry it is an Asus FX503VD, same processor and GPUs

#5 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to goupille

Thanks, I'll document the workaround for that Dell XPS.

note that another user with an Asus ux550 (same chipset, proc and GPUs) saw the same issue, unfortunately, even if tails can boot with them, the boot parameters break the screen backlight.

I'll document the workaround for this one too but I cannot write "break the screen backlight": I don't even know what it means. Does it mean that the screen brightness cannot be controlled via hardware buttons? And/or cannot be controlled via the GNOME system menu?

#6 Updated by intrigeri over 1 year ago

A user reported being showed a "soft lockup - CPU#X stuck for 22s" at boot with a Dell XPS 15 9560, with a core i7-7700 dual GPU (Intel HD Graphics 630 and NVIDIA GeForce GTX 1050).

just using the nouveau.modeset=0 parameter didn't solve the issue, however, the following parameters did :

> acpi_osi=linux acpi_backlight=vendor nouveau.modeset=0
> 

According to the online resources you've pointed me to, acpi_rev_override=1 is a better solution, so please have the user try acpi_rev_override=1 nouveau.modeset=0; and if that does not work, acpi_rev_override=1 acpi_backlight=vendor nouveau.modeset=0.

#7 Updated by goupille over 1 year ago

intrigeri wrote:

I'll document the workaround for this one too but I cannot write "break the screen backlight": I don't even know what it means. Does it mean that the screen brightness cannot be controlled via hardware buttons? And/or cannot be controlled via the GNOME system menu?

sorry about that, according to the user, by "break the screen backlight" I mean that the screen brightness is set to 0, the user can see that something is displayed on the screen but there is no backlight. pushing the brightness cursor to the maximum with the keyboard or the Gnome menu, in the greeter or on Tails desktop, doesn't change anything.

#8 Updated by goupille over 1 year ago

  • Assignee changed from goupille to intrigeri

other Dell XPS seems to be affected as well (9570)

#9 Updated by goupille about 1 year ago

several users answered that

acpi_rev_override=1 nouveau.modeset=0

fixed the issue, including one user showed with a "hard lockup" error on an Asus ux550.

However the user with the asus FX503VD (brightness issues) said that these parameters present the same problem

#10 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to goupille

Excellent, thanks! One last thing: did any of "your" users test with 3.9~rc1? If not, can you please ask them to test with and without acpi_rev_override=1 nouveau.modeset=0?

Also, please add them to the list of NVIDIA testers, at least some of them seem to be ready to test more things :)

#11 Updated by intrigeri about 1 year ago

Same question with 3.9.

#12 Updated by AtomiKe about 1 year ago

intrigeri wrote:

Excellent, thanks! One last thing: did any of "your" users test with 3.9~rc1? If not, can you please ask them to test with and without acpi_rev_override=1 nouveau.modeset=0?

Same question with 3.9.

Tested on an XPS 9560, with Tails 3.9. It doesn't work without acpi_rev_override=1 nouveau.modeset=0.

#13 Updated by intrigeri about 1 year ago

Tested on an XPS 9560, with Tails 3.9. It doesn't work without acpi_rev_override=1 nouveau.modeset=0.

Thank AtomiKe! For avoidance of doubt:

  • It does work with acpi_rev_override=1 nouveau.modeset=0, right?
  • Neither of these two single options is sufficient in itself, right?

Once I have confirmation on these two questions, I'll document the workaround :)

#14 Updated by intrigeri about 1 year ago

I got one report (c52297adde8509e04bcdf685eb7b5fbe) that says that acpi_osi=! nouveau.modeset=0 works fine on this laptop.

#15 Updated by goupille 11 months ago

  • Assignee changed from goupille to intrigeri

the users I've asked to try this workaround reported that it worked

#16 Updated by intrigeri 11 months ago

  • Category set to Hardware support
  • Target version set to Tails_3.12
  • QA Check deleted (Info Needed)
  • Type of work changed from Research to End-user documentation

#17 Updated by intrigeri 11 months ago

#18 Updated by intrigeri 11 months ago

#19 Updated by intrigeri 11 months ago

#20 Updated by intrigeri 11 months ago

  • Subject changed from soft lockup with Dell XPS 15 9560 and NVidia pascal to Document workaround for soft lockup with Dell XPS 15 9560 and NVidia pascal

#21 Updated by intrigeri 11 months ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

#22 Updated by intrigeri 11 months ago

  • Assignee deleted (intrigeri)

Also available in: Atom PDF