Project

General

Profile

Feature #15773

Feature #15023: Upgrade to Tor Browser based on Firefox ESR60

Tor Browser 8 can't install new addons

Added by segfault over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
08/08/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Tor Browser says "uBlock Origin could not be installed because Tor Browser cannot modify the needed file".

The log says:

1533738639975 addons.xpi ERROR Failed to move file /home/amnesia/.tor-browser/profile.default/extensions/uBlock0@raymondhill.net to /home/amnesia/.tor-browser/profile.default/extensions/trash: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.moveTo]" nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)" location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: _installFile :: line 582" data: no] Stack trace: _installFile()@resource://gre/modules/addons/XPIProvider.jsm:582
_installDirEntry()@resource://gre/modules/addons/XPIProvider.jsm:663

History

#1 Updated by segfault over 1 year ago

  • Status changed from Confirmed to Rejected

That was in an unclean session, I could not reproduce it in a clean one.

Also available in: Atom PDF