Project

General

Profile

Bug #15757

Feature #14468: Add VeraCrypt support to Tails

Feature #14480: Fix bugs and UX issues of VeraCrypt support

Some VeraCrypt volumes require admin password to unlock

Added by segfault about 1 year ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/31/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:


Related issues

Related to Tails - Bug #15733: Unlocking TCRYPT volume sometimes shows a confusing error message Resolved 07/16/2018

History

#1 Updated by segfault about 1 year ago

  • Subject changed from Some volumes require admin password to unlock to Some VeraCrypt volumes require admin password to unlock

#2 Updated by segfault about 1 year ago

I was not able to reproduce this issue - it does not happen with the file containers and the USB stick I use for testing.

#3 Updated by intrigeri about 1 year ago

  • Type of work changed from Research to Communicate

Maybe ping the bug reporter and ask help desk if they've received anything?

#4 Updated by segfault 12 months ago

  • Description updated (diff)

#5 Updated by segfault 12 months ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

#6 Updated by intrigeri 12 months ago

  • Description updated (diff)

#7 Updated by intrigeri 12 months ago

If you don't manage to gather enough debugging info to understand (and ideally, fix) this bug, perhaps the best we can do is to document the workaround.

#8 Updated by segfault 10 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#9 Updated by intrigeri 10 months ago

intrigeri wrote:

If you don't manage to gather enough debugging info to understand (and ideally, fix) this bug, perhaps the best we can do is to document the workaround.

Let's decide something, please :)

#10 Updated by intrigeri 10 months ago

  1. ask reporters to reproduce on 3.10.1
  2. try to reproduce with a non-removable USB stick

If none of these bring us a reproducer, close.

#11 Updated by segfault 10 months ago

  • Related to Bug #15733: Unlocking TCRYPT volume sometimes shows a confusing error message added

#12 Updated by segfault 10 months ago

  • Tracker changed from Feature to Bug

intrigeri wrote:

  1. try to reproduce with a non-removable USB stick

I was not able to reproduce with a non-removable USB stick. But I noticed something else (or actually, remembered something I had already noticed, but forgot to document): The user will get prompted for an admin password if they try to mount a volume for which the timeout exceeded during unlocking (see #15733). When this happens, udisks does not store the UID which unlocked the volume, so it doesn't know that the user is allowed to mount it.

So it might be that only users which were affected by #15733 were affected by this.

#13 Updated by segfault 10 months ago

ask reporters to reproduce on 3.10.1

I sent an email to the three reporters listed in the description and asked them to reproduce this on 3.10.1.

#14 Updated by intrigeri 10 months ago

I was not able to reproduce with a non-removable USB stick. But I noticed something else (or actually, remembered something I had already noticed, but forgot to document): The user will get prompted for an admin password if they try to mount a volume for which the timeout exceeded during unlocking (see #15733). When this happens, udisks does not store the UID which unlocked the volume, so it doesn't know that the user is allowed to mount it.

OK, good to know!

I sent an email to the three reporters listed in the description and asked them to reproduce this on 3.10.1.

Great. Let's close as resolved unless there are new failure reports or these folks report they can reproduce on 3.10.1 by Nov 18.

#15 Updated by intrigeri 9 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 80

#16 Updated by segfault 9 months ago

segfault wrote:

I sent an email to the three reporters listed in the description and asked them to reproduce this on 3.10.1.

So far, two of the three reporters replied to my request: One can still reproduce their issue with 3.10.1, the other one can't. I got a whisperback report from the first one, I will see if I can figure out their problem from the logs.

#17 Updated by segfault 8 months ago

segfault wrote:

So far, two of the three reporters replied to my request: One can still reproduce their issue with 3.10.1, the other one can't. I got a whisperback report from the first one, I will see if I can figure out their problem from the logs.

The whisperback report showed that the user didn't actually try any of the supported ways to unlock a VeraCrypt volume, but used the VeraCrypt application. They didn't reply back to my request to try it with a supported method.

So of all the users who reported issues with volumes requiring an admin password (it were actually four, not three) one tried it again in 3.10.1 and didn't encounter the issue anymore.

#18 Updated by CyrilBrulebois 8 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#19 Updated by anonym 7 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#20 Updated by intrigeri 6 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (segfault)
  • % Done changed from 80 to 100

Two months later, I'm closing this as fixed or unreproducible.

Please reopen if you have more info.

Also available in: Atom PDF