Project

General

Profile

Bug #15744

All branches FTBFS since CUPS DSA-4243-1

Added by intrigeri over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
07/22/2018
Due date:
% Done:

100%

Feature Branch:
bugfix/15744-ftbfs-dsa-4243-1+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Duplicated by Tails - Bug #15737: devel branch FTBFS because of cups AppArmor profile update Duplicate 07/17/2018
Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018

Associated revisions

Revision cdde464a (diff)
Added by intrigeri over 1 year ago

Unfuzzy CUPS AppArmor profile patch (refs: #15744)

Revision 26512ded (diff)
Added by intrigeri over 1 year ago

AppArmor CUPS profile: drop duplicate rule for /usr/lib/cups/backend/mdns (refs: #15744)

Since the cups 2.2.1-8+deb9u2 upload, the default profile confines
the mdns backend with the same rules (ix) as the cupsd binary,
so the rule for it we added manually will conflict. Let's drop it
and follow upstream's lead.

History

#1 Updated by intrigeri over 1 year ago

#2 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/15744-ftbfs-dsa-4243-1+force-all-tests

#3 Updated by intrigeri over 1 year ago

  • Duplicated by Bug #15737: devel branch FTBFS because of cups AppArmor profile update added

#4 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to 11
  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 100

Merged!

segfault, please ensure you include the time you've spent on this ticket in your Q3 timesheet :)

#5 Updated by intrigeri over 1 year ago

  • Status changed from 11 to In Progress

#6 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to 11

#7 Updated by intrigeri about 1 year ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF