Project

General

Profile

Bug #15738

Test feedback when opening applications from the Applications menu

Added by sajolida 12 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/17/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

While working on #15101 we realized that the lack of feedback might also affect other applications and not only the desktop launchers.

We should test the stuff we have in the Applications menu to see if there's anything else to fix in some application's code.


Related issues

Related to Tails - Bug #15101: Add feedback when opening desktop launchers Resolved 12/25/2017
Related to Tails - Feature #16334: Add feedback when opening VeraCrypt Mounter Resolved 01/09/2019
Related to Tails - Bug #16333: Add feedback when opening WhisperBack Resolved 01/09/2019
Blocks Tails - Feature #16080: Core work 2018Q4 → 2019Q2: User experience Confirmed 10/29/2018

History

#1 Updated by sajolida 12 months ago

  • Blocks Feature #15392: Core work 2018Q2 → 2018Q3: User experience added

#2 Updated by intrigeri 12 months ago

  • Related to Bug #15101: Add feedback when opening desktop launchers added

#3 Updated by sajolida 11 months ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

#4 Updated by sajolida 10 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Info Needed
  • Type of work changed from Test to Code

I tested all the entries in our Applications menu and here are the ones that don't trigger a spinner on the main mouse pointer:

  • KeePassX
  • Scribus: there's a (buggy) splash screen but GIMP has both a splash screen and a spinner
  • Electrum
  • OnionShare
  • Unsafe Browser: there's a spinner in the top navigation bar but not on the main mouse pointer (and people don't notice the application menu in the top navigation bar)
  • bookletimposer
  • Audacity: same as Scribus, there's a splash screen but no spinner on the main mouse pointer
  • Traverso
  • MAT
  • Synaptic
  • Tails Installer
  • WhisperBack
  • Unlock VeraCrypt Volumes

I'm relating this to #14544 and reassigning to intrigeri for more guidance.

What's the next step: reporting bugs upstream to all these?

#5 Updated by intrigeri 10 months ago

  • Assignee changed from intrigeri to sajolida

I tested all the entries in our Applications menu and here are the ones that don't trigger a spinner on the main mouse pointer:

Wow, great!

  • Unsafe Browser: there's a spinner in the top navigation bar but not on the main mouse pointer (and people don't notice the application menu in the top navigation bar)

FTR I can't reproduce this problem on 3.9 so I wonder if we're testing things differently. In passing, if the mouse cursor is above a window with a text area (e.g. a Terminal), then the cursor remains the text caret (that looks like a "I"). Maybe this explains some of your results and it would be good to re-test with no open window before reporting bugs upstream?

What's the next step: reporting bugs upstream to all these?

Almost:

  • For software we're not upstream of: reproduce on pristine Debian testing/sid and if reproduced, report upstream.
  • For software we're upstream of: file a Redmine ticket.

#6 Updated by sajolida 9 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#7 Updated by sajolida 9 months ago

  • Blocks deleted (Feature #15392: Core work 2018Q2 → 2018Q3: User experience)

#8 Updated by sajolida 9 months ago

  • Blocks Feature #16080: Core work 2018Q4 → 2019Q2: User experience added

#9 Updated by sajolida 7 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#10 Updated by sajolida 6 months ago

I installed a sid virtual machine (on the Mac!). I guess it'll be useful for other things in the future.

I could reproduce my tests.

I submitted pull requests to fix this in the following software:

To not too much time on this, I'll skip reporting to:

  • Audacity and Scribus as they have some kind of splash screen already
  • MAT as they are moving away from having a standalone GUI
  • bookletimposer as the user base is too small I think

I'll work on a branches to fix this for WhisperBack and VeraCrypt Mounter.

#11 Updated by sajolida 6 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Info Needed)

Done on #16333 and #16334.

#12 Updated by intrigeri 6 months ago

I submitted pull requests to fix this in the following software:

Wow, amazing!

#13 Updated by intrigeri 6 months ago

  • Related to Feature #16334: Add feedback when opening VeraCrypt Mounter added

#14 Updated by intrigeri 6 months ago

  • Related to Bug #16333: Add feedback when opening WhisperBack added

Also available in: Atom PDF