Project

General

Profile

Bug #15737

devel branch FTBFS because of cups AppArmor profile update

Added by segfault over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
07/17/2018
Due date:
% Done:

0%

Feature Branch:
segfault:bugfix/15737-refresh-cups-AppArmor-profile
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Duplicates Tails - Bug #15744: All branches FTBFS since CUPS DSA-4243-1 Resolved 07/22/2018

History

#1 Updated by segfault over 1 year ago

  • Assignee set to intrigeri
  • QA Check set to Ready for QA
  • Feature Branch set to segfault:bugfix/15737-refresh-cups-AppArmor-profile

Fixed in the bugfix/15737-refresh-cups-AppArmor-profile branch in my repo.

#2 Updated by segfault over 1 year ago

I just noticed that my previous commit resulted in an invalid AppArmor profile for cups, because it had two conflicting rules for /usr/lib/cups/backend/mdns. I fixed the conflict by removing the rule we used to add, and keeping the rule that was introduced in 2.2.1-8+deb9u2.

#3 Updated by intrigeri over 1 year ago

  • Duplicates Bug #15744: All branches FTBFS since CUPS DSA-4243-1 added

#4 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to Duplicate
  • Assignee deleted (intrigeri)
  • QA Check deleted (Ready for QA)

Sorry, I've filed #15744 and duplicated your work before noticing tis ticket. My branch is based on stable (which also FTBFS) and the resulting config/chroot_local-patches/apparmor-adjust-cupsd-profile.diff is identical so I'll take this as a +1 review from you for my branch, and will merge it into stable (and in turn into devel) if the tests pass.

Also available in: Atom PDF