Project

General

Profile

Feature #15718

Help Tails users on Mac access right-click menus

Added by sajolida over 1 year ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
-
Start date:
07/05/2018
Due date:
% Done:

0%

Feature Branch:
doc/15718-right-click-on-mac
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

Now that I'm a Tails user on Mac (haha!) I realize that I don't know how to do right-click from Tails on Mac.

We are documenting right-click in several places in our documentation:

  • To unlock a VeraCrypt file container (upcoming)
  • To verify a Tails image from Tails using OpenPGP
  • To calculate checksums of files using GtkHash
  • To securely delete files

In macOS I can do Ctrl+click to do right click but on Tails it doesn't work.

I think at some point I found online an very obscure key combination that's supposed to work on Linux but since two days I've looked for it again and can't find it again. I bet most of our users won't find it either.

So my questions are:

  • To other Tails users on Mac: how do you do right-click in Tails? Then we should at least make this information easy to find in our documentation.
  • To devs: could we consider making Ctrl+click do a right-click in Tails?

NB: Asking people to use an external mouse or avoid right-clicking is not an acceptable option.


Related issues

Blocks Tails - Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing Confirmed 01/08/2016

History

#1 Updated by sajolida over 1 year ago

Assigning to mercedes for his deep knowledge of Tails on Mac.

Ah, and that's a personal note: I'm also looking for how to do "Delete" (and not "Backspace") on Mac :)

#2 Updated by sajolida over 1 year ago

  • Blocks Feature #15392: Core work 2018Q2 → 2018Q3: User experience added

#3 Updated by muri over 1 year ago

hi,

on a macbook air (11", i think its from 2011), i can right click using a 'two-finger-tap' on the touchpad. The 'Delete' button is emulated using Fn+Backspace.

#4 Updated by sajolida over 1 year ago

  • Assignee set to intrigeri
  • QA Check set to Info Needed

Super helpful muri, thanks!

  • Fn+Backspace is also how to type "Delete" on macOS, so I'll blame my ignorance here (and thank you again).
  • Two finger tap is also advertised as an alternative to Ctrl+Click on macOS. But I'll only partly blame my ignorance here because Ctrl+Click is the most documented option.

intrigeri: Do you think it would make sense to map Ctrl+Click to right-click on Tails as well?

See for example: https://askubuntu.com/questions/742920/ubuntu-to-mac-ctrlclick-right-click.

#5 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to sajolida

intrigeri: Do you think it would make sense to map Ctrl+Click to right-click on Tails as well?

I have no strong opinion on this but I'm curious about:

  • why isn't GNOME doing this by default on Mac hardware?
  • is CTRL + left-click used elsewhere already, i.e. what would this change break?

With my FT hat on, if you tell me it's the right thing to do, then I'll take a clean, simple, and Wayland-compatible patch that implements it.

#6 Updated by sajolida over 1 year ago

  • why isn't GNOME doing this by default on Mac hardware?

I could only find a ticket from 2008 about that:

https://bugzilla.gnome.org/show_bug.cgi?id=559833

The information on there is partly outdated.

  • is CTRL + left-click used elsewhere already, i.e. what would this change break?

I realized only now that Ctrl+Click is a standard to toggle a list item
selection, for example in GNOME Files.

So I'll fallback on documenting this. I was doubting whether documenting
this only in one place, but then I was not sure where, or documenting it
every time we use right-click.

See that we use right-click only in a few places, I'll try to document
it every time and add it to the style guide.

#7 Updated by sajolida over 1 year ago

  • Blocks Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing added

#8 Updated by sajolida over 1 year ago

  • Blocks deleted (Feature #15392: Core work 2018Q2 → 2018Q3: User experience)

#9 Updated by intrigeri over 1 year ago

I realized only now that Ctrl+Click is a standard to toggle a list item selection, for example in GNOME Files.

Good catch!

#10 Updated by sajolida over 1 year ago

  • Target version set to Tails_3.10.1

#11 Updated by sajolida over 1 year ago

  • Blocks deleted (Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing)

#12 Updated by sajolida over 1 year ago

  • Blocks Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing added

#13 Updated by sajolida about 1 year ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#14 Updated by sajolida about 1 year ago

  • Target version changed from Tails_3.11 to Tails_3.12

#15 Updated by sajolida 11 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#16 Updated by sajolida 10 months ago

  • QA Check deleted (Info Needed)

#17 Updated by sajolida 9 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#18 Updated by sajolida 7 months ago

  • Target version deleted (Tails_3.14)

#19 Updated by sajolida 5 months ago

  • Blocks Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing added

#20 Updated by sajolida 5 months ago

  • Blocks deleted (Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing)

#21 Updated by sajolida 4 months ago

  • Status changed from Confirmed to Needs Validation
  • Assignee changed from sajolida to cbrownstein
  • Feature Branch set to doc/15718-right-click-on-mac

Here is a branch.

#22 Updated by sajolida 3 months ago

@cbrownstein: Ping on this review. This one is pretty tiny.

#23 Updated by cbrownstein 3 months ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from cbrownstein to sajolida

I pushed a single change to my branch. Otherwise, looks good!

https://0xacab.org/cbrownstein/tails/commits/doc/15718-right-click-on-mac

#24 Updated by sajolida 3 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

Good catch!

I did something very silly earlier today and broke the build on the website. I merged it locally and will push this once it's fixed by our dear sysadmins.

Also available in: Atom PDF