Project

General

Profile

Bug #15715

Translatable strings for the torstatus GNOME Shell extension are not taken into account

Added by intrigeri over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
Start date:
07/05/2018
Due date:
% Done:

100%

Estimated time:
0.25 h
Feature Branch:
bugfix/15715-torstatus-l10n
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Onion Circuits

Description

refresh-translations extracts them into tmp/pot/extension.js.pot but then nothing more happens because that file is not in po/POTFILES.in. So the strings (e.g. "Open Onion Circuits") don't end up in tails.pot, never get translated, and are always displayed in English in the GUI.


Related issues

Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018

Associated revisions

Revision 84aec1ed (diff)
Added by intrigeri over 1 year ago

Have translatable strings for the torstatus GNOME Shell extension added to tails.pot (refs: #15715).

Previously, refresh-translations extracted them into tmp/pot/extension.js.pot
but then nothing more happened because that file was not in po/POTFILES.in.
So the strings (e.g. "Open Onion Circuits") did not end up in tails.pot, never
got translated, and were always displayed in English in the GUI.

Revision b31c81e7 (diff)
Added by intrigeri over 1 year ago

[fr] Translate one string from the Tor Status extension (refs: #15715).

… so that I can confirm that such translations are now taken into account.

Revision 152a21ae
Added by intrigeri over 1 year ago

Merge branch 'bugfix/15715-torstatus-l10n' into stable (Fix-committed: #15715)

History

#1 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/15715-torstatus-l10n

#2 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to segfault
  • % Done changed from 10 to 50
  • Estimated time set to 0.25 h
  • QA Check set to Ready for QA

I've built an ISO, started it in French, clicked the Tor Status icon and verified that "Open Onion Circuits" text is correctly translated into French. So I think all you need to do is a quick code review of my (trivial) changes. Thanks in advance!

#3 Updated by segfault over 1 year ago

  • Assignee changed from segfault to intrigeri
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

LGTM

#4 Updated by intrigeri over 1 year ago

  • Assignee deleted (intrigeri)

Woohoo! Merged into stable and in turn into devel.

#5 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to 11

#6 Updated by intrigeri about 1 year ago

  • Status changed from 11 to Resolved

#7 Updated by segfault about 1 year ago

Also available in: Atom PDF