Project

General

Profile

Bug #15711

tails@ email contact OpenPGP key expires on 2018-10-01

Added by intrigeri about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
07/05/2018
Due date:
% Done:

50%

Feature Branch:
web/15711-update-email-key
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:

Description

As our test suite says:

The following key(s) will not be valid in 3 months: 09F6BC8FEEC9D8EE005DBAA41D2975EDF93E735F, C3948FE7B604C6114E294DDFD843C2F5E89382EB.

Related issues

Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018

Associated revisions

Revision 77612f28 (diff)
Added by intrigeri about 1 year ago

Update expiration date for tails@ email contact key (refs: #15711).

History

#1 Updated by intrigeri about 1 year ago

#2 Updated by intrigeri about 1 year ago

  • Description updated (diff)

#3 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to sajolida
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to web/15711-update-email-key

#4 Updated by intrigeri about 1 year ago

Notes to the reviewer:

  • The reason for the >> Normal priority is that due to the current expiration date, all test suite runs on Jenkins fail.
  • Please merge into master, then master into stable, then stable into devel.

Thanks in advance!

#5 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Ready for QA to Info Needed

Looks good to me. Merged all the way to devel.

Still, you changed the expiration date from 2018-10-01 to 2019-08-01. Having to do this again in 10 months sounds very little to me.

Why don't we push our keys forward by 2 years for example?

#6 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Info Needed to Ready for QA

sajolida wrote:

Looks good to me. Merged all the way to devel.

Thank you.

Still, you changed the expiration date from 2018-10-01 to 2019-08-01. Having to do this again in 10 months sounds very little to me.

Why don't we push our keys forward by 2 years for example?

I asked to do it that way because on 2019-08-01 this key will be 10 years old and I'd like us to have something that forces us to consider rotating it entirely. It's likely I'll be the one who notices the test failures next year again, and before I ask for a key to be updated I always check how old it is, so that should be enough. Sounds good?

#7 Updated by sajolida about 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

Sounds like a good reason, indeed :)

Also available in: Atom PDF