Project

General

Profile

Bug #15708

Feature #15023: Upgrade to Tor Browser based on Firefox ESR60

The Unsafe Browser lacks some of our customization with Firefox ESR60

Added by intrigeri 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
07/03/2018
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

  • it's listed as "Tor Browser" in the taskbar, while the window title is correct
  • it has search engines, while we try to disable search

Related issues

Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018

Associated revisions

Revision 81cbfa4e (diff)
Added by intrigeri 11 months ago

Fix some of the places where the Unsafe Browser displayed name was "Tor Browser" (refs: #15708).

This does not address the main problem (the name of the app in the taskbar)
but it's a start.

Revision d318f00f (diff)
Added by intrigeri 11 months ago

Delete all search plugins for the chroot'ed browsers (refs: #15708).

I did not manage to prevent the omnibar from allowing search
so let's simply delete the search plugins, which is the same,
from an end-user perspective, as before: we hid the search bar
via userChrome.css.

I'm not removing this one-liner in userChrome.css though, just in case it's
re-enabled by default at some point via Tor Browser prefs or something.

Revision 03bb07ec (diff)
Added by intrigeri 11 months ago

Fix "Delete all search plugins for the chroot'ed browsers" (refs: #15708).

Revision 263e2b59 (diff)
Added by intrigeri 11 months ago

Fix "Delete all search plugins for the chroot'ed browsers", again (refs: #15708).

Revision 6a819ffb (diff)
Added by intrigeri 11 months ago

Explicitly set the Unsafe Browser's WM_CLASS (refs: #15708)

… otherwise it appears as "Tor Browser" in the taskbar.

Revision 990dbf06 (diff)
Added by intrigeri 11 months ago

Fix the name and icon of the Unsafe Browser in the top bar in non-English languages (refs: #15708)

History

#1 Updated by intrigeri 11 months ago

#2 Updated by intrigeri 11 months ago

  • Assignee set to intrigeri

#3 Updated by intrigeri 11 months ago

intrigeri wrote:

  • it's listed as "Tor Browser" in the taskbar, while the window title is correct

Next steps:

  • try to patch chrome/en-US/locale/branding/brand.properties too.
  • grep "Tor Browser" in the profile directory and omni.ja archives
  • strace to find out where this string comes from

#4 Updated by intrigeri 11 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

intrigeri wrote:

intrigeri wrote:

  • it's listed as "Tor Browser" in the taskbar, while the window title is correct

Next steps:

  • try to patch chrome/en-US/locale/branding/brand.properties too.

That did the trick.

#5 Updated by intrigeri 11 months ago

  • % Done changed from 10 to 20
  • it has search engines, while we try to disable them

In a clean Tor Browser installation outside of Tails I've managed to hide all search engines this way:

  • Browser/browser/omni.ja
    • delete chrome/en-US/locale/browser/searchplugins/*.xml
    • echo '{"default": {"visibleDefaultEngines": []}, "experimental-hidden": {"visibleDefaultEngines": []}}' > chrome/en-US/locale/browser/searchplugins/list.json
  • Browser/TorBrowser/Data/Browser/profile.default/extensions/langpack-*@firefox.mozilla.org.xpi
    • delete browser/chrome/fr/locale/browser/searchplugins/*.xml
    • overwrite each browser/chrome/*/locale/browser/searchplugins/list.json with {"default": {"visibleDefaultEngines": []}, "experimental-hidden": {"visibleDefaultEngines": []}}

Next step: have the Unsafe Browser startup script do that.

#6 Updated by intrigeri 11 months ago

intrigeri wrote:

intrigeri wrote:

intrigeri wrote:

  • it's listed as "Tor Browser" in the taskbar, while the window title is correct

Next steps:

  • try to patch chrome/en-US/locale/branding/brand.properties too.

That did the trick.

Does not work in French.

#7 Updated by intrigeri 11 months ago

  • Description updated (diff)

#8 Updated by intrigeri 11 months ago

  • % Done changed from 20 to 50
  • QA Check set to Ready for QA

Update: the 2 problems discussed so far here seem to be mostly fixed, my next ISO rebuild will tell.

But the title of the app in the top bar suffers of ugly char encoding problems (reproducible in French: WM_CLASS(STRING) = "Navigator", "Navigateur non-s\303\251curis\303\251")… that I can reproduce on my sid system by running firefox --class="Navigateur non-sécurisé" in y terminal, so the problem is probably in Firefox or in GNOME. Given the --class option is not documented I don't expect Mozilla to care much about it, and this seems too hardcore for GNOME people to care either. Anyway, there are plenty of cues to tell the user what this app is: it's the one they've just started, the notification is correctly displayed, the window title is correctly displayed, there's the red theme, and the icon in the taskbar and top bar is now the Firefox' one (while it was the Tor Browser one so far in Tails). So all in all, I think the current status on this branch is at least as good as it was in Tails 3.8, be it in terms of usability or of safety => not worth spending more time on it.

#9 Updated by intrigeri 11 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100
  • QA Check deleted (Ready for QA)

intrigeri wrote:

Update: the 2 problems discussed so far here seem to be mostly fixed, my next ISO rebuild will tell.

Confirmed.

But the title of the app in the top bar suffers of ugly char encoding problems (reproducible in French: WM_CLASS(STRING) = "Navigator", "Navigateur non-s\303\251curis\303\251")… that I can reproduce on my sid system by running firefox --class="Navigateur non-sécurisé" in y terminal, so the problem is probably in Firefox or in GNOME. Given the --class option is not documented I don't expect Mozilla to care much about it, and this seems too hardcore for GNOME people to care either. Anyway, there are plenty of cues to tell the user what this app is: it's the one they've just started, the notification is correctly displayed, the window title is correctly displayed, there's the red theme, and the icon in the taskbar and top bar is now the Firefox' one (while it was the Tor Browser one so far in Tails). So all in all, I think the current status on this branch is at least as good as it was in Tails 3.8, be it in terms of usability or of safety => not worth spending more time on it.

Fixed.

Also available in: Atom PDF