Project

General

Profile

Bug #15707

Feature #15023: Upgrade to Tor Browser based on Firefox ESR60

Our custom extensions.torbutton.launch_warning is not honored

Added by intrigeri about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
07/03/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

It's set to true even though we're trying to set it to false. Then, when opening a download URL, we get a warning dialog that we want to hide (especially since we set browser.download.forbid_open_with to true).

Associated revisions

Revision b65f1e56 (diff)
Added by intrigeri about 1 year ago

Make extensions.torbutton.launch_warning be taken into account (refs: #15707)

For some reason, it's ignored when we set it via
/usr/share/tails/tor-browser-prefs.js.

History

#1 Updated by intrigeri about 1 year ago

  • Tracker changed from Feature to Bug

#2 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

#3 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100
  • QA Check deleted (Ready for QA)

#4 Updated by intrigeri about 1 year ago

  • Assignee deleted (intrigeri)

Also available in: Atom PDF