Project

General

Profile

Bug #15706

Tor Browser 8 always prompts wrt. asking webpages in English

Added by intrigeri 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
07/03/2018
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/15803-tor-browser-8.0a10+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

… when started in a non-English locale. That is, extensions.torbutton.prompted_language is not honored.


Related issues

Related to Tails - Feature #15023: Upgrade to Tor Browser based on Firefox ESR60 Resolved 08/30/2017 08/09/2018
Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018
Blocked by Tails - Feature #15803: Upgrade Tor Browser to 8.0a10 Resolved 08/18/2018

Associated revisions

Revision f6c0009d (diff)
Added by intrigeri 5 months ago

Tell Firefox to set language setting to English (refs: #15706)

This probably won't be enough to fix #15706 ("Tor Browser 8 always prompts wrt.
asking webpages in English") until
https://trac.torproject.org/projects/tor/ticket/26409 is fixed.
But once Torbutton is fixed, then this should avoid Firefox prompting
the user.

Revision b61d81a9 (diff)
Added by intrigeri 4 months ago

Upgrade Tor Browser to 8.0a10-build5 (refs: #15803, #15706).

Revision 0634dd33 (diff)
Added by intrigeri 4 months ago

Drop obsolete Torbutton prefs (refs: #15706).

The implementation behind these prefs was superseded by the version
which was upstreamed in Firefox:
https://trac.torproject.org/projects/tor/ticket/26409

Revision efa6c024
Added by intrigeri 4 months ago

Merge branch 'feature/15803-tor-browser-8.0a10+force-all-tests' into testing (Fix-committed: #15803, #15706, #15801)

History

#1 Updated by intrigeri 5 months ago

#2 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

intrigeri wrote:

… when started in a non-English locale. That is, extensions.torbutton.prompted_language is not honored.

I've set a pref that will be useful in the future. With this in place, the prompt should disappear once https://trac.torproject.org/projects/tor/ticket/26409 is fixed. Worst case, I will submit a branch to drop the now useless code in Torbutton.

#3 Updated by intrigeri 5 months ago

  • Type of work changed from Code to Communicate

#4 Updated by intrigeri 4 months ago

  • % Done changed from 10 to 50

The upstream fix works for me so we now only have to wait for a new build that includes it.

#5 Updated by intrigeri 4 months ago

  • Type of work changed from Communicate to Wait

#6 Updated by intrigeri 4 months ago

  • Parent task deleted (#15023)

(Unparenting so I can mark #15023 as fix committed.)

#7 Updated by intrigeri 4 months ago

  • Related to Feature #15023: Upgrade to Tor Browser based on Firefox ESR60 added

#8 Updated by intrigeri 4 months ago

  • Feature Branch set to feature/15803-tor-browser-8.0a10+force-all-tests
  • Type of work changed from Wait to Code

#9 Updated by intrigeri 4 months ago

#10 Updated by intrigeri 4 months ago

  • % Done changed from 50 to 100

That's fixed on the topic branch.

#11 Updated by intrigeri 4 months ago

  • Assignee changed from intrigeri to segfault
  • QA Check set to Ready for QA

(To test this, one needs to log in with non-English.)

#12 Updated by segfault 4 months ago

  • QA Check changed from Ready for QA to Pass

Tested, works for me

#13 Updated by intrigeri 4 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (segfault)

#14 Updated by intrigeri 3 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF