Project

General

Profile

Feature #15704

Feature #15023: Upgrade to Tor Browser based on Firefox ESR60

Check what to do wrt. the libmozsandbox.so loading error

Added by intrigeri 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
07/03/2018
Due date:
08/07/2018
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

ERROR: ld.so: object 'libmozsandbox.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored. (after patching the AppArmor profile to allow reading /etc/ld.so.conf,{.d,.d/*}


Related issues

Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018

Associated revisions

Revision 0bcdc8ad (diff)
Added by intrigeri 11 months ago

Don't scrub the environment when Firefox executes itself (refs: #15704).

It causes this error:

ERROR: ld.so: object 'libmozsandbox.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

… presumably because LD_LIBRARY_PATH is not set due to the "P" profile
transition flag.

History

#1 Updated by intrigeri 11 months ago

#2 Updated by intrigeri 11 months ago

Next step: reproduce with pristine Tor Browser 8.0aN outside of Tails.

#3 Updated by intrigeri 11 months ago

  • Due date set to 08/07/2018
  • Assignee set to segfault
  • Estimated time set to 2.00 h

#4 Updated by intrigeri 11 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from segfault to intrigeri
  • Estimated time deleted (2.00 h)

Found it while investigating #15716, trivial to fix.

#5 Updated by intrigeri 11 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100
  • Type of work changed from Research to Code

0bcdc8ad14374f5c4e91807a84ece82a20e684a0

Also available in: Atom PDF