Project

General

Profile

Bug #15698

tor status: Documentation needs to be updated after screenshot update

Added by emmapeel about 1 year ago. Updated 8 days ago.

Status:
Needs Validation
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
07/01/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Yes
Affected tool:
Onion Circuits

Description

It seems it went unnoticed that the documentation pointed to the names mentioned at

https://tails.boum.org/doc/anonymous_internet/tor_status/

"In the example above, the connection to check.torproject.org goes through the relays Unnamed, betGamersTorRelay, and the exit node hessel0."

This is not true anymore. Now the nodes shown have other names.

Associated revisions

Revision 6ed446fd
Added by sajolida about 1 month ago

Merge commit 'aac439cfb1' (Closes: #15698)

History

#1 Updated by cbrownstein about 2 months ago

  • Assignee set to cbrownstein

#2 Updated by sajolida about 1 month ago

  • Status changed from Confirmed to New
  • Assignee changed from cbrownstein to emmapeel
  • Target version set to Tails_3.15

@emmapeel: Tor generates random circuits that are different each time Tails is started. The screenshot is meant as an example and advertized as such: everybody will see different names. What made you believe that everybody should see the same names?

If I misunderstood your ticket, please send me a screenshot of what you see and point me to what should be fixed in the current one.

#3 Updated by emmapeel about 1 month ago

sajolida wrote:

@emmapeel: Tor generates random circuits that are different each time Tails is started. The screenshot is meant as an example and advertized as such: everybody will see different names. What made you believe that everybody should see the same names?

No, the nodes ON THE SCREENSHOT do not change. The documentation writes about the nodes you see in the picture.

If I misunderstood your ticket, please send me a screenshot of what you see and point me to what should be fixed in the current one.

Yes, you misunderstood. There is a screenshot on the webpage, with some nodes. The name of those nodes is explained on the docs. But the screenshot was updated and now the nodes have other names.

You can see the problem if you read the link: https://tails.boum.org/doc/anonymous_internet/tor_status/ . As explained on the description, it says:

"In the example above, the connection to check.torproject.org goes through the relays Unnamed, betGamersTorRelay, and the exit node hessel0." making specific reference to the nodes shown probable on a previous screenshot

#4 Updated by emmapeel about 1 month ago

  • Status changed from New to Confirmed
  • Assignee changed from emmapeel to cbrownstein

i leave it to cbrownstein cause he seemed to take it before...

#5 Updated by cbrownstein about 1 month ago

  • Status changed from Confirmed to Needs Validation
  • Assignee changed from cbrownstein to sajolida

Here's a branch:

https://0xacab.org/cbrownstein/tails/commits/doc/15698-tor-doc-screenshot-update

Now the documentation matches the screenshot.

#6 Updated by sajolida about 1 month ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

#7 Updated by sajolida about 1 month ago

  • Status changed from Resolved to In Progress
  • Assignee changed from sajolida to cbrownstein
  • % Done changed from 100 to 0

Thanks for the branch!

Your commit 35a5544733 updates 474 PO files which is way too much to not be suspicious. I think that I've already suffered from something like this when we were working on the USB images branch. Can you please tell me which versions of the following packages you have:

dpkg -l ikiwiki libyaml-perl libyaml-libyaml-perl libyaml-syck-perl perlmagick po4a ruby

I think that we assume stable versions of these, so if you have something different than me it might be the reason why and you should force it to track stable. I can help you doing this if you're not running Debian stable.

I have:

ii  ikiwiki                                3.20190228-1             all                      wiki compiler
ii  libyaml-libyaml-perl                   0.63-2                   amd64                    Perl interface to libyaml, a YAML implementation
ii  libyaml-perl                           1.21-1                   all                      YAML Ain't Markup Language
ii  libyaml-syck-perl                      1.29-1+b2                amd64                    Perl module providing a fast, lightweight YAML loader and dumper
ii  perlmagick                             8:6.9.7.4+dfsg-11+deb9u7 all                      Perl interface to ImageMagick -- dummy package
ii  po4a                                   0.47-2                   all                      tools for helping translation of documentation
ii  ruby                                   1:2.3.3                  amd64                    Interpreter of object-oriented scripting language Ruby (default version)

So I only applied aac439cfb1 from your branch and fixed the PO files again in 9a758d88b0.

#8 Updated by cbrownstein about 1 month ago

@sajolida:

Can you please tell me which versions of the following packages you have: […]

I have:

ii  ikiwiki              3.20190228-1         all          wiki compiler
ii  libyaml-libyaml-perl 0.76+repack-1        amd64        Perl interface to libyaml, a YAML implementation
ii  libyaml-perl         1.27-1               all          YAML Ain't Markup Language
ii  libyaml-syck-perl    1.31-1+b1            amd64        Perl module providing a fast, lightweight YAML loader and dumper
ii  perlmagick           8:6.9.10.23+dfsg-2.1 all          Perl interface to ImageMagick -- dummy package
ii  po4a                 0.55-1               all          tools to ease the translation of documentation
ii  ruby                 1:2.5.1              amd64        Interpreter of object-oriented scripting language Ruby (default version)

I'm running unstable but I'll force use of the stable packages.

I think that we assume stable versions of these […]

Maybe we should mention this on the website [1]?

[1]: https://tails.boum.org/contribute/build/website/

#9 Updated by intrigeri about 1 month ago

I'm running unstable but I'll force use of the stable packages.

I believe that only po4a matters actually. That's only documented on wiki/src/contribute/release_process.mdwn but maybe we should add this to wiki/src/contribute/build/website.mdwn?

#10 Updated by sajolida 9 days ago

  • Status changed from In Progress to Needs Validation

@cbrownstein: I have a very different list indeed:

ii  ikiwiki             3.20190228-1   all            wiki compiler
ii  libyaml-libyaml-per 0.63-2         amd64          Perl interface to libyaml, a YAML implement
ii  libyaml-perl        1.21-1         all            YAML Ain't Markup Language
ii  libyaml-syck-perl   1.29-1+b2      amd64          Perl module providing a fast, lightweight Y
ii  perlmagick          8:6.9.7.4+dfsg all            Perl interface to ImageMagick -- dummy pack
ii  po4a                0.47-2         all            tools for helping translation of documentat
ii  ruby                1:2.3.3        amd64          Interpreter of object-oriented scripting la

Please force po4a from Stretch only and then close this ticket.

Thanks @intrigeri for chiming in with useful tips (as often!).

I updated this in cc3f3803aa.

#11 Updated by CyrilBrulebois 8 days ago

  • Target version changed from Tails_3.15 to Tails_3.16

Also available in: Atom PDF