Project

General

Profile

Feature #15680

Feature #14468: Add VeraCrypt support to Tails

Icon for VeraCrypt Mounter

Added by segfault over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
06/20/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Graphics
Blueprint:
Starter:
Affected tool:

Description

We decided to implement VeraCrypt Mounter, so we need an icon for it.

folder-v.png View (51.4 KB) sajolida, 07/17/2018 03:52 PM

folder-vc.png View (51.5 KB) sajolida, 07/17/2018 03:52 PM

applications-menu.png View (55.8 KB) sajolida, 07/17/2018 03:57 PM

alt-shift-menu.png View (45.4 KB) sajolida, 07/17/2018 03:57 PM

package-v.png View (37.7 KB) sajolida, 07/17/2018 04:09 PM

package-key.png View (37 KB) sajolida, 07/17/2018 04:09 PM

package-vc.xcf View (153 KB) sajolida, 07/26/2018 02:01 PM

package-vc.png View (37.7 KB) sajolida, 07/26/2018 02:01 PM


Related issues

Related to Tails - Feature #15039: Iteration 2: Icon for .hc and .tc file extension Rejected 12/10/2017
Related to Tails - Feature #15043: Iteration 4: Create VeraCrypt Mounter application Resolved 08/14/2018

History

#1 Updated by segfault over 1 year ago

  • Related to Feature #15039: Iteration 2: Icon for .hc and .tc file extension added

#2 Updated by segfault over 1 year ago

I'm really not into icon designing. For now I will use the icon u designed here (I prefer the upper right one).

#3 Updated by sajolida over 1 year ago

  • Assignee set to sajolida
  • Target version set to Tails_3.9

I'll have a look as well.

#4 Updated by intrigeri over 1 year ago

  • QA Check set to Ready for QA

#5 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50
  • Parent task deleted (#15043)

#7 Updated by sajolida over 1 year ago

  • Parent task set to #15043

#8 Updated by sajolida over 1 year ago

Hey!

Here are some other possible versions for the logo.

What I tried to improve regarding the current design:

  1. I don't think that the green triangles are a clear enough hint to the original logo to make sense for most of our users on a small size and at first sight. I'm instead reusing bigger parts of the original logo (and even the entire logo). I'm afraid we might be the only ones aware of that.
    • I wrote upstream to ask them for the license and terms of use of their logo: https://mailman.boum.org/pipermail/tails-dev/2018-July/012227.html.
    • If we can't do that, then I think that we should forget about trying to evocate their icon without reusing it and go for a simple metaphor. People are looking for anything called VeraCrypt and I don't think that the icon will make much a difference.
  2. Every other icon that we have in the Applications menus is some object with smooths colors on a transparent background. The current design has a solid background and plain colors which looks inconsistent and messy in the middle of the others. Reusing elements from other GNOME icons solves that.
    • I used the standard folder icon as it was more generic (for file containers and devices) than either a disk icon (like in the native VeraCrypt interface) or a file icon. I also tried with the standard package icon, used for ZIP files and such but I think that the methaphor of the folder is more acurate as you don't extract a VeraCrypt volume but open it.

I also attach a version with a key if we don't end up using any part of the original VeraCrypt logo.

Note that the icon also appears in the Alt+Shift menu when switching between applications. So we should make sure that it looks good there as well.

#9 Updated by segfault over 1 year ago

  • Assignee changed from segfault to sajolida
  • QA Check changed from Ready for QA to Info Needed

sajolida wrote:

Here are some other possible versions for the logo.

Cool!

What I tried to improve regarding the current design:

  1. I don't think that the green triangles are a clear enough hint to the original logo to make sense for most of our users on a small size and at first sight. I'm instead reusing bigger parts of the original logo (and even the entire logo). I'm afraid we might be the only ones aware of that.

I think the colors of the current logo are enough to show a resemblance of the original logo and help users to find the application in the menu.

Thanks! The only thing I'm not sure about is that you wrote that VeraCrypt Mounter would only be distributed as part of Tails. We might want to create a Debian package for it at some point, and then it would make sense to upload it to the Debian repo, too. That could be a problem if VeraCrypt now only gives permission for the use of their logo on the condition that it is only used in Tails.

  • If we can't do that, then I think that we should forget about trying to evocate their icon without reusing it and go for a simple metaphor. People are looking for anything called VeraCrypt and I don't think that the icon will make much a difference.
  1. Every other icon that we have in the Applications menus is some object with smooths colors on a transparent background. The current design has a solid background and plain colors which looks inconsistent and messy in the middle of the others. Reusing elements from other GNOME icons solves that.
    • I used the standard folder icon as it was more generic (for file containers and devices) than either a disk icon (like in the native VeraCrypt interface) or a file icon. I also tried with the standard package icon, used for ZIP files and such but I think that the methaphor of the folder is more acurate as you don't extract a VeraCrypt volume but open it.

I don't think we should use either a folder or package as the icon for the application. Those would be appropriate as icons for the file containers, and we could use different icons for those. But the application is not a container, it's not something that can be opened - it's the tool you use to open the containers. See also the icons of the Synaptic Package Manager and the Archive Manager, which both don't use packages in their application icons, but only for the files which they can open.

#10 Updated by segfault over 1 year ago

  1. Every other icon that we have in the Applications menus is some object with smooths colors on a transparent background. The current design has a solid background and plain colors which looks inconsistent and messy in the middle of the others.

That is correct. I would like it best if the current logo would be improved a bit to better fit in, for example by smoothing the colors a bit and only using the background color in between the rectangles, to form the shape of the key, and make the rest of the background transparent.

#11 Updated by sajolida over 1 year ago

I think the colors of the current logo are enough to show a resemblance of the original logo and help users to find the application in the menu.

Then we disagree and neither of us have data to verify our claim :)
Maybe having more people's opinion would help.

Note that your claim is the optimistic one and mine is the pessimistic
one. Of course my opinion is super biased here, but in matters of what
is clear to users, I prefer erring on the side of caution.

Thanks! The only thing I'm not sure about is that you wrote that VeraCrypt Mounter would only be distributed as part of Tails. We might want to create a Debian package for it at some point, and then it would make sense to upload it to the Debian repo, too. That could be a problem if VeraCrypt now only gives permission for the use of their logo on the condition that it is only used in Tails.

Good point! I don't remember this being discussed anywhere, sorry if I
took that for granted. Let's wait until we have an answer from VeraCrypt
and then we can adjust what we're telling them during the discussion.

But the application is not a container, it's not something that can be opened - it's the tool you use to open the containers. See also the icons of the Synaptic Package Manager and the Archive Manager, which both don't use packages in their application icons, but only for the files which they can open.

I can find many examples where GNOME applications use the object on
which the application operates as part of their icon:

- The icon for Text Editor is a notepad (object) with a pen (action)
- The icon for Brasero is a CD (object) with a light beam (action)
- The icon for Videos is a film roll (object)
- The icon for Disks is a hard drive (object) with a wrench (action)
- The icon for Document Viewer is a PDF document (object)
- The icon for Image Viewer is an image (object) with a lens (action)

The version I made with a package (object) and a key (action) aligns to
that. Similarly, the VeraCrypt icon could be considered an action.

Outside of GNOME, all the LibreOffice applications use as icon the type
of document they operate on (object).

So, from both a style and usability point of view, I think it's fine to
use a folder or a package as part of the icon.

I would like it best if the current logo would be improved a bit to
better fit in, for example by smoothing the colors a bit and only
using the background color in between the rectangles, to form the
shape of the key, and make the rest of the background transparent.

Then please don't count on me for that. It took me ~1 hour to come up
with 5 different ideas that I uploaded yesterday by reusing other GNOME
icons. Making the current icon look polished and consistent with other
icons in the GNOME set would take me much more time than that.

Still, I'm ok with trying some other combinations of preexisting GNOME
icons if we agree on a different idea, but not drawing something from
scratch.

And, only partly related, some UX theory:

https://en.wikipedia.org/wiki/Aesthetic_usability_effect

« The Aesthetic-Usability Effect describes a paradox that people
perceive more aesthetic designs as much more intuitive, than those
considered to be less aesthetically pleasing. »

« The apparent usability is less correlated with the inherent usability
compared to the apparent beauty. ... This suggests that the user may be
strongly affected by the aesthetic aspect of the interface even when
they try to evaluate the interface in its functional aspects, and it is
suggested that the interface designers should strive not only to improve
the inherent usability but also brush up the apparent usability or the
aesthetic aspect of the interface. »

So I might prefer something that's "pretty" over something that's "correct" as long as it "works fine".

#12 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to segfault

#13 Updated by intrigeri over 1 year ago

  • Type of work changed from Graphics to Communicate

#14 Updated by intrigeri over 1 year ago

If the VC logo is free software and there's no trademark problem, then package-vc.png. otherwise, if there's a consensual alternate proposal by August 2, we take it. otherwise, we fall back to package-key.png. but that should not postpone other important segfault's work.

#15 Updated by sajolida over 1 year ago

If we go for package-key.png I'd like to create a better version from the SVG source: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/blob/master/src/fullcolor/dialog-password.svg

#16 Updated by segfault over 1 year ago

  • Type of work changed from Communicate to Graphics

We got the OK from VeraCrypt to use their logo. They state that the logo is under Apache License 2.0, so that should also not be a problem if we want to use it in Debian.

I'm changing the icon to package-vc.png now.

#17 Updated by sajolida over 1 year ago

  • File deleted (package-vc.png)

#18 Updated by sajolida over 1 year ago

By a weird coincidence, VeraCrypt answered us this morning while we were having our meeting:

https://mailman.boum.org/pipermail/tails-dev/2018-July/012240.html

Their logo is licensed under the Apache License 2.0 which is compatible with the Debian Free Software Guidelines. So we're fine :)

I'm uploading a new version of the icon with the package, the full VeraCrypt logo, a slightly better alignment, and cleaned using compress-image. I'm also attaching a GIMP "source" for that.

#19 Updated by intrigeri over 1 year ago

segfault, I see you've added the VeraCrypt logo in commit:3701f37649cb63f6c4e5875d6136ef3231243b12 => please check license compatibility with GPL-3+ and update wiki/src/doc/about/license.mdwn accordingly.

#21 Updated by intrigeri over 1 year ago

See:

Thanks! I'll happily review your (segfault, I guess) conclusions :)

#22 Updated by segfault over 1 year ago

  • Assignee changed from segfault to intrigeri
  • QA Check changed from Info Needed to Ready for QA

I'll reply here to your email:

We also need:

1. to check whether that license is compatible with GPL-3+ i.e. can we
build a product that mixes works licensed under GPL-3+ and work
licensed under Apache License 2.0

https://www.gnu.org/licenses/license-list.html#apache2 says it's
OK :)

2. the copyright notice

Added to wiki/src/doc/about/license.mdwn.

3. a pointer to some authoritative-ish place where the copyright
holders made the license clear

I added a link to their reply on tails-dev to wiki/src/doc/about/license.mdwn. This is the only source we have that makes it clear that we are allowed to use the logo. The Apache License states that it does not allow to use trademarks of the copyright owner, so we are only allowed to do so because we got special permission by the copyright owner.

#23 Updated by intrigeri over 1 year ago

we are only allowed to do so because we got special permission by the copyright owner.

(Assuming the reasoning that lead you to this conclusion is correct) this is very problematic. I'll look at it closer in the next few days.

#24 Updated by segfault over 1 year ago

intrigeri wrote:

we are only allowed to do so because we got special permission by the copyright owner.

(Assuming the reasoning that lead you to this conclusion is correct) this is very problematic. I'll look at it closer in the next few days.

See https://www.apache.org/licenses/LICENSE-2.0.txt:

6. Trademarks. This License does not grant permission to use the trade
names, trademarks, service marks, or product names of the Licensor,
except as required for reasonable and customary use in describing the
origin of the Work and reproducing the content of the NOTICE file.

Btw, this might also be problematic https://www.veracrypt.fr/code/VeraCrypt/tree/README.md#n12:

Note that the license specifies, for example, that a derived work must not be called 'TrueCrypt' or 'VeraCrypt'

#25 Updated by segfault over 1 year ago

  • QA Check changed from Ready for QA to Info Needed

During todays meeting we found that

  • while we now have permission to use their logo, derivatives of Tails do not. We should ask VeraCrypt if they can also grant this permission to all derivatives of Tails
  • The VeraCrypt license says "This license does not grant you rights to use any contributors' name, logo, or trademarks, including IDRIX, VeraCrypt and all derivative names." This means that we are currently not allowed to name our application "VeraCrypt Mounter". We should ask them to grant us (and our derivates) permission to use this name.

We didn't discuss this during the meeting, but I would also like to tell them about our plans to maybe get VeraCrypt Mounter into Debian. intrigeri, do you think it would be possible to get VeraCrypt Mounter into Debian if they grant permission like "we allow the software VeraCrypt Mounter and all derivatives to use the name "VeraCrypt" in its name and the VeraCrypt logo in its icon"?

#26 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to segfault
  • QA Check changed from Info Needed to Dev Needed

We didn't discuss this during the meeting, but I would also like to tell them about our plans to maybe get VeraCrypt Mounter into Debian. intrigeri, do you think it would be possible to get VeraCrypt Mounter into Debian if they grant permission like "we allow the software VeraCrypt Mounter and all derivatives to use the name "VeraCrypt" in its name and the VeraCrypt logo in its icon"?

Yes, please.

#27 Updated by intrigeri over 1 year ago

  • Priority changed from Normal to High

(Blocks merging feature/14481-TCRYPT-support-beta into devel.)

#28 Updated by intrigeri about 1 year ago

What is this ticket for now?

#29 Updated by intrigeri about 1 year ago

  • Parent task changed from #15043 to #14468

#30 Updated by intrigeri about 1 year ago

  • Related to Feature #15043: Iteration 4: Create VeraCrypt Mounter application added

#31 Updated by segfault about 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100
  • QA Check deleted (Dev Needed)

What is this ticket for now?

It was solved by #15787

Also available in: Atom PDF